REGEDIT pode não ser capaz de importar o registo com chaves grandes

Traduções de Artigos Traduções de Artigos
Artigo: 132064 - Ver produtos para os quais este artigo se aplica.
Importante: Este artigo contém informações sobre como editar o registo. Antes de editar o registo, certifique-se de que compreende como o restaurar se ocorrer um problema. Para obter informações sobre como efectuar este procedimento, consulte o tópico de ajuda "Restaurar o registo" no Regedit.exe ou o tópico de ajuda "Restaurar uma chave de registo" no Regedt32.exe.
Expandir tudo | Reduzir tudo

Sintomas

Quando tenta importar o registo utilizando o Editor de registo (Regedit.exe) em modo real, poderá receber uma das seguintes mensagens de erro:
  • Não é possível abrir registo (14) - System.dat
  • Erro ao aceder ao registo: O ficheiro pode não estar concluído.

Causa

O stub de modo real do Regedit.exe tem a capacidade de exportar, importar e criar ficheiros de registo. Regedit.exe utiliza a biblioteca de registo de modo real interno para efectuar estas tarefas. O código de modo real nesta biblioteca tiver determinados problemas com ficheiros de registo grande.

Por exemplo, se existirem muitas aplicações instaladas, HKEY_CLASSES_ROOT pode ser muito grande. Se uma das estruturas no ficheiro System.dat ocupa muito espaço na memória convencional, o registo não pode ser acedido.

Resolução

Aviso: A utilização incorrecta do Editor de registo pode provocar problemas graves que poderão forçar a reinstalação do sistema operativo. Microsoft não garante que os problemas resultantes da utilização incorrecta do Editor de registo possam ser resolvidos. As suas próprias risco da utilização do Editor de registo.

Para obter informações sobre como editar o registo, consulte o tópico de ajuda "Alterar chaves e valores" no Editor de registo (Regedit.exe) ou os tópicos de ajuda "Adicionar e eliminar informações no registo" e "Editar dados do registo" do Regedt32.exe. Nota efectuar uma que deve cópia de segurança do registo antes de o editar.

Para contornar este problema, utilize o Editor de registo no modo protegido.

Para obter informações sobre como importar o registo, consulte o tópico de ajuda "Importar o registo" no Editor de registo (Regedit.exe).

Ponto Da Situação

Microsoft confirmou que este seja um problema no Windows 95. Está a investigar este problema e publicará novas informações na base de dados de conhecimento da Microsoft como fica disponível.

Propriedades

Artigo: 132064 - Última revisão: 15 de novembro de 2006 - Revisão: 1.1
A informação contida neste artigo aplica-se a:
  • Microsoft Windows 95
Palavras-chave: 
kbmt kberrmsg kbusage KB132064 KbMtpt
Tradução automática
IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine translation ou MT), não tendo sido portanto revisto ou traduzido por humanos. A Microsoft tem artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais. O objectivo é simples: oferecer em Português a totalidade dos artigos existentes na base de dados do suporte. Sabemos no entanto que a tradução automática não é sempre perfeita. Esta pode conter erros de vocabulário, sintaxe ou gramática? erros semelhantes aos que um estrangeiro realiza ao falar em Português. A Microsoft não é responsável por incoerências, erros ou estragos realizados na sequência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza actualizações frequentes ao software de tradução automática (MT). Obrigado.
Clique aqui para ver a versão em Inglês deste artigo: 132064
Exclusão de Responsabilidade para Conteúdo sem Suporte na KB
Este artigo foi escrito sobre produtos para os quais a Microsoft já não fornece suporte. Por conseguinte, este artigo é oferecido "tal como está" e deixará de ser actualizado.

Submeter comentários

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com