ID do artigo: 133725 - Última revisão: segunda-feira, 7 de maio de 2007 - Revisão: 3.4

Comandos de menu ausentes na pasta de fontes

Dica do SistemaEste artigo aplica-se a um sistema operativo diferente do que está a utilizar. Foi desactivado o conteúdo do artigo, que pode não ser relevante para si.

Nesta página

Expandir tudo | Recolher tudo

Sintomas

Quando você abre a pasta fontes no Windows Explorer, os comandos a seguir podem sumir dos menus de pasta fontes. No menu arquivo :
  • Abrir
  • Impressão
  • Instalar nova fonte
No menu Exibir :
  • Listar fontes por similaridade
  • Ocultar variações (negrito, itálico, etc..)

Causa

Esse comportamento pode ocorrer para qualquer um dos seguintes motivos:
  • Os atributos de sistema e somente leitura não são definidos para a pasta fontes. A pasta Fonts deve ter seu sistema e definir atributos somente leitura para funcionar corretamente.
  • O arquivo Fontext.dll pode estar faltando ou danificado, fazendo com que os menus conter somente os comandos para uma pasta genérico.
  • O arquivo Desktop.ini pode estar ausente ou danificado. Observe que você não vir o arquivo Desktop.ini quando você exibir a pasta fontes. Para ver o arquivo, abra uma sessão de MS-DOS e exibir a pasta Windows\Fontes.

Resolução

Para restaurar os comandos corretos para a pasta fontes, execute estas etapas:
  1. Em um prompt de comando, alterne para a pasta Windows digitando o seguinte comando:
    cd\windows
    Observação : se o Windows estiver instalado em uma pasta diferente da pasta Windows, ajustar estas instruções de forma apropriada.
  2. Digite o seguinte comando:
    attrib + s + r fontes
  3. Desligue e reinicie o Windows.
Observação : você não é possível definir o atributo sistema para a pasta fontes na interface do usuário gráfica.

Se os comandos para a pasta fontes não forem restaurados, o arquivo Fontext.dll pode estar faltando ou danificado. Para substituir o arquivo Fontext.dll, use as etapas na seção apropriada abaixo.

O Windows 95/98

  1. Reinicie o Windows no modo MS-DOS.
  2. Altere para a pasta Windows\System.
  3. Se o arquivo Fontext.dll existir, renomeie-Fontext.old.
  4. Extraia uma nova cópia do arquivo Fontext.dll do CD-ROM ou discos originais do Windows para a pasta Windows\System.

    Para informações sobre como usar a ferramenta Extract, consulte o seguinte artigo na Base de dados de Conhecimento da Microsoft:
    129605  (http://support.microsoft.com/kb/129605/EN-US/ ) Como extrair arquivos originais compactados do Windows
  5. Reinicie o Windows normalmente.
Se o problema persistir, o arquivo Desktop.ini pode estar ausente ou danificado. Para substituir o arquivo Desktop.ini, execute essas etapas:
  1. Reinicie o Windows no modo MS-DOS.
  2. Altere para a pasta Windows\Fontes.
  3. Se o arquivo Desktop.ini existir, renomeie-Desktop.old.
  4. Extraia uma nova cópia do arquivo Desktop.ini do CD-ROM ou discos originais do Windows para a pasta Windows\Fontes.

    Para informações sobre como usar a ferramenta Extract, consulte o seguinte artigo na Base de dados de Conhecimento da Microsoft:
    129605  (http://support.microsoft.com/kb/129605/EN-US/ ) Como extrair arquivos originais compactados do Windows
  5. Reinicie o Windows normalmente.

Windows NT 4.0

  1. Em um prompt de comando, exclua o arquivo Desktop.ini na pasta Winnt\Fonts.
  2. Exclua o arquivo Fontext.dll na pasta Winnt\System32.
  3. Expanda um novo Desktop.ini arquivo da pasta I386 em seu CD-ROM original do Windows NT 4.0 para a pasta Fonts no seu disco rígido.
  4. Expanda um novo Fontext.dll arquivo da pasta I386 em seu CD-ROM original do Windows NT 4.0 para a pasta Winnt\System32 no seu disco rígido.

    Por exemplo, use o seguinte comando:
    expanda d:\i386\fontext.dl_ c:\winnt\system32\fontext.dll
  5. Reinicie o computador.


Windows 2000

  1. Inicialização no modo de segurança
  2. Renomear fontext.dll in a %systemroot%\System32 para fontext.old
  3. Renomear fontext.dll in a %SystemRoot%\System32\Dllcache para fontext.old
  4. Copie uma cópia extraída do arquivo fontext.dll para ambas as pastas.
  5. Reinicialize para o modo normal.

Mais Informações

A resolução listada neste artigo também pode resolver os seguintes sintomas:

  • Na guia TrueType está ausente quando no menu Exibir clique em Opções e, em seguida, abra a pasta fontes .
  • Fontes que são listadas na pasta fontes não estão disponíveis a serem selecionados dentro de programas.

A informação contida neste artigo aplica-se a:
  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows 2000 Professional Edition
  • Microsoft Windows 95
  • Microsoft Windows 98 Standard Edition
  • Microsoft Windows 98 Second Edition
  • Microsoft Windows NT Workstation 4.0 Developer Edition
  • Microsoft Windows NT Server 4.0 Standard Edition
  • Microsoft Windows Millennium Edition
Palavras-chave: 
kbmt kbfaq kbprb kbui KB133725 KbMtpt
Tradução automáticaTradução automática
IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine Translation ou MT), não tendo sido portanto traduzido ou revisto por pessoas. A Microsoft possui artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais, com o objetivo de oferecer em português a totalidade dos artigos existentes na base de dados de suporte. No entanto, a tradução automática não é sempre perfeita, podendo conter erros de vocabulário, sintaxe ou gramática. A Microsoft não é responsável por incoerências, erros ou prejuízos ocorridos em decorrência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza atualizações freqüentes ao software de tradução automática (MT). Obrigado.
Clique aqui para ver a versão em Inglês deste artigo: 133725  (http://support.microsoft.com/kb/133725/en-us/ )