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Missing TrueType Fonts in Fonts Folder or Programs

Article ID:133732
Last Review:January 19, 2007
Revision:2.3
This article was previously published under Q133732
IMPORTANT: This article contains information about editing the registry. Before you edit the registry, you should first make a backup copy of the registry files (System.dat and User.dat). Both are hidden files in the Windows folder.
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SYMPTOMS

You may notice one or more of the following symptoms:
TrueType fonts may not be present in the Fonts folder.
You may receive the following error message if you try to add a TrueType font:
The <fontname> TrueType font is already installed. To install a new version, first remove the old version.
TrueType fonts are not listed in any program.
Previously created documents are printed differently or the formatting is changed when you view the document.
When you print a document, the text may appear smaller than expected.
Custom desktop settings have changed fonts.

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CAUSE

The registry key that lists TrueType fonts may be damaged or missing.

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RESOLUTION

To resolve this issue, use the appropriate method:

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Use the Fontreg Tool

Running Fontreg.exe adds a registry key that allows the installation of TrueType fonts. To run Fontreg.exe and install the fonts, follow these steps:

NOTE: The Fontreg tool (Fontreg.exe) is not included with Windows NT 4.0. To use this tool in Windows NT 4.0, copy the Fontreg.exe file from a Windows 95/98-based computer.
1.Click the Start button, and then click Run.
2.Type fontreg in the Open box, and then click OK.
3.In Control Panel, double-click Fonts.
4.On the File menu, click Install New Font.
5.In the Folders box, select the folder that contains the TrueType fonts (usually Windows\Fonts).
6.Click Select All, and then click OK.
7.If your documents are not printed as you expect, remove and reinstall the appropriate printer driver.

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Edit the Fonts Registry Key

WARNING: Using Registry Editor incorrectly can cause serious problems that may require you to reinstall Windows 95/98 or Windows NT. Microsoft cannot guarantee that problems resulting from the incorrect use of Registry Editor can be solved. Use Registry Editor at your own risk.

NOTE: For information about how to edit the registry, view the Changing Keys And Values online Help topic in Registry Editor (Regedit.exe). Note that you should make a backup copy of the registry files (System.dat and User.dat) before you edit the registry.

To replace a missing or damaged Fonts key in the registry, follow these steps:
1.Move the contents of the Fonts folder to an empty folder.
2.If the Fonts key exists in the following registry setting, delete the Fonts key and then add it again:

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Windows 95/98:

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion

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Windows NT:

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion

If the Fonts key does not exist in the registry setting listed above, add the following key:
Fonts
3.In Control Panel, double-click Fonts.
4.On the Fonts menu, click Install New Font.
5.In the Folders box, select the folder you moved the fonts to in step 1.
6.Click Select All, and then click OK.
7.If your documents are not printing as expected, remove and reinstall the appropriate printer driver.

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MORE INFORMATION

Note that Windows 95/98 has a limit of approximately 1000 fonts.

For additional information about this font limitation, see the following article in the Microsoft Knowledge Base:
ARTICLE-ID: 131943 (http://support.microsoft.com/kb/131943/EN-US/)
TITLE : TrueType Font Limits in Windows 95

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APPLIES TO
Microsoft Windows 95
Microsoft Windows 98 Standard Edition
Microsoft Windows NT Server 4.0 Standard Edition
Microsoft Windows NT Workstation 4.0 Developer Edition
Microsoft Windows 98 Second Edition
Microsoft Windows Millennium Edition

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Keywords: 
kberrmsg kbprb kbprint KB133732

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