Fehlende TrueType-Schriften im Schriftartenordner oder Programmen

SPRACHE AUSWÄHLEN SPRACHE AUSWÄHLEN
Artikel-ID: 133732 - Produkte anzeigen, auf die sich dieser Artikel bezieht
Dieser Artikel wurde zuvor veröffentlicht unter D35656
Dieser Artikel ist eine Übersetzung des folgenden englischsprachigen Artikels der Microsoft Knowledge Base:
133732 Missing TrueType Fonts in Fonts Folder or Programs
Alles erweitern | Alles schließen

Zusammenfassung

WARNUNG:
Dieser Artikel enthält Informationen zum Bearbeiten der Registierdatenbank. Bevor Sie die Registrierung bearbeiten, erstellen Sie eine Sicherungskopie der Dateien SYSTEM.DAT und USER.DAT. Vergewissern Sie sich, dass Sie die Registrierung wiederherstellen können, wenn ein Problem auftritt. Informationen hierzu finden Sie unter dem Hilfethema "Wiederherstellen der Registrierung" in "Regedit.exe" oder unter "Wiederherstellen eines Registrierungsschlüssels" in "Regedt32.exe".

Problembeschreibung

Sie bemerken möglicherweise eines oder mehrere der folgenden Symptome:
  1. Fehlende TrueType-Schriftarten im Schriftartenordner.
  2. Wenn Sie versuchen, eine TrueType-Schriftart hinzuzufügen, wird folgende Fehlermeldung angezeigt:
       "Die TrueType-Schriftart <Schriftartname> ist bereits installiert.
        Entfernen Sie zum Installieren der neuen Schriftart die alte Version."
  3. In irgendeinem Programm sind TrueType-Schriftarten nicht aufgelistet.
  4. Zuvor erstellte Dokumente werden anders ausgedruckt oder die Formatierung wird geändert, wenn Sie das Dokument einsehen.
  5. Wenn Sie ein Dokument ausdrucken, erscheint der Text kleiner als erwartet.
  6. Benutzerdefinierte Desktop-Einstellungen haben Schriftarten geändert.

Ursache

Der Registrierungsschlüssel, in dem die TrueType-Schriftarten aufgelistet sind, ist beschädigt oder nicht vorhanden.

Lösung

Um dieses Problem zu beheben, verwenden Sie das jeweils anwendbare der nachstehenden Verfahren:

Ausführen des Hilfsprogramms "Fontreg"

Durch das Ausführen der Fontreg.exe wird ein Registrierungsschlüssel hinzugefügt, der die Installation von TrueType-Schriftarten ermöglicht. Zum Ausführen der Fontreg.exe und zur Installation der Schriftarten führen Sie folgende Schritte durch:

HINWEIS: Das Hilfsprogramm "Fontreg" (Fontreg.exe) ist in Windows NT 4.0 nicht enthalten. Um dieses Hilfsprogramm in Windows NT 4.0 einzusetzen, kopieren Sie die Datei Fontreg.exe von einem Computer auf Windows 95/98-Basis.
  • Klicken Sie auf "Start" und dann auf "Ausführen".
  • Geben Sie "fontreg" (ohne Anführungszeichen) in das Feld "Öffnen" ein und klicken Sie dann auf "OK".
  • Klicken Sie in der Systemsteuerung doppelt auf "Schriftarten".
  • Im Menü "Datei" klicken Sie auf "Neue Schriftart installieren".
  • Im Feld "Ordner" wählen Sie den Ordner aus, in dem die TrueType-Schriftarten gespeichert sind (in der Regel der Ordner Windows\Fonts).
  • Klicken Sie auf "Alle auswählen" und dann auf "OK".
  • Werden Ihre Dokumente nicht so ausgedruckt, wie Sie es erwartet haben, entfernen Sie den entsprechenden Druckertreiber und installieren Sie diesen neu.
Bearbeiten des Schriftarten-Registrierungsschlüssels

Um einen fehlenden oder beschädigten Schriftartenschlüssel in der Registrierung zu ersetzen, führen Sie folgende Schritte durch:
  1. Verschieben Sie den Inhalt des Schriftartenordners in einen leeren Ordner.
  2. Existiert der Schriftartenschlüssel in der nachstehend aufgeführten Registrierungseinstellung, löschen Sie diesen Schlüssel und fügen Sie ihn danach wieder hinzu:
Windows 95/98:
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion

Windows NT:
   HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion
Ist der Schriftartenschlüssel in den vorstehend aufgeführten Registrierungseinstellungen nicht vorhanden, fügen Sie folgenden Schlüssel hinzu:
   Fonts
3. Klicken Sie in der Systemsteuerung doppelt auf "Schriftarten".
  1. Im Menü "Schriftarten" klicken Sie auf "Neue Schriftart installieren".
  2. Im Feld "Ordner" wählen Sie den Ordner aus, in den Sie in Schritt 1 die Schriftarten verschoben haben.
  3. Klicken Sie auf "Alle auswählen" und dann auf "OK".
  4. Werden Ihre Dokumente nicht so ausgedruckt, wie Sie es erwartet haben, entfernen Sie den entsprechenden Druckertreiber und installieren Sie diesen neu.

Weitere Informationen

Beachten Sie, daß für Windows 95/98 eine Beschränkung auf ca. 1000 Schriftarten gilt.

Für weitere Informationen über Beschränkungen der Anzahl an Schriftarten lesen Sie bitte den folgenden Artikel in der Microsoft Knowledge Base:
   ARTIKEL-ID: D35567
   TITEL     : Beschränkung der Anzahl an TrueType-Schriftarten in Windows 95/98
Microsoft kann keine Gewährleistungen oder Support für Probleme übernehmen, welche durch eine Manipulation der Windows oder Windows NT Registrierdatenbank verursacht wurden. Es ist Ihr eigenes Risiko, den Windows oder Windows NT Registriereditor Regedit.exe oder ähnliche Werkzeuge zur Manipulation der Windows oder Windows NT Registrierdatenbank zu verwenden.

Bitte beachten Sie: Bei diesem Artikel handelt es sich um eine Übersetzung aus dem Englischen. Es ist möglich, daß nachträgliche Änderungen bzw. Ergänzungen im englischen Originalartikel in dieser Übersetzung nicht berücksichtigt sind. Die in diesem Artikel enthaltenen Informationen basieren auf der/den englischsprachige(n) Produktversion(en). Die Richtigkeit dieser Informationen in Zusammenhang mit anderssprachigen Produktversionen wurde im Rahmen dieser Übersetzung nicht getestet. Microsoft stellt diese Informationen ohne Gewähr für Richtigkeit bzw. Funktionalität zur Verfügung und übernimmt auch keine Gewährleistung bezüglich der Vollständigkeit oder Richtigkeit der Übersetzung.

Eigenschaften

Artikel-ID: 133732 - Geändert am: Montag, 27. Dezember 2004 - Version: 2.1
Die Informationen in diesem Artikel beziehen sich auf:
  • Microsoft Windows 95
  • Microsoft Windows 98 Standard Edition
  • Microsoft Windows NT Server 4.0 Standard Edition
  • Microsoft Windows NT Workstation 4.0 Developer Edition
  • Microsoft Windows 98 Second Edition
Keywords: 
kberrmsg KB133732
Microsoft stellt Ihnen die in der Knowledge Base angebotenen Artikel und Informationen als Service-Leistung zur Verfügung. Microsoft übernimmt keinerlei Gewährleistung dafür, dass die angebotenen Artikel und Informationen auch in Ihrer Einsatzumgebung die erwünschten Ergebnisse erzielen. Die Entscheidung darüber, ob und in welcher Form Sie die angebotenen Artikel und Informationen nutzen, liegt daher allein bei Ihnen. Mit Ausnahme der gesetzlichen Haftung für Vorsatz ist jede Haftung von Microsoft im Zusammenhang mit Ihrer Nutzung dieser Artikel oder Informationen ausgeschlossen.

Ihr Feedback an uns

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com