I tipi di carattere TrueType non sono presenti nella cartella Fonts o nei programmi

Traduzione articoli Traduzione articoli
Identificativo articolo: 133732 - Visualizza i prodotti a cui si riferisce l?articolo.
Questo articolo è stato precedentemente pubblicato con il codice di riferimento I133732
IMPORTANTE: in questo articolo sono contenute informazioni su come modificare il Registro di configurazione. Prima di apportare modifiche al Registro di configurazione, si consiglia di eseguire una copia di backup dei file del Registro di configurazione, System.dat e User.dat. Entrambi sono file nascosti contenuti nella cartella Windows.
Espandi tutto | Chiudi tutto

In questa pagina

Sintomi

È possibile che si verifichi uno o più dei seguenti sintomi:
  • I tipi di carattere TrueType non sono presenti nella cartella Fonts.
  • Quando si tenta di aggiungere un tipo di carattere TrueType, è possibile che venga visualizzato il seguente messaggio di errore:
    Il tipo di carattere TrueType <nome carattere> è già installato. Prima di installare una nuova versione del tipo di carattere rimuovere quella vecchia.
  • I tipi di carattere TrueType non sono elencati in alcun programma.
  • I documenti creati precedentemente vengono stampati con caratteri diversi oppure formattati diversamente quando si tenta di visualizzarli.
  • Quando si stampa un documento, la dimensione del testo è inferiore rispetto al previsto.
  • Le impostazioni personalizzate del desktop utilizzano tipi di carattere diversi.

Cause

È possibile che la chiave di registro che elenca i tipi di carattere TrueType sia danneggiata o mancante.

Risoluzione

Per risolvere il problema, utilizzare il metodo appropriato:

Utilizzo dello strumento Fontreg

Eseguendo Fontreg.exe è possibile aggiungere una chiave di registro che consente di installare i tipi di carattere TrueType. Per eseguire Fontreg.exe e installare i caratteri, attenersi alla seguente procedura:

NOTA: lo strumento Fontreg (Fontreg.exe) non è incluso in Windows NT 4.0. Per utilizzare questo strumento in Windows NT 4.0, copiare il file Fontreg.exe da un computer che esegue Windows 95/98.
  1. Fare clic sul pulsante Start/Avvio e scegliere Esegui.
  2. Digitare fontreg nella casella Apri, quindi scegliere OK.
  3. Nel Pannello di controllo fare doppio clic su Fonts.
  4. Scegliere Installa nuovo tipo di carattere dal menu File.
  5. Nella casella Cartelle selezionare la cartella contenente i tipi di carattere TrueType, solitamente la cartella Windows\Fonts.
  6. Fare clic su Seleziona tutto, quindi scegliere OK.
  7. Se i documenti non vengono stampati nel modo desiderato, rimuovere e reinstallare il driver della stampante appropriato.

Modifica della chiave di registro relativa ai tipi di carattere

ATTENZIONE: l'utilizzo non corretto dell'Editor del Registro di configurazione può causare seri problemi che potrebbero richiedere la reinstallazione del sistema operativo Windows 95/98 o Windows NT. Microsoft non garantisce che i problemi derivanti dall'errato utilizzo dell'Editor del Registro di configurazione possano essere risolti. L'utilizzo dell'Editor del Registro è a rischio e pericolo dell'utente.

NOTA: per informazioni su come modificare il Registro di configurazione, leggere l'argomento della Guida in linea "Modifica di chiavi e valori" nell'Editor del registro di configurazione (Regedit.exe). È consigliabile fare una copia dei file del Registro (System.dat e User.dat) prima di modificarlo.

Per sostituire nel Registro di configurazione la chiave danneggiata o mancante relativa ai tipi di carattere, attenersi alla seguente procedura:
  1. Spostare il contenuto della cartella Fonts in una cartella vuota.
  2. Se la chiave dei tipi di carattere è già presente nell'impostazione di registro riportata di seguito, eliminarla e aggiungerla nuovamente:

    Windows 95/98:

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion

    Windows NT:

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion


    Se la chiave relativa ai tipi di caratteri non è presente nell'impostazione di registro elencata in precedenza, aggiungere la seguente chiave:
    Fonts
  3. Nel Pannello di controllo fare doppio clic sulla cartella Fonts.
  4. Scegliere Installa nuovo tipo di carattere dal menu File.
  5. Nella casella Cartelle selezionare la cartella in cui sono stati copiati i tipi di carattere al passaggio 1.
  6. Fare clic su Seleziona tutto, quindi scegliere OK.
  7. Se i documenti non vengono stampati come desiderato, rimuovere e reinstallare il driver della stampante appropriato.

Informazioni

Si noti che Windows 95/98 prevede un limite massimo di circa 1000 tipi di carattere.

Per ulteriori informazioni sul limite massimo di tipi di carattere, vedere il seguente articolo della Microsoft Knowledge Base (informazioni in lingua inglese):
ID ARTICOLO: 131943
TITOLO: TrueType Font Limits in Windows 95

Proprietà

Identificativo articolo: 133732 - Ultima modifica: mercoledì 29 dicembre 2004 - Revisione: 3.1
Le informazioni in questo articolo si applicano a
  • Microsoft Windows 95
  • Microsoft Windows 98 Standard Edition
  • Microsoft Windows NT Server 4.0 Standard Edition
  • Microsoft Windows NT Workstation 4.0 Developer Edition
  • Microsoft Windows 98 Second Edition
Chiavi: 
kberrmsg kbprint kbprb winttf KB133732
LE INFORMAZIONI CONTENUTE NELLA MICROSOFT KNOWLEDGE BASE SONO FORNITE SENZA GARANZIA DI ALCUN TIPO, IMPLICITA OD ESPLICITA, COMPRESA QUELLA RIGUARDO ALLA COMMERCIALIZZAZIONE E/O COMPATIBILITA' IN IMPIEGHI PARTICOLARI. L'UTENTE SI ASSUME L'INTERA RESPONSABILITA' PER L'UTILIZZO DI QUESTE INFORMAZIONI. IN NESSUN CASO MICROSOFT CORPORATION E I SUOI FORNITORI SI RENDONO RESPONSABILI PER DANNI DIRETTI, INDIRETTI O ACCIDENTALI CHE POSSANO PROVOCARE PERDITA DI DENARO O DI DATI, ANCHE SE MICROSOFT O I SUOI FORNITORI FOSSERO STATI AVVISATI. IL DOCUMENTO PUO' ESSERE COPIATO E DISTRIBUITO ALLE SEGUENTI CONDIZIONI: 1) IL TESTO DEVE ESSERE COPIATO INTEGRALMENTE E TUTTE LE PAGINE DEVONO ESSERE INCLUSE. 2) I PROGRAMMI SE PRESENTI, DEVONO ESSERE COPIATI SENZA MODIFICHE, 3) IL DOCUMENTO DEVE ESSERE DISTRIBUITO INTERAMENTE IN OGNI SUA PARTE. 4) IL DOCUMENTO NON PUO' ESSERE DISTRIBUITO A SCOPO DI LUCRO.

Invia suggerimenti

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com