PC DirSync: Message d'erreur : irrécupérable [7] Erreur de modification du nom de fichier

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Symptômes

Au cours d'un bureau de poste synchronisation d'annuaire (Dir-Sync), le DIRSYNC.LOG peuvent indiquer les erreurs suivantes :
06/12/95 16:52:14 | État Microsoft (R) Mail Importer V3.2a
06/12/95 16:52:23 | Erreur Fatal [7] modification du nom de fichier : M:INF\IMPORT.INF
ou
08/06/94 02:47:52 | État Microsoft (R) Importation du courrier V3.2.6
08/06/94 13 : 03 : 25 | Erreur Fatal [7] modification du nom de fichier : M:USR\IMPORT.USR

Cause

En général, IMPORT.EXE génère le message d'erreur ci-dessus lorsqu'il est impossible de renommer le fichier IMPORT.* temporaire pour le <hexid>.inf approprié ou le fichier .USR de <hexid>.

Résolution

En règle générale, cette impossibilité de renommer correctement les fichiers est dû en ce fichier particulier (INF ou USR) cours inaccessible pour une raison quelconque. Ces raisons peuvent inclure une des opérations suivantes :
  • Le fichier INF est verrouillé en ouverture.
  • Le compte d'utilisateur connecté au réseau et l'exécution de la synchronisation Dir processus (DISPATCH.EXE) n'a pas de droits suffisants pour le bureau de poste ou ses sous-répertoires.
  • Descripteurs de fichiers insuffisants dans le config.sys de l'ordinateur MS-DOS qui exécute le processus DISPATCH.EXE.
  • Un ou plusieurs fichiers INF (ou USR) dans le sous-répertoire INF est marqué en lecture seule.
  • Un antivirus fonctionne en «temps réel» sur le serveur.
  • En raison des verrous optionnels sur le serveur Windows NT, les lectures et écritures sont mis en cache. Suppression verrouillage opportuniste sur le serveur Windows NT rencontre le 7 irrécupérable a été identifiée pour résoudre ce problème. Pour supprimer ne l'utilisation de serveur Regedt32.exe et modifiez la clé suivante ;
    Avertissement: À l'aide de l'Éditeur du Registre incorrecte peut provoquer des problèmes sérieuses au niveau du système, pouvant vous obliger à réinstaller Windows NT. Microsoft ne peut pas garantir que les problèmes résultant de l'utilisation de l'Éditeur du Registre puissent être résolus. Utilisez cet outil à vos risques et périls.
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\LanmanServer \Parameters

Plus d'informations

Tout bureau de poste unique fait référence à chacun des bureaux de poste externe défini par un identificateur hexadécimal (hex-id). Par exemple, un bureau de poste particulier peut faire référence à un autre bureau de poste en identifiant avec l'id hexadécimal de 00000005. Par conséquent, les fichiers MBG et KEY pour tous les messages à ce bureau de poste externe défini sortants seront 00000005.MBG et 00000005.KEY. La liste des utilisateurs externes existera dans 00000005.USR et toute information de modèle existeront dans 00000005.TPL et 00000005.INF (le format de modèle et les informations de fichiers, respectivement). Chacun de ces fichiers résideront dans leurs sous-répertoires appropriés.

Lorsque IMPORT.EXE traite au cours du cycle de synchronisation de répertoire, il crée des fichiers temporaires pour stocker les fichiers mis à jour terminées ; deux exemples de ces fichiers temporaires sont les fichiers IMPORT.INF et IMPORT.USR. Une fois le processus est terminé, IMPORT.EXE tentera de renommer le fichier temporaire pour le nom de fichier réel. IMPORT.EXE serait dans ce cas, tentez d'affecter IMPORT.INF 00000005.INF ou IMPORT.USR à 00000005.USR. Les messages d'erreur mentionnés ci-dessus sont générées dans le DIRSYNC.LOG si ce processus de changement de nom ne peut pas être effectué.

Remarque : L'erreur irrécupérable 7 est souvent suivi plusieurs messages d'avertissement 90. Une fois le processus de synchronisation Dir se termine et une de ces messages d'erreur est générée, le fichier IMPORT.INF ou IMPORT.USR peut-être exister dans le sous-répertoire INF ou USR. L'administrateur de messagerie souhaiterez peut-être essayer de terminer le processus de synchronisation de répertoire manuellement.

Tout d'abord, assurez-vous qu'aucune des problèmes répertoriés ci-dessus existe sur ce bureau de poste. Ensuite, exécutez une importation manuelle en tapant dans la commande suivante sur le bureau de poste du problème :
<lecteur>ADMIN -P <mot_passe> <drive><password>IMPORT -D -Y -Q
Si IMPORT.EXE s'exécute sans erreur, le problème devrait être résolu sur ce bureau de poste.

Propriétés

Numéro d'article: 134228 - Dernière mise à jour: jeudi 23 janvier 2014 - Version: 1.1
Les informations contenues dans cet article s'appliquent au(x) produit(s) suivant(s):
  • Microsoft Mail for PC Networks 3.0
  • Microsoft Mail for PC Networks 3.2
  • Microsoft Mail for PC Networks 3.2a
  • Microsoft Mail for PC Networks 3.5
Mots-clés : 
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