Article ID: 135962 - Last Review: January 19, 2007 - Revision: 1.2 Disk Tools Run by System Agent Pause for User InputThis article was previously published under Q135962
IMPORTANT: This article contains information about editing the registry.
Before you edit the registry, you should first make a backup copy of the
registry files (System.dat and User.dat). Both are hidden files in the
Windows folder.
On This PageSYMPTOMS
When System Agent runs one of the disk tools (Compression Agent, Disk
Defragmenter, or ScanDisk), the tool may pause for user input. Typically,
the tool is prompting for the drive on which it should run, or is waiting
for you to click the Start button.
CAUSE
This behavior can occur if the System Agent-aware registry settings for the
disk tool are missing or damaged. If the disk tool does not have valid
registry settings, System Agent does not start the disk tool in unattended
operation mode.
RESOLUTION
Use Registry Editor to verify that the correct registry settings exist for
the disk tool. The System Agent-aware registry settings are located in the
following registry branch:
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Plus!\System Agent\SAGE
Compression AgentType Name Data -------------------------------------------------- String Value Friendly Name Compression Agent String Value Program CMPAGENT.EXE Binary Value Settings 01 Disk DefragmenterType Name Data -------------------------------------------------- String Value Friendly Name Disk Defragmenter String Value Program DEFRAG.EXE Binary Value Settings 01 Low Disk Space NotificationType Name Data ------------------------------------------------------------ String Value Friendly Name Low disk space notification String Value Program DISKALM.EXE Binary Value Settings 01 ScanDisk for WindowsType Name Data ----------------------------------------------------- String Value Friendly Name ScanDisk for Windows String Value Program SCANDSKW.EXE Binary Value Settings 01 WARNING: Using Registry Editor incorrectly can cause serious problems that may require you to reinstall Windows 95. Microsoft cannot guarantee that problems resulting from the incorrect use of Registry Editor can be solved. Use Registry Editor at your own risk. NOTE: You can also restore these settings by reinstalling System Agent. For information about reinstalling System Agent without losing your current System Agent settings, please see the following article in the Microsoft Knowledge Base: 133191
(http://support.microsoft.com/kb/133191/EN-US/
)
Reinstalling System Agent Without Losing Scheduled Tasks
MORE INFORMATION
In addition to the settings listed above, each key contains a Result Codes
subkey. The Result Codes subkey is not required to make a tool System Agent-
aware, but without these settings the Last Result column in System Agent
and the System Agent log file contains only code numbers. The following
tables list the result code settings for each disk tool. All of these
settings are String Values.
Compression Agent\Result Codes
Name Data
------------------------------------------------------------------
0 Completed Successfully
1 Some files could not be optimized, due to low disk space
2 Unsuccessful; not enough free space
3 The process was interrupted before completing
4 Unsuccessful; drive contains errors
5 Unsuccessful; error reading from drive
6 Unsuccessful; error writing to drive
9 Unsuccessful; not enough memory
10 Unsuccessful; drive was invalid
11 Unsuccessful; no DriveSpace 3 drives found
15 Unsuccessful; disk was write-protected
26 Unsuccessful; could not access drive
105 Unsuccessful; drive was locked
106 Unsuccessful; could not access drive
108 Unsuccessful; could not access drive
109 Unsuccessful; 32-bit compression driver not installed
249 One or more drives could not be recompressed
Success 1
Disk Defragmenter\Result Codes
Name Data
---------------------------------------------------------------
0 Completed Successfully
2 Unsuccessful; not enough free space
3 The process was interrupted before completing
4 Unsuccessful; drive contains errors
5 Unsuccessful; error reading from drive
6 Unsuccessful; error writing to drive
9 Unsuccessful; not enough memory
10 Unsuccessful; the drive was invalid
15 Unsuccessful; disk was write-protected
26 Unsuccessful; could not access drive
105 Unsuccessful; drive was locked
106 Unsuccessful; could not access drive
108 Unsuccessful; could not access drive
109 Unsuccessful; 32-bit compression driver not installed
249 One or more drives could not be defragmented
Success 0
Low Disk Space Notification\Result CodesName Data -------------------------------- 0 Completed Successfully Success 0 ScanDisk for Windows\Result Codes
Name Data
----------------------------------------------------------
0 No errors found
1 Errors found and all were fixed
249 One or more drives could not be checked
250 Drive could not be checked - could not load
or find DSKMAINT.DLL
251 Drive could not be checked - insufficient memory
252 Errors were found and some were not fixed
254 Check was canceled
255 Check was stopped because of an error
Success 1
| Article Translations
|

Back to the top
