Artigo: 139063 - Última revisão: sexta-feira, 19 de Janeiro de 2007 - Revisão: 2.3

Mensagem de erro: Falha de inicializaçao do dispositivo VFAT

Dica do SistemaEste artigo aplica-se a um sistema operativo diferente do que está a utilizar. Foi desactivado o conteúdo do artigo, que pode não ser relevante para si.
importante Este artigo contém informações que mostra a ajuda de definições de segurança mais baixas ou como desactivar as funcionalidades de segurança num computador. Pode efectuar estas alterações para contornar um problema específico. Antes de efectuar estas alterações, recomendamos que avalie os riscos associados à implementação desta solução alternativa no seu ambiente específico. Se implementar esta solução alternativa, tome medidas adicionais adequadas para proteger o seu sistema.

Nesta página

Expandir tudo | Reduzir tudo

Sintomas

Quando inicia o Windows, poderá receber a seguinte mensagem de erro num ecrã azul:
Não foi possível a inicializaçao do dispositivo VFAT

Um dispositivo ou recurso requerido pelo VFAT não está presente ou não está disponível. VFAT não pode continuar a carregar.

Sistema parado.

Causa

Este problema pode ocorrer em qualquer uma das seguintes condições:
  • Se o ficheiro ifshlp.sys estiver em falta a partir do Windows pasta.

    - ou
  • Se o ficheiro Config.sys contiver uma linha que aponta para uma versão anterior do ficheiro ifshlp.sys.

    - ou -
  • Se a seguinte instrução de ifshlp.sys for eliminada do ficheiro Config.sys depois de reinstalar o Windows:
    DEVICE=C:\Windows\Ifshlp.sys
    - ou -
  • Se a secção [Paths] o ficheiro Msdos.sys está incorrecto.

    - ou -
  • Se existir um ficheiro Winboot.ini de uma instalação incompleta anterior na pasta raiz do disco de arranque.

    - ou -
  • Se um "maxfilecache = 4096" linha está presente no ficheiro System.ini.

Resolução

aviso Esta medida pode tornar o computador ou a rede mais vulnerável a ataques de utilizadores mal intencionados ou software malicioso como vírus. A Microsoft não recomenda esta medida, mas fornece estas informações para que o utilizador pode implementá-la à sua própria responsabilidade. Usar esta solução por sua conta e risco.

Nota Um programa antivírus foi concebido para ajudar a proteger o computador contra vírus. Não tem de transferir ou abrir ficheiros de fontes não fidedignas, visitar Web sites que não confia ou abrir anexos de correio electrónico quando o programa antivírus estiver desactivado.

Para obter informações adicionais sobre vírus informáticos, clique no número de artigo que se segue para visualizar o artigo na Microsoft Knowledge Base:
129972  (http://support.microsoft.com/kb/129972/ ) Vírus informáticos: Descrição, prevenção e recuperação
Para resolver o problema, utilize um dos seguintes métodos.

Ficheiro ifshlp.sys em falta da pasta Windows

Se o ficheiro ifshlp.sys estiver em falta a partir da pasta Windows, extraia uma cópia nova do ficheiro do CD-ROM ou disquetes Windows originais para a pasta Windows.

Para obter informações sobre como utilizar a ferramenta Extract, consulte o seguinte artigo na base de dados de conhecimento da Microsoft:
129605  (http://support.microsoft.com/kb/129605/EN-US/ ) Como extrair ficheiros originais comprimidos do Windows

Os pontos de ficheiro Config.sys para uma versão anterior do ficheiro ifshlp.sys

  1. Windows 95

    Reinicie o computador. Quando visualiza a mensagem "iniciar o Windows 95", prima F8 e seleccione a opção Apenas linha de comandos em modo de segurança no menu de arranque .

    Windows 98

    Reiniciar o computador, prima e mantenha premida a tecla CTRL após o computador concluir o procedimento POST (Power On Self Test) e, em seguida, seleccione a opção Apenas linha de comandos em modo de segurança no menu de arranque.
  2. Utilize um editor de texto (tal como o Edit.com) para abrir o Config.sys ficheiro.
  3. Elimine a linha que carrega o ficheiro ifshlp.sys. Tenha em atenção que Windows carrega automaticamente este controlador quando iniciar o computador.
  4. Guarde e feche o ficheiro Config.sys.
  5. Reinicie o computador.

Declaração ifshlp.sys foram eliminada do ficheiro Config.sys depois É Windows reinstalados

Quando reinstalar o Windows, a instrução ifshlp.sys é eliminada do ficheiro Config.sys e não é substituído. Para adicionar o ifshlp.sys instrução para o ficheiro Config.sys:
  1. Windows 95

    Reinicie o computador. Quando visualiza a mensagem "iniciar o Windows 95", prima F8 e seleccione a opção Apenas linha de comandos em modo de segurança no menu de arranque .

    Windows 98

    Reinicie o computador, prima e mantenha premida a tecla CTRL após o computador concluir o procedimento POST (Power On Self Test) e, em seguida, seleccione a opção Apenas linha de comandos em modo de segurança no menu de arranque de.
  2. Utilize um editor de texto (tal como o Edit.com) para abrir o Config.sys ficheiro.
  3. Escreva a seguinte linha no ficheiro Config.sys:
    DEVICE=C:\Windows\Ifshlp.sys
  4. Guarde e feche o ficheiro Config.sys.
  5. Reinicie o computador.

Secção [Paths] incorrecta no ficheiro Msdos.sys

  1. Windows 95

    Reinicie o computador. Quando visualiza a mensagem "iniciar o Windows 95", prima F8 e seleccione a opção Apenas linha de comandos em modo de segurança no menu de arranque .

    Windows 98

    Reinicie o computador, prima e mantenha premida a tecla CTRL após o computador concluir o procedimento POST (Power On Self Test) e, em seguida, seleccione a opção Apenas linha de comandos em modo de segurança no menu de arranque de.
  2. Escreva o seguinte comando numa linha de comandos:
    attrib -s-h-r msdos.sys
  3. Utilize um editor de texto (tal como o Edit.com) para abrir o Msdos.sys ficheiro.
  4. Verifique se as seguintes linhas Msdos.sys ficheiro corrigir WinDir [Paths] = Windows WinBootDir = Windows HostWinBootDrv = C em que o Windows é a pasta que contém o Windows. Nota que se estiver a utilizar software de compressão de disco, tem de alterar a letra de unidade a HostWinBootDrv = linha para a letra da unidade anfitriã.
  5. Guarde e feche o ficheiro Msdos.sys.
  6. Escreva a seguinte linha numa linha de comandos:
    attrib + s + h + r msdos.sys
  7. Reinicie o computador.

Winboot.ini ficheiros presente na pasta raiz da unidade de arranque

  1. Windows 95

    Reinicie o computador. Quando visualiza a mensagem "iniciar o Windows 95", prima F8 e seleccione a opção Apenas linha de comandos em modo de segurança no menu de arranque .

    Windows 98

    Reinicie o computador, prima e mantenha premida a tecla CTRL após o computador concluir o procedimento POST (Power On Self Test) e, em seguida, seleccione a opção Apenas linha de comandos em modo de segurança no menu de arranque de.
  2. Escreva deltree winboot.ini uma linha de comandos para eliminar o ficheiro Winboot.ini na pasta raiz da unidade de arranque e, em seguida, prima ENTER.
  3. Reinicie o computador.

Existe um "maxfilecache = 4096" linha no ficheiro System.ini

Utilize qualquer editor de texto (tal como o bloco de notas) para abrir o ficheiro System.ini na pasta Windows. Escreva um ponto e vírgula () no início do "maxfilecache = 4096" linha, guardar o ficheiro, feche o ficheiro e, em seguida, reinicie o computador.

Mais Informação

Para obter informações adicionais sobre como determinar a pasta Windows está instalado, clique no número de artigo existente abaixo para visualizar o artigo na base de dados de conhecimento da Microsoft:
305792  (http://support.microsoft.com/kb/305792/EN-US/ ) Como determinar a pasta Windows está instalado

A informação contida neste artigo aplica-se a:
  • Microsoft Windows 95
  • Microsoft Windows 98 Standard Edition
Palavras-chave: 
kbmt kbenv kberrmsg kbfaq kbfile kbprb KB139063 KbMtpt
Tradução automáticaTradução automática
IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine translation ou MT), não tendo sido portanto revisto ou traduzido por humanos. A Microsoft tem artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais. O objectivo é simples: oferecer em Português a totalidade dos artigos existentes na base de dados do suporte. Sabemos no entanto que a tradução automática não é sempre perfeita. Esta pode conter erros de vocabulário, sintaxe ou gramática? erros semelhantes aos que um estrangeiro realiza ao falar em Português. A Microsoft não é responsável por incoerências, erros ou estragos realizados na sequência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza actualizações frequentes ao software de tradução automática (MT). Obrigado.
Clique aqui para ver a versão em Inglês deste artigo: 139063  (http://support.microsoft.com/kb/139063/en-us/ )