BUG: MCI Unable to Open .AVI File Using File-Interface Pointer

Article translations Article translations
Article ID: 140750 - View products that this article applies to.
This article was previously published under Q140750
Expand all | Collapse all

On This Page

SYMPTOMS

When you attempt to use MCI to access an .avi file by using its reference pointer returned from AVIFileOpen(), the following error message occurs under Windows 95:
mmsystem 275: CANNOT FIND THE SPECIFIED FILE, MAKE SURE THE FILE AND PATHNAME ARE CORRECT"

This problem does not occur under Windows NT or Windows 3.11.

STATUS

Microsoft has confirmed this to be a bug in the Microsoft products listed at the beginning of this article. We are researching this problem and will post new information here in the Microsoft Knowledge Base as it becomes available.

MORE INFORMATION

Code to Demonstrate the Problem



hrReturnVal = AVIFileOpen(&pfile,
                          "c:\\winvideo\\sample.avi",
                          OF_SHARE_DENY_WRITE,
                          0L);

if (hrReturnVal == 0)
{
     wsprintf(ach, "AVIVideo!@%ld", pfile);
     MCIWndOpen(hwndMci, ach, 0);      //Bug occurs here.
     MCIWndPlay(hwndMci);
}
				

Properties

Article ID: 140750 - Last Review: July 11, 2005 - Revision: 2.2
APPLIES TO
  • Microsoft Platform Software Development Kit-January 2000 Edition, when used with:
    • Microsoft Windows NT Server 4.0 Standard Edition
    • Microsoft Windows NT Workstation 4.0 Developer Edition
Keywords: 
kbmm KB140750

Give Feedback

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com