OFF:» ne peut pas changer d'imprimante» et messages d'erreur similaires

Traductions disponibles Traductions disponibles
Numéro d'article: 140754 - Voir les produits auxquels s'applique cet article
Cet article a été archivé. Il est proposé « en l'état » et ne sera plus mis à jour.
Agrandir tout | Réduire tout

Sommaire

Symptômes

Lorsque vous imprimez à partir d'un programme Microsoft Office pour Windows, un des messages d'erreur suivant s'afficher.

Word

Word ne peut pas changer d'imprimante. Aucune imprimante n'est installée.
- ou -
Impossible d'imprimer en raison d'un problème avec la configuration actuelle de l'imprimante.

Excel

Il n'y a pas d'imprimante installé. Utilisez l'option imprimantes dans le contrôle de Panneau de configuration pour installer une imprimante.

PowerPoint

Il n'y a pas d'imprimante installé.
- ou -
Impossible de trouver l'imprimante.

Planification

Impossible de terminer l'opération d'impression. Il n'y a pas d'imprimante par défaut. Utilisez le Panneau de configuration pour sélectionner une imprimante par défaut.

Cause

Ces messages d'erreur peuvent se produire si une des conditions suivantes est remplie :
  • Vous ne disposez pas d'un fichier Win.ini.

    - ou -

  • La section périphériques du fichier Win.ini est manquante.

    - ou -

  • La section périphériques du fichier Win.ini contient des informations incomplètes ou incorrectes.

    - ou -

  • Le fichier Win.ini dépasse la limite de taille de 64 Ko.

    - ou -

Notez que si vous supprimez le fichier Win.ini, ou si elle est endommagé et que vous redémarrez Microsoft Windows 95, un nouveau fichier Win.ini est créée. Toutefois, le nouveau fichier Win.ini contient uniquement les sections Desktop ou l'incorporation. La section périphériques est manquante.

Pour plus d'informations sur ce problème et Microsoft Word 97, veuillez consulter l'article suivant dans la base de connaissances Microsoft :
162411 OFF97 : erreur de page dans Mso97 lors de l'impression

Contournement

Méthode 1: Réinstallez le pilote d'imprimante

Lorsque vous utilisez cette méthode vous créez les informations requises pour la section périphériques ainsi que écrivez les entrées correctes pour les sections de ports, ports d'imprimante et Windows dans le fichier Win.ini.

Pour plus d'informations sur l'exécution de cette tâche dans Windows, consultez votre Windows documentation imprimée ou à l'aide en ligne.

Méthode 2: Corriger une entrée dans Win.ini

Localisez le fichier Win.ini et corrigez la section périphériques. Pour ce faire, procédez comme suit :
  1. Sur la barre des tâches de Windows 95, cliquez sur Démarrer, pointez sur Rechercher.
  2. Cliquez sur fichiers ou dossiers.
  3. Dans la boîte de dialogue Rechercher tous les fichiers, cliquez sur l'onglet Nom & emplacement.
  4. Dans la zone nommé, tapez Win.ini.
  5. Dans la zone Regarder dans, choisissez le nom de votre disque dur.
  6. Activez la case à cocher Inclure les sous-dossiers et cliquez sur Rechercher.
  7. Cliquez avec le bouton droit sur le fichier Win.ini, puis cliquez sur Ouvrir.
  8. Dans le fichier Win.ini, recherchez la section [Devices].
  9. La section périphériques doit lister le nom convivial de l'imprimante suivie par un signe égal, le nom du pilote, virgule et le port ou le chemin d'accès réseau. Si la section [Devices] est manquante, ajoutez-la. Voici une section [Devices] exemple :
          [Devices]
          HP LaserJet 4/4M=HPPCL5MS,LPT1:
          HP LaserJet IIISi=HPPCL5MS,\\Server\Sharename
    						

Méthode 3: Créez un nouveau fichier Win.ini

Si la méthode 1 ni méthode 2 ne résout le problème, vous pouvez créer un nouveau fichier Win.ini avec les informations correctes.

Renommez le fichier Win.ini à Win.old et réinstallez Windows 95. Windows 95 détecte que vous réinstallez, et une boîte de dialogue s'affiche à nouveau avec le titre «Exécution du programme d'installation»?. La boîte de dialogue vous propose deux options. Sélectionnez la première option (pour restaurer les fichiers Windows modifiés ou endommagés) et réinstallez Windows 95.

Cette méthode recrée un fichier nouveau, complet Win.ini avec toutes les sections requises.

Propriétés

Numéro d'article: 140754 - Dernière mise à jour: lundi 3 février 2014 - Version: 2.2
Les informations contenues dans cet article s'appliquent au(x) produit(s) suivant(s):
  • Microsoft Office 97 Standard
  • Microsoft Office 95 Édition Standard
  • Microsoft Access 95 Standard
  • Microsoft Access 97 Standard
  • Microsoft Excel 97 Standard
  • Microsoft Excel 95 Standard
  • Microsoft PowerPoint 97 Standard
  • Microsoft PowerPoint 95 Standard
  • Microsoft Schedule+ 97 Standard
  • Microsoft Word 97 Standard Edition
  • Microsoft Word 95 Standard Edition
Mots-clés : 
kbnosurvey kbarchive kbmt kbprb kbprint KB140754 KbMtfr
Traduction automatique
IMPORTANT : Cet article est issu du système de traduction automatique mis au point par Microsoft (http://support.microsoft.com/gp/mtdetails). Un certain nombre d?articles obtenus par traduction automatique sont en effet mis à votre disposition en complément des articles traduits en langue française par des traducteurs professionnels. Cela vous permet d?avoir accès, dans votre propre langue, à l?ensemble des articles de la base de connaissances rédigés originellement en langue anglaise. Les articles traduits automatiquement ne sont pas toujours parfaits et peuvent comporter des erreurs de vocabulaire, de syntaxe ou de grammaire (probablement semblables aux erreurs que ferait une personne étrangère s?exprimant dans votre langue !). Néanmoins, mis à part ces imperfections, ces articles devraient suffire à vous orienter et à vous aider à résoudre votre problème. Microsoft s?efforce aussi continuellement de faire évoluer son système de traduction automatique.
La version anglaise de cet article est la suivante: 140754
L'INFORMATION CONTENUE DANS CE DOCUMENT EST FOURNIE PAR MICROSOFT SANS GARANTIE D'AUCUNE SORTE, EXPLICITE OU IMPLICITE. L'UTILISATEUR ASSUME LE RISQUE DE L'UTILISATION DU CONTENU DE CE DOCUMENT. CE DOCUMENT NE PEUT ETRE REVENDU OU CEDE EN ECHANGE D'UN QUELCONQUE PROFIT.

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com