Id. de artículo: 140901 - Última revisión: jueves, 30 de diciembre de 2004 - Versión: 1.2

Mensaje de error: No se puede descodificar este archivo (.cab)...

Este artículo se publicó anteriormente con el número E140901
Expandir todo | Contraer todo

Síntomas

Al intentar instalar Windows 95 o Windows 98, o un componente que requiera copiar archivos del CD-ROM o los discos originales de Windows, puede aparecer un mensaje de error similar a alguno de los siguientes:
  • El programa de instalación ha detectado el siguiente error de descodificación: "No se puede descodificar este archivo (.CAB)". El programa de instalación intentará continuar; haga clic en Aceptar para continuar.
  • Error en archivo de instalación (.cab). El programa de instalación ha detectado el siguiente error de descodificación: el programa de instalación ha detectado un archivo de instalación (.cab) dañado. El programa de instalación intentará continuar.
Al hacer clic en Aceptar, el programa de instalación continúa o genera el mismo mensaje de error de nuevo.

Al instalar Windows 98 Segunda edición, el mensaje de error indica:
El programa de instalación no puede copiar todos los archivos del CD de Windows 98. Limpie el CD de Windows 98 con un paño suave, vuelva a ponerlo en la unidad de CD-ROM y, a continuación, haga clic en Aceptar. Si aparece de nuevo este mensaje, lea la sección Errores CAB del archivo Setup.txt. Este archivo se encuentra en el directorio Win98 del CD de Windows 98.

Causa

Esto puede ocurrir por alguno de los siguientes motivos:
  • La unidad de CD-ROM no funciona adecuadamente. Es posible que el CD-ROM vibre demasiado como para que el láser pueda leer los datos de forma precisa. Con la mayor velocidad de giro de las unidades de CD-ROM modernas, los pequeños daños de un CD-ROM pueden afectar a la capacidad de la unidad de CD-ROM para leerlo correctamente.
  • La CPU del equipo tiene una frecuencia de reloj superior a la predeterminada. Al extraer archivos desde los archivos contenedores de Windows 95 o 98 se usa mucho la memoria. Si el equipo tiene una frecuencia de reloj superior a la configuración predeterminada, puede contribuir a que se produzcan errores de descodificación. Los equipos que no sufren este problema pero tienen problemas de refrigeración también pueden experimentar errores de descodificación.
  • El equipo tiene memoria RAM o caché deficiente o que no coincide. Por ejemplo, utiliza RAM EDO y no EDO, o diferentes velocidades de RAM. Incluso aunque parezca que Windows se ejecuta sin problemas, la carga adicional de la extracción de archivos y del acceso al disco puede contribuir a los errores de descodificación.
  • El equipo tiene habilitado control por bus o Ultra DMA en el BIOS y en el Administrador de dispositivos. Es posible que los datos se muevan demasiado deprisa como para que se mantenga el sistema.
  • Utiliza un administrador de memoria de terceros.
  • Hay un virus en el equipo.
  • No se puede detectar correctamente un dispositivo plug and play.
  • El CD-ROM o los discos de Windows 85 o 98 están dañados.
  • La CPU del equipo se calienta demasiado como resultado de una configuración errónea del CMOS, un ventilador defectuoso de la CPU o una disipación de calor inadecuada. Por ejemplo, el disipador térmico de la CPU no la está refrigerando correctamente.
  • La caché interna o externa del procesador o de la placa base produce errores. Esto es más perceptible cuando el programa de instalación tiene este problema durante la fase de copia de archivos.
  • Norton Autoprotect está habilitado. NOTA: si es el caso, desactive la casilla de verificación Norton Autoprotect en el elemento del grupo Inicio en Msconfig y póngase en contacto con Symantec para obtener una revisión.

Solución

Para resolver este mensaje de error, siga estos pasos. Si un paso no resuelve el problema, pruebe el siguiente.
  1. Quite el CD-ROM de la unidad de CD-ROM, gírelo entre un cuarto a medio giro, vuelva a insertar el CD-ROM en la unidad y, a continuación, haga clic en Aceptar.
  2. Utilice controladores de CD-ROM en modo real. Si no puede encontrar los controladores de CD-ROM en modo real para su unidad de CD-ROM, intente utilizar los del disco de inicio de Windows 98. El disco de inicio de Windows 98 proporciona compatibilidad con la mayoría de unidades de CD-ROM, incluidas las unidades electrónicas de dispositivos integradas (IDE, Integrated Device Electronics) y de interfaz estándar de equipos pequeños (SCSI, Small Computer System Interface). Ejecute el programa de instalación de Windows desde MS-DOS.
  3. Intente disminuir la velocidad del equipo. Para ello, utilice alguno de los métodos siguientes:
    1. Cambie la configuración del CMOS del equipo. El Control por bus, la caché interna y externa, la cronología y la configuración de RAM y otras configuraciones afectan a la velocidad a la que se ejecuta el equipo. Para obtener información acerca de cómo cambiar estas configuraciones, consulte la documentación que se incluye con el equipo.
  4. Copie el contenido de la carpeta Win95 o Win98 del CD-ROM a una carpeta vacía del disco duro y, a continuación, ejecute el programa de instalación de Windows desde esta carpeta. Si no puede copiar la carpeta Win95 o Win98 del CD-ROM al disco duro, el CD-ROM puede estar dañado.
  5. Reinicie el equipo. Reinicie Windows 95, presione la tecla F8 cuando vea el mensaje "Iniciando Windows 95" y después, en el menú Inicio, elija Confirmación paso a paso.

    En Windows 98, mantenga presionada la tecla CTRL una vez completada la comprobación automática durante el encendido (POST) del equipo y, a continuación, en el menú Inicio, elija Confirmación paso a paso. Para obtener más información acerca del inicio de Windows 98, consulte el artículo siguiente en Microsoft Knowledge Base:
    E178548  (http://support.microsoft.com/kb/E178548/ES/ ) No aparece el mensaje de "Iniciando Windows 98" al inicio
    Presione Y (S) en cada pregunta excepto en las siguientes:
    ¿Procesar los controladores de dispositivo de inicio (CONFIG.SYS)?
    ¿Procesar el archivo de comandos de inicio (AUTOEXEC.BAT)?
    Si esto resuelve el problema, aísle el conflicto con un controlador de dispositivo en modo real o programa residente (TSR) mediante la función Confirmar paso a paso.
  6. Compruebe si hay algún virus en el equipo mediante software de detección de virus.
  7. Ejecute el programa de instalación de Windows 98 con el comando siguiente:

    setup /c Este modificador evita la ejecución de SMARTDrive.
  8. Mediante un procesador de texto para MS-DOS (como EDIT.COM), examine el contenido del archivo SETUPLOG.TXT (ubicado en la raíz de la unidad de inicio). Busque la línea que hace referencia al archivo contenedor (.CAB) al que se ha tenido acceso y extraiga manualmente todos los archivos del archivo contenedor en una carpeta vacía del disco duro; después, copie todos los archivos que queden en la carpeta Win98 del CD-ROM a la misma carpeta del disco duro.

    Normalmente, hay muchas entradas duplicadas en SETUPLOG.TXT que pueden parecerse a lo siguiente:
     
    Regsvr32 c:\progra~1\common~1\micros~1\dao\dao3032.dll
     
     Ubicación de carpeta                      Nombre del archivo 
    ---------------------------------------------------------------
    
    \Program Files\Common Files\Microsoft Shared\DAO DAO3032.DLL
    \<windir>\System                                 MSJETSQL.TLB 
    \<windir>\System                                 MSJINT32.DLL 
    \<windir>\System                                 MSJT3032.DLL 
    \<windir>\System                                 MSJTER32.DLL 
    \<windir>\System                                 MSRD2X32.DLL 
    \<windir>\System                                 MSWNG300.DLL 
    \<windir>\System                                 VAEN232.DLL 
    \<windir>\System                                 VBA232.DLL 
    \<windir>\System                                 VBAJET32.DLL 
    \<windir>\System                                 VBAR2232.DLL 
    \<windir>\System                                 VEN2232.OLB
     
    Ubicación de carpeta  Nombre del archivo
     ---------------------------------------------------------------
    
     \<windir>\System32  DAO3032.DLL 
    \<windir>\System32   MSJETSQL.TLB 
    \<windir>\System32   MSJINT32.DLL 
    \<windir>\System32   MSJT3032.DLL 
    \<windir>\System32   MSJTER32.DLL 
    \<windir>\System32   MSRD2X32.DLL 
    \<windir>\System32   MSWNG300.DLL 
    \<windir>\System32   VAEN232.DLL 
    \<windir>\System32   VBA232.DLL 
    \<windir>\System32   VBAJET32.DLL 
    \<windir>\System32   VBAR2232.DLL 
    \<windir>\System32   VEN2232.OLB
      a:\setup /y
  9. Si sigue recibiendo un error de descodificación en Windows 98, puede extraer manualmente todos los archivos de Windows 98 de los archivos contenedores de Windows 98 del CD-ROM en el disco duro y, a continuación, ejecutar el programa de instalación de Windows 98 allí. Se requieren 300 MB, aproximadamente, de espacio en el disco duro para extraer los archivos de Windows 98. Puede utilizar la utilidad Ext.exe para extraerlos. Esta utilidad se encuentra en el disco de inicio de Windows 98 y en la carpeta \Oldmsdos del CD-ROM de Windows 98. Para extraer manualmente los archivos de Windows 98, siga estos pasos:
    1. Inserte el disco de inicio de Windows 98 en la unidad de disco y reinicie el equipo.

      NOTA: si no tiene un disco de inicio de Windows 98, debe obtener uno en un equipo con Windows 98. Para crear un disco de inicio de Windows 98 en un equipo funcional con este sistema operativo, siga estos pasos:
      1. Haga clic en Inicio, seleccione Configuración, haga clic en Panel de control y, a continuación, haga doble clic en Agregar o quitar programas.
      2. Haga clic en Disco de inicio y en Crear disco. Después, siga las instrucciones que aparecerán en la pantalla.
    2. En el símbolo del sistema, escriba ext .
    3. Cuando se le pregunte la ubicación de los archivos contenedores, escriba la ruta de acceso de la carpeta que creó en el paso 4.
    4. Cuando se le pregunten los archivos que se deben extraer, escriba *.* para extraerlos todos.
    5. Cuando se le pregunte la ubicación donde se deben extraer los archivos, escriba la ruta de acceso de la carpeta que creó en el paso 4. El programa de instalación se ha diseñado para buscar un archivo antes de extraerlo del archivo contenedor.

      Tenga en cuenta que de este modo no se extraen los archivos de los archivos contenedores Precopy1.cab y Precopy2.cab.
    6. Después de extraer todos los archivos, ejecute el programa de instalación desde MS-DOS en la carpeta que contiene los archivos de instalación.
NOTA: es posible que tenga que quitar los dispositivos Plug and Play del equipo para solucionar conflictos de Plug and Play.

Más información

El programa de instalación de Windows 98 intentará recuperarse del error de descodificación; para ello, volverá a buscar en el CD-ROM e intentará extraer los archivos en una ubicación diferente. El programa de instalación intenta hasta 128 veces volver a buscar en una ubicación aleatoria del CD-ROM para iniciar de nuevo el proceso de copia de archivos. Esto se registra en el archivo Setuplog.txt. Se puede observar actividad en el CD-ROM y el disco duro, pero la instalación avanzará muy poco. Si el programa de instalación no puede extraer los archivos después de 128 intentos, volverá a aparecer el mensaje de error de descodificación.

Tenga en cuenta que este comportamiento también puede deberse a un CD-ROM sucio. Puede limpiar el CD-ROM y, a continuación, ejecutar el programa de instalación de Windows de nuevo.

La información de este artículo se refiere a:
  • Microsoft Windows 98 Standard Edition
  • Microsoft Windows 95
  • Microsoft Windows 98 Second Edition
Palabras clave: 
kberrmsg kbtshoot kbsetup kbhw win98se win98 kbprb win95 KB140901
 

Seleccione idioma

 

Related Support Centers