Fichiers Opens.exe de Internet Explorer au lieu de les télécharger

Traductions disponibles Traductions disponibles
Numéro d'article: 140991 - Voir les produits auxquels s'applique cet article
Agrandir tout | Réduire tout

Sommaire

Symptômes

Lorsque vous essayez de télécharger un fichier exécutable (.exe) dans Microsoft Internet Explorer, le fichier peut être ouvert au lieu de télécharger.

Cause

Dans les versions d'Internet Explorer antérieure à la version Internet Explorer 4.0, lorsque vous choisissez tout d'abord télécharger un fichier dans Internet Explorer, vous recevez une boîte de dialogue Confirmer l'ouverture du fichier s'ouvre. LeToujours demander avant d'ouvrir ce type de fichiercase à cocher dans cette boîte de dialogue est sélectionnée.

Si vous désactivez la case à cocher "Toujours demander avant d'ouvrir ce type de fichier", l'entrée de Registre pour ce paramètre est modifiée et vous ne voyez pas la boîte de dialogue Confirmer l'ouverture du fichier s'ouvre dans les sessions de téléchargement suivantes. Au lieu de cela, Internet Explorer ouvre automatiquement les fichiers au lieu de les télécharger.

Résolution

ImportantCette section, la méthode ou tâche contient des procédures qui vous indiquent comment modifier le Registre. Toutefois, des problèmes sérieux peuvent se produire si vous modifiez le Registre de façon incorrecte. Par conséquent, assurez-vous que vous suivez ces étapes avec précaution. Pour plus de protection, sauvegardez le Registre avant de le modifier. Ensuite, vous pouvez restaurer le Registre si un problème se produit. Pour plus d'informations sur la façon de sauvegarder et restaurer le Registre, cliquez sur le numéro ci-dessous pour afficher l'article correspondant dans la base de connaissances Microsoft :
322756Comment faire pour sauvegarder et restaurer le Registre dans Windows

Pour contourner ce problème, utilisez la méthode appropriée.

Méthode 1

Avec le bouton droit de la liaison pour le fichier à télécharger, puis cliquez surEnregistrer la cible sous.

Méthode 2

Activer leToujours demander avant d'ouvrir ce type de fichieroption . Pour ce faire, utilisez l'Éditeur du Registre pour modifier le troisième octet de la valeur EditFlags de la clé Hkey_Classes_Root\exefile de 01 à 00.

Remarque: Cette méthode ne fonctionne pas si vous utilisez Internet Explorer version 4.0 ou version ultérieure.

Par exemple, remplacez la valeur EditFlagsd8 07 01 00pourd8 07 00 00.

Remarque: L'indicateur de modification pour les documents Word est à l'emplacement suivant :
   [HKEY_CLASSES_ROOT\Word.Document.6]
   @="Microsoft Word 6.0 - 7.0 Document" "EditFlags"=hex:00,00,01,00
				

01 De modification dans le troisième octet à 00.

Plus d'informations

La première fois que vous cliquez sur un lien pour télécharger un fichier .exe dans les versions d'Internet Explorer antérieure à la version Internet Explorer 4.0, vous recevez unConfirmation de l'ouverture du fichierboîte de dialogue . LeToujours demander avant d'ouvrir ce type de fichierdans cette boîte de dialogue est activée. Si vous êtes sûr, il est sage d'ouvrir le fichier, cliquez surOuvert. Pour enregistrer le fichier sur disque, cliquez surEnregistrer en tant que.

Si vous désactivez leToujours demander avant d'ouvrir ce type de fichiercase à cocher de , vous n'êtes plus invité à ouvrir un fichier ou non. Au lieu de cela, le fichier est ouvert automatiquement.

Si vous désactivez l'invite de commandes pour les fichiers ActiveMovie (Cela inclut tout type de fichier utilisant ActiveMovie tels que les fichiers .wav, .mov et .avi), la clé de Registre doit être modifiée est :

   HKEY_CLASSES_ROOT\AMOVIE.ActiveMovie.Control.1
				

Modifier la valeur EditFlags de 00 00 01 00 à 00 00 00 00.

Si vous exécutez Internet Explorer 4.0 ultérieurement, la clé de Registre doit être modifiée est :

   HKEY_CLASSES_ROOT\AMOVIE.ActiveMovieControl.2
				

Modifier la valeur EditFlags de 00 00 01 00 à 00 00 00 00.

Si vous exécutez le lecteur Windows Media version 5.2, la clé de Registre doit être modifiée est :

   HKEY_CLASSES_ROOT\MediaPlayer.MediaPlayer.1
				

Modifier la valeur EditFlags de sorte qu'il soit uniquement des zéros ou un zéro valeur.

LeToujours demander avant d'ouvrir ce type de fichiercase à cocher n'apparaît pas dans Internet Explorer 4.0 et version ultérieure.


Pour Windows Millennium Edition

  1. Cliquez surLe poste de travailcliquez surOutils, puis cliquez surOptions des dossiers.
  2. Cliquez sur le fichier de types et la mise en surbrillance puis un type de fichier.
  3. Cliquez surAvancé, puis cliquez sur SélectionnerConfirmer l'ouverture après le téléchargement.
Pour plus d'informations sur le téléchargement d'autres types de fichiers, veuillez consulter l'article suivant dans la base de connaissances Microsoft :
177976Pas invité à pour spécifier le dossier de téléchargement de fichier
Remarque Il s'agit d'un article de « PUBLICATION RAPIDE » rédigé directement au sein du service de support technique Microsoft. Les informations qui y sont contenues sont fournies en l'état, en réponse à des problèmes émergents. En raison du délai rapide de mise à disposition, les informations peuvent contenir des erreurs typographiques et, à tout moment et sans préavis, faire l'objet de révisions. Pour d'autres considérations, consultez les Conditions d'utilisation.

Propriétés

Numéro d'article: 140991 - Dernière mise à jour: mercredi 5 janvier 2011 - Version: 2.0
Les informations contenues dans cet article s'appliquent au(x) produit(s) suivant(s):
  • Microsoft Windows 95
  • Microsoft Plus! 95 Standard Edition
  • Microsoft Windows NT Server 4.0 Standard Edition
  • Microsoft Windows NT Workstation 4.0 Édition Développeur
Mots-clés : 
kbenv kbui kbmt KB140991 KbMtfr
Traduction automatique
IMPORTANT : Cet article est issu du système de traduction automatique mis au point par Microsoft (http://support.microsoft.com/gp/mtdetails). Un certain nombre d?articles obtenus par traduction automatique sont en effet mis à votre disposition en complément des articles traduits en langue française par des traducteurs professionnels. Cela vous permet d?avoir accès, dans votre propre langue, à l?ensemble des articles de la base de connaissances rédigés originellement en langue anglaise. Les articles traduits automatiquement ne sont pas toujours parfaits et peuvent comporter des erreurs de vocabulaire, de syntaxe ou de grammaire (probablement semblables aux erreurs que ferait une personne étrangère s?exprimant dans votre langue !). Néanmoins, mis à part ces imperfections, ces articles devraient suffire à vous orienter et à vous aider à résoudre votre problème. Microsoft s?efforce aussi continuellement de faire évoluer son système de traduction automatique.
La version anglaise de cet article est la suivante: 140991
L'INFORMATION CONTENUE DANS CE DOCUMENT EST FOURNIE PAR MICROSOFT SANS GARANTIE D'AUCUNE SORTE, EXPLICITE OU IMPLICITE. L'UTILISATEUR ASSUME LE RISQUE DE L'UTILISATION DU CONTENU DE CE DOCUMENT. CE DOCUMENT NE PEUT ETRE REVENDU OU CEDE EN ECHANGE D'UN QUELCONQUE PROFIT.

Envoyer des commentaires

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com