Internet Explorer แฟ้ม Opens.exe แทนที่จะดาวน์โหลดมา

การแปลบทความ การแปลบทความ
หมายเลขบทความ (Article ID): 140991 - ผลิตภัณฑ์ที่เกี่ยวข้องในบทความนี้
ขยายทั้งหมด | ยุบทั้งหมด

เนื้อหาบนหน้านี้

อาการ

เมื่อคุณพยายามที่จะดาวน์โหลดแฟ้มปฏิบัติการ (.exe) ในอินเทอร์เน็ตของ Microsoft Explorer อาจมีเปิดแฟ้มแทนดาวน์โหลดได้

สาเหตุ

ใน Internet Explorer รุ่นก่อนหน้านี้กว่า Internet Explorer 4.0 เมื่อคุณเลือกการดาวน์โหลดแฟ้มใน Internet Explorer คุณได้รับกล่องโต้ตอบยืนยันการเปิดแฟ้ม ที่ ถามทุกครั้งก่อนที่จะเปิดแฟ้มชนิดนี้ มีเลือกกล่องกาเครื่องหมายในกล่องโต้ตอบนี้

ถ้าคุณล้างกล่องกาเครื่องหมาย "ถามทุกครั้งก่อนที่จะเปิดแฟ้มชนิดนี้" กล่อง รายการรีจิสทรีสำหรับการตั้งค่านี้จะมีการเปลี่ยนแปลง และคุณไม่เห็น กล่องโต้ตอบยืนยันการเปิดแฟ้มในเซสชันการดาวน์โหลดในเวลาต่อมา แทน Internet Explorer โดยอัตโนมัติเปิดแฟ้มแทน ดาวน์โหลดมา

การแก้ไข

สิ่งสำคัญ นี้ส่วน วิธีการ หรืองานประกอบด้วยขั้นตอนที่บอกให้คุณทราบวิธีการปรับเปลี่ยนรีจิสทรี อย่างไรก็ตาม ปัญหาร้ายแรงอาจเกิดขึ้นหากคุณปรับเปลี่ยนรีจิสทรีอย่างไม่ถูกต้อง ดังนั้น ตรวจสอบให้แน่ใจว่า คุณทำตามขั้นตอนเหล่านี้อย่างระมัดระวัง สำหรับการป้องกันเพิ่มเติม สำรองรีจิสทรีก่อนที่คุณปรับเปลี่ยน แล้ว คุณสามารถคืนค่ารีจิสทรีหากเกิดปัญหา สำหรับข้อมูลเพิ่มเติมเกี่ยวกับวิธีการสำรอง และคืนค่ารีจิสทรี คลิกหมายเลขบทความต่อไปนี้เพื่อดูบทความในฐานความรู้ของ Microsoft:
322756 วิธีการสำรอง และคืนค่ารีจิสทรีใน Windows

เมื่อต้องแก้ไขปัญหานี้ ใช้วิธีการที่เหมาะสม

วิธีที่ 1

คลิกขวาการเชื่อมโยงสำหรับแฟ้มคุณต้องการดาวน์โหลด และจากนั้น คลิกบันทึกเป้าหมายเป็น

วิธีที่ 2

เปิดใช้งานนั้น ถามทุกครั้งก่อนที่จะเปิดแฟ้มชนิดนี้ ตัวเลือก เมื่อต้องทำเช่นนี้ ใช้ตัวแก้ไขรีจิสทรีเพื่อปรับเปลี่ยน octet สามสำหรับค่า EditFlags ในการให้คีย์ Hkey_Classes_Root\exefile จาก 01 00

หมายเหตุ: วิธีการนี้ไม่ทำงานถ้าคุณกำลังใช้ Internet Explorer เวอร์ชั่น 4.0 หรือรุ่นที่ใหม่กว่า

ตัวอย่างเช่น เปลี่ยนค่า EditFlags จาก d8 07 01 00 เมื่อต้องการ d8 07 00 00.

หมายเหตุ: แก้ไขค่าสถานะสำหรับเอกสาร Word ที่อยู่ในตำแหน่งต่อไปนี้:
   [HKEY_CLASSES_ROOT\Word.Document.6]
   @="Microsoft Word 6.0 - 7.0 Document" "EditFlags"=hex:00,00,01,00
				

เปลี่ยน 00 01 ใน octet สาม

ข้อมูลเพิ่มเติม

ในครั้งแรกที่คุณคลิกลิงค์ดาวน์โหลดแฟ้ม.exe ใน Internet Explorer รุ่นก่อนหน้าของ Internet Explorer 4.0 คุณได้รับกล่องโต้ตอบยืนยันการเปิดแฟ้ม ที่ ถามทุกครั้งก่อนที่จะเปิดแฟ้มชนิดนี้ กล่องกาเครื่องหมายในกล่องโต้ตอบนี้ เลือก ถ้าคุณแน่ใจว่ามีความปลอดภัยที่จะเปิดแฟ้ม คลิกเปิด ถ้าต้องบันทึกแฟ้มลงดิสก์ คลิกบันทึกเป็น

ถ้าคุณล้างข้อมูลนั้น ถามทุกครั้งก่อนที่จะเปิดแฟ้มชนิดนี้ กล่องกาเครื่องหมาย คุณจะไม่ได้รับพร้อมท์ว่า จะเปิดแฟ้มหรือไม่ แทน แฟ้มถูกเปิดโดยอัตโนมัติ

ถ้าคุณปิดการใช้งานของพร้อมท์สำหรับแฟ้มของ ActiveMovie (ซึ่งรวมถึงแฟ้มใด ๆ ชนิดที่ใช้ ActiveMovie เช่นแฟ้ม.wav, .mov และ.avi), การ รีจิสทรีคีย์ที่จำเป็นต้องปรับเปลี่ยนได้คือ:

   HKEY_CLASSES_ROOT\AMOVIE.ActiveMovie.Control.1
				

เปลี่ยนค่า EditFlags จาก 00 00 00 01 00 ไป 00 00 00 00

ถ้าคุณกำลังเรียกใช้ Internet Explorer 4.0 ในภายหลัง รีจิสทรีคีย์ที่ ต้องแก้ไขเป็น:

   HKEY_CLASSES_ROOT\AMOVIE.ActiveMovieControl.2
				

เปลี่ยนค่า EditFlags จาก 00 00 00 01 00 ไป 00 00 00 00

ถ้าคุณกำลังเรียกใช้ Windows Media Player เวอร์ชั่น 5.2 คีย์รีจิสทรี ที่ต้องแก้ไขเป็น:

   HKEY_CLASSES_ROOT\MediaPlayer.MediaPlayer.1
				

เปลี่ยนค่า EditFlags เพื่อให้เป็นศูนย์ทั้งหมดหรือมีค่าเป็น 0

ที่ ถามทุกครั้งก่อนที่จะเปิดแฟ้มชนิดนี้ กล่องกาเครื่องหมายจะไม่แสดง ใน Internet Explorer 4.0 และรุ่นที่ใหม่กว่า


สำหรับ Windows Millennium

  1. คลิกMy Computerคลิกเครื่องมือและจากนั้น คลิกตัวเลือกโฟลเดอร์
  2. คลิกแฟ้มชนิด และชนิดของแฟ้มที่เน้นแล้ว
  3. คลิกขั้นสูงและจากนั้น คลิกเพื่อเลือก Confirm open after download.
สำหรับข้อมูลเพิ่มเติมเกี่ยวกับการดาวน์โหลดแฟ้มชนิดอื่น ๆ โปรดดู บทต่อไปนี้ในฐานความรู้ของ Microsoft:
177976 ไม่ได้รับการพร้อมท์เพื่อระบุการดาวน์โหลดโฟลเดอร์สำหรับแฟ้ม

คุณสมบัติ

หมายเลขบทความ (Article ID): 140991 - รีวิวครั้งสุดท้าย: 5 พฤศจิกายน 2555 - Revision: 7.0
ใช้กับ
  • Microsoft Windows 95
  • Microsoft Plus! 95 Standard Edition
  • Microsoft Windows NT Server 4.0 Standard Edition
  • Microsoft Windows NT Workstation 4.0 Developer Edition
Keywords: 
kbenv kbui kbmt KB140991 KbMtth
แปลโดยคอมพิวเตอร์
ข้อมูลสำคัญ: บทความนี้แปลโดยซอฟต์แวร์การแปลด้วยคอมพิวเตอร์ของ Microsoft แทนที่จะเป็นนักแปลที่เป็นบุคคล Microsoft มีบทความที่แปลโดยนักแปลและบทความที่แปลด้วยคอมพิวเตอร์ เพื่อให้คุณสามารถเข้าถึงบทความทั้งหมดในฐานความรู้ของเรา ในภาษาของคุณเอง อย่างไรก็ตาม บทความที่แปลด้วยคอมพิวเตอร์นั้นอาจมีข้อบกพร่อง โดยอาจมีข้อผิดพลาดในคำศัพท์ รูปแบบการใช้ภาษาและไวยากรณ์ เช่นเดียวกับกรณีที่ชาวต่างชาติพูดผิดเมื่อพูดภาษาของคุณ Microsoft ไม่มีส่วนรับผิดชอบต่อความคลาดเคลื่อน ความผิดพลาดหรือความเสียหายที่เกิดจากการแปลเนื้อหาผิดพลาด หรือการใช้บทแปลของลูกค้า และ Microsoft มีการปรับปรุงซอฟต์แวร์การแปลด้วยคอมพิวเตอร์อยู่เป็นประจำ
ต่อไปนี้เป็นฉบับภาษาอังกฤษของบทความนี้:140991

ให้ข้อเสนอแนะ

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com