Help and Support

Id. de artículo: 141373 - Última revisión: martes, 26 de diciembre de 2006 - Versión: 10.0

Mensaje de error "No hay licencia" al iniciar Microsoft Access

Este artículo se publicó anteriormente con el número E141373
Importante
Este artículo contiene información sobre cómo modificar el Registro. Antes de modificar el Registro, asegúrese de hacer una copia de seguridad del mismo y de que sabe cómo restaurarlo si se produce algún problema. Para obtener más información acerca de cómo realizar una copia de seguridad, restaurar y modificar el Registro, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
256986  (http://support.microsoft.com/kb/256986/ ) Definición del Registro de Microsoft Windows
Principiante: se requieren conocimientos de la interfaz de usuario en equipos de usuario único.

En esta página

Expandir todo | Contraer todo

Síntomas

Cuando inicia Microsoft Access 97, puede recibir uno de los mensajes de error siguientes:
No se puede iniciar Microsoft Access porque no hay licencia para el producto en este equipo.
No se puede encontrar la base de datos que especificó o no especificó ninguna base de datos.
Al iniciar Microsoft Access 7.0 puede aparecer un mensaje de error similar al siguiente:
No se puede iniciar Microsoft Access porque no hay licencia para el producto en este equipo.

Causa

Este mensaje de error tiene dos causas posibles.

La más probable es que Microsoft Access no está registrado correctamente en el equipo. Si Microsoft Access no está registrado correctamente en su equipo, siga los pasos de la sección "Cambiar un nombre de fuente y a continuación volver a instalar Microsoft Access" de la sección "Resolución" de este artículo, para registrar Access correctamente en el equipo.

La segunda causa se aplica únicamente a los equipos que ejecutan Microsoft Windows NT 4.0 o Microsoft Windows 2000. En estos sistemas operativos, también puede recibir este mensaje de error si no tiene permisos de lectura para la clave Licenses del Registro. Si es éste su caso, siga los pasos descritos en la sección "Sin permisos de lectura para la clave Licenses" de la sección "Resoluciones" de este artículo, para conceder permisos de lectura para la clave Licenses a todos los usuarios y grupos que considere necesario.

Solución

Nota
Si ejecuta Microsoft Windows 98, puede descargar una herramienta que corrige el problema tratado en este artículo. Si ejecuta un sistema operativo distinto de Windows 98, puede que esta herramienta no funcione correctamente.

Para obtener más información acerca de cómo descargar esta herramienta, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
191224  (http://support.microsoft.com/kb/191224/ ) AcLicn97.exe está disponible en el Centro de descarga

Cambiar un nombre de fuente y a continuación volver a instalar Microsoft Access

Importante
Si recibió un mensaje de error cuando instaló Access semejante a
Error de configuración del controlador nombre y extensión del controlador ODBC para Microsoft.
y a continuación recibió alguno de los mensajes de error mencionados en la sección "Síntomas" de este artículo, instale MDAC 2.8 o una versión anterior desde el siguiente sitio Web de Microsoft:

Para obtener MDAC 2.8, visite el siguiente sitio Web de Microsoft Developer Network (MSDN):
http://www.microsoft.com/downloads/details.aspx?FamilyID=6c050fe3-c795-4b7d-b037-185d0506396c&DisplayLang=es (http://www.microsoft.com/downloads/details.aspx?FamilyID=6c050fe3-c795-4b7d-b037-185d0506396c&DisplayLang=es)
Nota
En los pasos siguientes, cuando se vuelve a instalar Microsoft Access 97 utilizando la instalación en modo de mantenimiento, no hay que desinstalar primero Microsoft Access. Esta operación vuelve a dejar el equipo en el estado de instalación en el que estaba la última vez que ejecutó el programa de instalación.

Siga estos pasos para corregir el error del Registro.

Nota
Dado que existen varias versiones de Windows, es posible que los pasos siguientes no sean iguales en su equipo. Si es así, consulte la documentación del producto para completarlos. Si usa Microsoft Windows Millennium Edition, siga los pasos descritos en la sección "Pasos para Microsoft Windows Millennium" más adelante en este artículo.
  1. Cierre todos los programas de Microsoft Office que se estén ejecutando en el equipo.
  2. En el menú Inicio, seleccione Buscar y haga clic en Archivos o carpetas.
  3. En el cuadro Nombre, escriba hatten.ttf.
  4. En el cuadro Buscar en, escriba c:\windows\fonts.

    Nota
    La ruta de acceso de la carpeta Fonts puede ser diferente en su equipo.
  5. Haga clic en Buscar ahora para iniciar la búsqueda.

    Nota
    Si no se encuentra el archivo Hatten.ttf, pruebe a buscar Haettenschweiler.ttf, que es el nombre completo de la fuente Hatten.
  6. En Nombre, haga clic con el botón secundario del mouse en el archivo hatten.ttf y, a continuación, en el menú de acceso directo que aparece, haga clic en Cambiar nombre.
  7. Cambie el nombre del archivo a hatten.xxx. Si aparece un mensaje donde se indica que si cambia la extensión puede hacer que el archivo se vuelva inutilizable, haga clic en .
  8. Minimice, pero no cierre, el cuadro de diálogo Buscar.
  9. En el menú Inicio, seleccione Configuración y haga clic en Panel de control.
  10. En el Panel de control, haga doble clic en Agregar o quitar programas.
  11. En el cuadro de diálogo Propiedades de Agregar o quitar programas, haga clic en la ficha Instalar o desinstalar y seleccione Microsoft Office 97, Professional Edition en la lista de programas.
  12. Haga clic en Agregar o quitar para ejecutar el programa de instalación de Office en modo de mantenimiento.
  13. En el cuadro de diálogo Instalación de Microsoft Office 97, haga clic en Reinstalar.
  14. Una vez finalizada la reinstalación, haga clic en el cuadro de diálogo Buscar en la barra de tareas, para maximizarlo.
  15. En Nombre, haga clic con el botón secundario del mouse en el archivo hatten.xxx y, a continuación, en el menú de acceso directo que aparece, haga clic en Cambiar nombre.
  16. Vuelva a cambiar el nombre del archivo a hatten.ttf.
Ahora Microsoft Access se debería registrar correctamente.

Pasos para Microsoft Windows Millennium Edition

Importante
Si recibió un mensaje de error cuando instaló Access semejante a
Error de configuración del controlador nombre y extensión del controlador ODBC para Microsoft.
y a continuación recibió alguno de los mensajes de error mencionados en la sección "Síntomas" de este artículo, instale MDAC 2.8 o una versión anterior desde el siguiente sitio Web de Microsoft:

Puede descargar MDAC 2.8 desde el siguiente sitio Web de Microsoft:
http://www.microsoft.com/downloads/details.aspx?FamilyID=6c050fe3-c795-4b7d-b037-185d0506396c&DisplayLang=es (http://www.microsoft.com/downloads/details.aspx?FamilyID=6c050fe3-c795-4b7d-b037-185d0506396c&DisplayLang=es)
  1. Cierre todos los programas de Microsoft Office que se estén ejecutando en el equipo.
  2. Haga clic en Inicio, seleccione Programas, Accesorios y, a continuación, haga clic en MS-DOS.
  3. En el símbolo del sistema de MS-DOS, escriba cd fonts y presione ENTRAR.
  4. En el símbolo del sistema de MS-DOS, escriba ren hatten.ttf hatten.old y presione ENTRAR.

    Nota
    Al hacerlo, puede recibir el mensaje de error siguiente:
    nombre de archivo duplicado o archivo en uso.
    Si se cumple dicha afirmación, siga estos pasos en lugar de los pasos 1 a 4 para cambiar el nombre de la fuente:
    1. Reinicie el equipo con el disco de inicio en la unidad de disco.
    2. En la pantalla de inicio, elija la opción 4 para un inicio mínimo.
    3. En el símbolo del sistema de MS-DOS, escriba c: y presione ENTRAR.
    4. En el símbolo del sistema de MS-DOS, escriba cd windows\fonts y presione ENTRAR.
    5. En el símbolo del sistema de MS-DOS, escriba ren hatten.ttf hatten.old y presione ENTRAR.
  5. Reinicie el equipo.
  6. Haga clic en Inicio, seleccione Configuración y haga clic en Panel de control.
  7. En el Panel de control, haga doble clic en Agregar o quitar programas.
  8. En el cuadro de diálogo Propiedades de Agregar o quitar programas, haga clic en la ficha Instalar o desinstalar y, a continuación, haga clic en Microsoft Office 97, Professional Edition en la lista de programas.
  9. Haga clic en Agregar o quitar para ejecutar el programa de instalación de Office en modo de mantenimiento.
  10. En el cuadro de diálogo Instalación de Microsoft Office 97, haga clic en Reinstalar.
Ahora Microsoft Access se debería haber registrado correctamente.

Sin permisos de lectura para la clave de licencias

Advertencia
Pueden producirse graves problemas si modifica incorrectamente el Registro mediante el Editor del Registro o con cualquier otro método. Estos problemas pueden requerir que reinstale el sistema operativo. Microsoft no puede garantizar la solución de esos problemas. Modifique el Registro bajo su responsabilidad.

Importante
Los pasos descritos en esta sección se aplican únicamente a equipos que utilizan Microsoft Windows NT 4.0 o Microsoft Windows 2000.

Cuando inicia sesión como administrador en un equipo con Windows NT 4.0 o Windows 2000, .puede usar el Editor del Registro para comprobar y modificar los permisos de usuario para las diferentes claves del Registro.

Para examinar los permisos de usuario, siga estos pasos:
  1. Inicie sesión como administrador en el equipo con problemas.
  2. Haga clic en Inicio y en Ejecutar, escriba regedt32 y haga clic en Aceptar.
  3. Seleccione la clave \\HKEY_CLASSES_ROOT\Licenses.
  4. En el menú Seguridad, haga clic en Permisos.
  5. Asegúrese de que los usuarios y grupos correspondientes tengan al menos permisos de lectura para la clave.
  6. Cierre el Editor del Registro y reinicie el equipo.
Cuando inicie sesión como usuario normal, debe poder iniciar Microsoft Access sin problemas.

Estado

Microsoft ha confirmado que se trata de un problema de los productos de Microsoft enumerados en la sección "La información de este artículo se refiere a" de este artículo.

Más información

Para obtener más información acerca de cómo instalar Access 97 y Access 2000 en el mismo equipo, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
241141  (http://support.microsoft.com/kb/241141/ ) Cómo instalar Access 97 y Access 2000 en el mismo equipo

La información de este artículo se refiere a:
  • Microsoft Access 95 Standard Edition
  • Microsoft Access 97 Standard Edition
Palabras clave: 
kbpubtypekc kberrmsg kbprb kbsetup KB141373
Retired KB ArticleRenuncia a responsabilidad de los contenidos de la KB sobre productos a los que ya no se ofrece asistencia alguna
El presente artículo se escribió para productos para los que Microsoft ya no ofrece soporte técnico. Por tanto, el presente artículo se ofrece "tal cual" y no será actualizado.

Seleccione idioma