Identificativo articolo: 141373 - Ultima modifica: venerdì 22 dicembre 2006 - Revisione: 10.0

Messaggio di errore relativo alla mancanza di licenza all'avvio di Microsoft Access

Questo articolo è stato precedentemente pubblicato con il codice di riferimento I141373
Importante In questo articolo sono contenute informazioni su come modificare il Registro di sistema. Assicurarsi di eseguire il backup del Registro di sistema prima di modificarlo e di sapere come ripristinarlo in caso di problemi. Per informazioni su come eseguire il backup, ripristinare e modificare il Registro di sistema, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito:
256986  (http://support.microsoft.com/kb/256986/ ) Descrizione del Registro di sistema di Microsoft Windows
Utenti inesperti: è richiesta la conoscenza dell'interfaccia utente dei computer a utente singolo.

In questa pagina

Espandi tutto | Chiudi tutto

Sintomi

Quando si avvia Microsoft Access 97, è possibile che venga visualizzato un messaggio di errore analogo a uno dei seguenti:
Impossibile avviare Microsoft Access. Non è stata concessa la licenza d'uso su questo computer.
Impossibile trovare il database specificato oppure database non specificato.
Quando si avvia Microsoft Access 7.0, è possibile che venga visualizzato il seguente messaggio d'errore:
Impossibile avviare Microsoft Access. Non è stata concessa la licenza d'uso su questo computer.

Cause

Questo messaggio di errore è imputabile a due possibili cause.

La causa più probabile è la registrazione non corretta di Microsoft Access nel computer in uso. Se Microsoft Access non è registrato correttamente nel computer in uso, seguire le procedure descritte nel paragrafo "Ridenominazione di un tipo di carattere e reinstallazione di Microsoft Access" della sezione "Risoluzione".

La seconda causa riguarda solo i computer che eseguono Microsoft Windows NT 4.0 e Microsoft Windows 2000. In questi sistemi operativi tale messaggio di errore può essere visualizzato anche se non si dispone delle autorizzazioni di lettura per le chiavi Licenses contenute nel Registro di sistema. In questo caso seguire le procedure illustrate nel paragrafo "Se non si dispone delle autorizzazioni di lettura per la chiave Licenses" della sezione "Risoluzione" di questo articolo per assegnare a utenti e gruppi le autorizzazioni corrette per la lettura della chiave Licenses.

Risoluzione

Nota: se è in esecuzione Microsoft Windows 98, è possibile scaricare uno strumento che risolve il problema descritto in questo articolo. Se si utilizza un sistema operativo diverso da Windows 98, lo strumento potrebbe tuttavia non funzionare correttamente.

Per ulteriori informazioni sul download di questo strumento, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito:
191224  (http://support.microsoft.com/kb/191224/ ) ACC97: AcLicn97.exe disponibile nell'Area download Microsoft

Ridenominazione di un tipo di carattere e reinstallazione di Microsoft Access

Importante Se durante l'installazione di Access è stato visualizzato un messaggio di errore analogo a
Configurazione del driver ODBC Microsoft nome driver ed estensione non riuscita.
e successivamente viene visualizzato uno dei messaggi di errore menzionati nella sezione "Sintomi" del presente articolo, installare MDAC 2.8 o versione precedente dal sito Web Microsoft riportato di seguito.

Per ottenere MDAC 2.8, visitare il seguente sito Web Microsoft Developer Network (MSDN):
http://www.microsoft.com/downloads/details.aspx?displaylang=it&FamilyID=6c050fe3-c795-4b7d-b037-185d0506396c (http://www.microsoft.com/downloads/details.aspx?displaylang=it&FamilyID=6c050fe3-c795-4b7d-b037-185d0506396c)
Nota Nelle procedure riportate di seguito, per reinstallare Microsoft Access 97 utilizzando la modalità di manutenzione, non è necessario disinstallare prima il programma. Questa operazione ripristina semplicemente lo stato di installazione del sistema precedente all'ultima esecuzione dell'installazione.

Attenersi alla seguente procedura per correggere l'errore nel Registro di sistema.

Nota Data l'esistenza di varie versioni di Windows, la procedura descritta di seguito potrebbe risultare diversa da computer a computer. In tal caso, consultare la documentazione relativa alla propria versione di Windows per completare la procedura. Se è in esecuzione Microsoft Windows Millennium Edition, seguire la procedura descritta nella sezione "Procedura per Microsoft Windows Millennium Edition" più avanti in questo articolo.
  1. Chiudere tutti i programmi di Microsoft Office in esecuzione nel computer.
  2. Fare clic sul pulsante Start, scegliere Trova, quindi File o cartelle.
  3. Nella casella Nome digitare hatten.ttf.
  4. Nella casella Cerca in digitare c:\windows\fonts.

    Nota
    Il percorso della cartella Fonts può essere diverso a seconda del computer in uso.
  5. Scegliere Trova per avviare la ricerca.

    Nota Se il file Hatten.ttf non viene trovato, provare a cercare il file Haettenschweiler.ttf. Haettenschweiler è il nome completo del tipo di carattere Hatten.
  6. In Nome fare clic con il pulsante destro del mouse sul file hatten.ttf e scegliere Rinomina dal menu di scelta rapida.
  7. Modificare il nome del file in hatten.xxx. Se viene visualizzato un messaggio per informare l'utente che modificando l'estensione il file potrebbe diventare inutilizzabile, scegliere .
  8. Non chiudere la finestra di dialogo Trova, ma ridurla a icona.
  9. Fare clic sul pulsante Start, scegliere Impostazioni, quindi Pannello di controllo.
  10. Nel Pannello di controllo fare doppio clic su Installazione applicazioni.
  11. Nella finestra di dialogo Installazione applicazioni scegliere la scheda Installa/Rimuovi e selezionare Microsoft Office 97 Professional Edition nell'elenco dei programmi.
  12. Scegliere Aggiungi/Rimuovi per eseguire il programma di installazione di Office in modalità manutenzione.
  13. Nella finestra di dialogo Installazione di Microsoft Office 97 fare clic su Reinstalla.
  14. Dopo avere completato la reinstallazione, fare clic sulla finestra di dialogo Trova sulla barra delle applicazioni per ingrandirla.
  15. In Nome fare clic con il pulsante destro del mouse sul file hatten.xxx e scegliere Rinomina dal menu di scelta rapida.
  16. Modificare nuovamente il nome del file in hatten.ttf.
A questo punto Microsoft Access è registrato.

Procedura per Microsoft Windows Millennium Edition

Importante Se durante l'installazione di Access è stato visualizzato un messaggio di errore analogo a
Configurazione del driver ODBC Microsoft nome driver ed estensione non riuscita.
e successivamente viene visualizzato uno dei messaggi di errore menzionato nella sezione "Sintomi" del presente articolo, installare MDAC 2.8 o versione precedente dal sito Web Microsoft riportato di seguito:

È possibile effettuare il download di MDAC 2.8 dal seguente sito Web Microsoft:
http://www.microsoft.com/downloads/details.aspx?displaylang=it&FamilyID=6c050fe3-c795-4b7d-b037-185d0506396c (http://www.microsoft.com/downloads/details.aspx?displaylang=it&FamilyID=6c050fe3-c795-4b7d-b037-185d0506396c)
  1. Chiudere tutti i programmi di Microsoft Office in esecuzione nel computer.
  2. Fare clic sul pulsante Start, scegliere Programmi, Accessori e infine Prompt di MS-DOS.
  3. Al prompt di MS-DOS digitare cd fonts e premere INVIO.
  4. Al prompt di MS-DOS digitare ren hatten.ttf hatten.old e premere INVIO.

    Nota A questo punto è possibile che venga visualizzato il seguente messaggio di errore.
    Nome file duplicato o file già in uso.
    In tal caso, seguire questa procedura anziché i passaggi dall'1 al 4 per rinominare il tipo di carattere:
    1. Riavviare il computer dopo avere inserito il disco di avvio nell'unità disco floppy.
    2. Nella schermata di avvio scegliere l'opzione 4 corrispondente all'avvio minimo.
    3. Al prompt di MS-DOS digitare c: e premere INVIO.
    4. Al prompt di MS-DOS digitare cd windows\fonts e premere INVIO.
    5. Al prompt di MS-DOS digitare ren hatten.ttf hatten.old e premere INVIO.
  5. Riavviare il computer.
  6. Fare clic sul pulsante Start, scegliere Impostazioni, quindi Pannello di controllo.
  7. Nel Pannello di controllo fare doppio clic su Installazione applicazioni.
  8. Nella finestra di dialogo Installazione applicazioni scegliere la scheda Installa/Rimuovi e selezionare Microsoft Office 97 Professional Edition nell'elenco dei programmi.
  9. Scegliere Aggiungi/Rimuovi per eseguire il programma di installazione di Office in modalità manutenzione.
  10. Nella finestra di dialogo Installazione di Microsoft Office 97 fare clic su Reinstalla.
A questo punto Microsoft Access è registrato.

Se non si dispone delle autorizzazioni di lettura per la chiave Licenses

Avviso L'errata modifica del Registro di sistema tramite l'editor o un altro metodo può causare seri problemi, che potrebbero richiedere la reinstallazione del sistema operativo. Microsoft non è in grado di garantire la soluzione di problemi derivanti dall'errato utilizzo dell'editor del Registro di sistema. La modifica del Registro di sistema è a rischio e pericolo dell'utente.

Importante Le procedure illustrate in questa sezione riguardano solo i computer che eseguono Microsoft Windows NT 4.0 o Microsoft Windows 2000.

Quando si accede come amministratore a un computer con Windows NT 4.0 o Windows 2000, è possibile utilizzare l'editor del Registro di sistema per controllare e modificare le autorizzazioni di accesso degli utenti alle diverse chiavi del Registro di sistema.

Per esaminare le autorizzazioni degli utenti, attenersi alla seguente procedura:
  1. Accedere come amministratore al computer in cui si è verificato il problema.
  2. Fare clic sul pulsante Start, scegliere Esegui, digitare regedt32, quindi scegliere OK.
  3. Selezionare la chiave \\HKEY_CLASSES_ROOT\Licenses.
  4. Scegliere Autorizzazioni dal menu Protezione.
  5. Verificare che gli utenti e i gruppi necessari dispongano almeno delle autorizzazioni di lettura per la chiave.
  6. Chiudere l'editor del Registro di sistema e riavviare il computer.
Accedendo al sistema come normale utente, si dovrebbe ora essere in grado di avviare Microsoft Access senza problemi.

Status

Microsoft ha confermato che questo problema si verifica con i prodotti elencati alla fine di questo articolo.

Informazioni

Per ulteriori informazioni sull'installazione di Access 97 e Access 2000 nello stesso computer, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito:
241141  (http://support.microsoft.com/kb/241141/ ) Installazione di Access 97 e Access 2000 nello stesso computer

Le informazioni in questo articolo si applicano a:
  • Microsoft Access 95 Standard Edition
  • Microsoft Access 97 Standard Edition
Chiavi: 
kbpubtypekc kberrmsg kbprb kbsetup KB141373
LE INFORMAZIONI CONTENUTE NELLA MICROSOFT KNOWLEDGE BASE SONO FORNITE SENZA GARANZIA DI ALCUN TIPO, IMPLICITA OD ESPLICITA, COMPRESA QUELLA RIGUARDO ALLA COMMERCIALIZZAZIONE E/O COMPATIBILITA' IN IMPIEGHI PARTICOLARI. L'UTENTE SI ASSUME L'INTERA RESPONSABILITA' PER L'UTILIZZO DI QUESTE INFORMAZIONI. IN NESSUN CASO MICROSOFT CORPORATION E I SUOI FORNITORI SI RENDONO RESPONSABILI PER DANNI DIRETTI, INDIRETTI O ACCIDENTALI CHE POSSANO PROVOCARE PERDITA DI DENARO O DI DATI, ANCHE SE MICROSOFT O I SUOI FORNITORI FOSSERO STATI AVVISATI. IL DOCUMENTO PUO' ESSERE COPIATO E DISTRIBUITO ALLE SEGUENTI CONDIZIONI: 1) IL TESTO DEVE ESSERE COPIATO INTEGRALMENTE E TUTTE LE PAGINE DEVONO ESSERE INCLUSE. 2) I PROGRAMMI SE PRESENTI, DEVONO ESSERE COPIATI SENZA MODIFICHE, 3) IL DOCUMENTO DEVE ESSERE DISTRIBUITO INTERAMENTE IN OGNI SUA PARTE. 4) IL DOCUMENTO NON PUO' ESSERE DISTRIBUITO A SCOPO DI LUCRO.
Retired KB ArticleDichiarazione di non responsabilità per articoli della Microsoft Knowledge Base su prodotti non più supportati
Questo articolo è stato scritto sui prodotti per cui Microsoft non offre più supporto. L?articolo, quindi, viene offerto ?così come è? e non verrà più aggiornato.
 

Traduzione articoli