PRJ: How to Print Specific Tasks from a View

Article translations Article translations
Article ID: 141654 - View products that this article applies to.
This article was previously published under Q141654
Expand all | Collapse all

On This Page

SUMMARY

In Microsoft Project, when you print a view such as a Gantt Chart, it is possible to print only a selected group of tasks and/or a specific timescale.

MORE INFORMATION

Selecting Specific Tasks

If there is a common attribute for the desired tasks, you can apply a filter to the view to eliminate tasks that do not satisfy the criteria of the filter. In a task view, for example, the Date Range filter displays only tasks that exist between two specified dates; the Task Range filter shows a block of tasks between two specified ID numbers.

If the tasks to be printed have no common criteria, it is possible to "tag" the desired tasks by setting values in each tasks' Marked field to "Yes." A filter then can be constructed that filters only tasks that have "Yes" in their Marked fields.

NOTE: The "Flag" fields can be used in the same manner as the "Marked" field.

To add the "Marked" field to your table in Microsoft Project 2010:

1.       Click the column that you want to be to the right of the inserted column (for instance, the Duration column).

2.       On the Format tab, click Insert Column.

3.       In the Field Name list, click Marked. Click OK.

 To add the "Marked" field to your table in Microsoft Project 2007 and earlier versions:
  1. Click the column that you want to be to the right of the inserted column (for instance, the Duration column).
  2. On the Insert menu, click Insert Column.
  3. In the Field Name list, click Marked. Click OK.
 To create a "Marked Tasks" filter in Microsoft Project 2010:

1.       On the View tab, click the Filter drop-down list, and then click More Filters.

2.       In the More Filters dialog box, click New.

3.       In the Name field, type "Marked Tasks" as the name for your new filter. Select the "Show In Menu" option.

4.       Under the Field Name column, type "Marked".

5.       Under the Test column, type "Equals".

6.       Under the Values column, type "Yes".

7.       Click Save.


To create a "Marked Tasks" filter in Microsoft Project 2007 and earlier versions:

  1. On the Project menu in Microsoft Project 98through 2007 (or the Tools menu in Microsoft Project versions 4.0 and 4.1), click Filtered For, and then click More Filters.
  2. In the More Filters dialog box, click New.
  3. In the Name field, type "Marked Tasks" as the name for your new filter. Select the "Show In Menu" option.
  4. Under the Field Name column, type "Marked".
  5. Under the Test column, type "Equals".
  6. Under the Values column, type "Yes".
  7. Click OK.
You can now click Apply to run the filter.

To print a specific timescale

 Many times, filtering is only the first step to get the desired output. Microsoft Project allows further flexibility to define the printout's date range. To use the date range functions in Microsoft Project 2010, follow these steps:

1.       On the File tab, click Print.

2.       In the Settings section, specify a range of dates for your output by typing the start and finish dates in the Dates and To fields.

NOTE: Microsoft Project uses the project start date and the project finish date as the default date range, even when you have filtered tasks unless the dates are manually specified as in step 2.

 To use the date range functions in Microsoft Project 2007 and earlier versions, follow these steps:

  1. On the File menu, click Print.

    The Print command is different from the Print button on the toolbar. The Print command must be used to define the date range.
  2. In the Timescale options, specify a range of dates for your output by typing the start and finish dates in the Dates From and Dates To fields.

    NOTE: Microsoft Project uses the project start date and the project finish date as the default date range, even when you have filtered tasks unless the dates are manually specified as in step 2.

NOTES ON OTHER VIEWS

Calendar View

After applying a filter, it may be necessary to use the Layout Now command on the Format menu to maximize the number of visible tasks. You may be limited in the number of visible tasks by the size of the date boxes in the calendar.

PERT Chart

It is not possible to filter a PERT chart view, nor can a specific timescale be printed. The PERT chart always shows all the tasks that exist in the project.

Resource Graph

Before applying a resource filter, it is necessary to specify how filtered resources will appear in the graph.

  1. On the Format tab in Microsoft Project 2010 (or the Format menu in Microsoft Project 2007 and earlier versions), click Bar Styles.
  2. Under Filtered Resources, on the left side, select a style for Overallocated and/or Allocated Resources.
  3. If you like, the individual resources can be shown in the graph relative to the filtered resources or Don't Show can be selected for Resources on the right side of the dialog box.

Sheet Views (Resource Sheet, Task Sheet)

Because these views do not have a timescale, they can only be filtered by the appropriate type of filter.

Resource Usage

These are similar to the Gantt views, except that you must create a resource filter for this view instead of a task filter.

REFERENCES

For additional information, click the following article number to view the article in the Microsoft Knowledge Base:
44582 PRJ: How to Create an Interactive Filter

Properties

Article ID: 141654 - Last Review: September 19, 2011 - Revision: 6.0
APPLIES TO
  • Microsoft Project 2000 Standard Edition
  • Microsoft Project 98 Standard Edition
  • Microsoft Project 4.1 Standard Edition
  • Microsoft Project 4.0 Standard Edition
  • Microsoft Project 4.0 for Macintosh
  • Microsoft Office Project Professional 2007
  • Microsoft Office Project Professional 2003
  • Microsoft Office Project Standard 2007
  • Microsoft Office Project Standard 2003
  • Microsoft Project 2002 Standard Edition
  • Microsoft Project 2002 Professional Edition
  • Microsoft Project Professional 2010
  • Microsoft Project Standard 2010
Keywords: 
kbhowto kbusage KB141654

Give Feedback

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com