Summary of methods to recover data from corrupted files

Article translations Article translations
Article ID: 142117 - View products that this article applies to.
This article was previously published under Q142117
For a Microsoft Excel 2000 version of this article, see 179871.
Expand all | Collapse all

On This Page

Summary

There are several methods that you can use to recover information from damaged or corrupted files. This article discusses those methods and points you to other Microsoft Knowledge Base articles that discuss the methods in greater detail.

Methods for Recovering Data in Corrupted Microsoft Excel Files

Save the File in the SYLK Format

If you can open the corrupted Microsoft Excel file, you can "filter" it by saving the file in the SYLK format, closing the file, and then reopening it.

Use the Revert To Saved Document Command to Recover Data

If you are editing a Microsoft Excel worksheet and the file accidentally becomes corrupted before you have saved changes to the file, you can recover the original worksheet by doing the following:

  1. On the File menu, click Open and select the name of the file that you are editing. Note that a dialog box appears with the message "Revert to Saved Document?"
  2. Click OK.

    The file that you are editing reverts to the last saved version of the file.

Use a Macro to Extract the Data in a Chart

In Microsoft Excel versions 5.0 and later, data may be retrieved from a chart, even when the data is in an external worksheet or workbook. This behavior can be useful in situations where the chart was created from or linked to another file that is unavailable or has been damaged in some way.

When the source data to a chart is lost, you can still retrieve the data from the chart itself by using a Visual Basic for Applications (VBA) macro.

For additional information, please see the following article in the Microsoft Knowledge Base:
137016 XL: Macro to Extract Data from a Chart

Use the Microsoft Excel 97 File Recovery Macro to Recover Information (Excel 97 only)

If you can open the workbook in Microsoft Excel 97, you can use the Microsoft Excel 97 File Recovery Macro to re-create Excel worksheets, XLM macro sheets, and module sheets in a new workbook. This macro also creates a log file so that you can identify items that cause problems when you use the macro to transfer them to the new worksheet. If the Microsoft Excel 97 File Recovery Macro fails, view the last entry in the log file to determine which item causes the problem, and then re-create the workbook without that item.

You can download this macro from Microsoft. The following file is available for download from the Microsoft Download Center:
Recover.exe
For additional information about how to download Microsoft Support files, click the following article number to view the article in the Microsoft Knowledge Base:
119591 How to Obtain Microsoft Support Files from Online Services
Microsoft scanned this file for viruses. Microsoft used the most current virus-detection software that was available on the date that the file was posted. The file is stored on security-enhanced servers that help to prevent any unauthorized changes to the file.

To find information about this macro in the "Office 97 Resource Kit" book, see Appendix A, pages 1027-1028. Note that the macro is referenced by the Cleaner.xla add-in that contains it.

To find this macro in the Office Resource Kit compact disc, insert the disc and open the following folder on the CD-ROM drive (usually drive D):
Excel\Recover
The macro on the disc is in the Cleaner.xla add-in.

Open the File in Microsoft Word or WordPad

If you have the Microsoft Excel converter installed, you may be able to open your Microsoft Excel workbook in Microsoft Word. If the file does open in Microsoft Word, you will not be able to recover module sheets, dialog sheets, chart sheets, macro sheets, or any embedded charts. Also, you will not recover any cell formulas, just the results of those formulas that are currently in the cells.

You can also open your Microsoft Excel workbook in WordPad. If the file does open, you may be able to recover Visual Basic code in your modules and class modules. Search for the words "Sub" or "Function" to find your code.

Open the File in Microsoft Excel Viewer

If Microsoft Excel Viewer is installed, you may be able to open the Microsoft Excel workbook in Microsoft Excel Viewer, copy the cells and paste the cells into a new workbook. However, you cannot recover module sheets, dialog sheets, chart sheets, or macro sheets. Also, you cannot recover any cell formulas; you can recover only the results of the formulas that are currently in the cells.

For more information about Microsoft Excel Viewer, use your Web browser to go to the following Microsoft Web site:
Excel Viewer

Set the Recalculation Option to Manual Before Opening the File

You may be able to open the file if you set the recalculation option to manual. To do this, follow these steps:
  1. Start Excel.

    You should see a blank workbook on the screen.
  2. On the Tools menu, click Options.
  3. Click the Calculation tab.
  4. In the Calculation section, click Manual, and then click OK.
  5. On the File menu, click Open and try to open the file.

References

"Microsoft Excel User's Guide 1," version 4.0, pages 157-158, 365-371

"Microsoft Excel User's Guide 2," version 4.0, pages 126-132

"Microsoft Excel User's Guide," version 3.0, pages 280-282, 307-316

Properties

Article ID: 142117 - Last Review: July 27, 2012 - Revision: 3.0
Applies to
  • Microsoft Excel 97 Standard Edition
  • Microsoft Excel 95 Standard Edition
  • Microsoft Excel 2.0 Standard Edition
  • Microsoft Excel 3.0 Standard Edition
  • Microsoft Excel 4.0 Standard Edition
  • Microsoft Excel 5.0 Standard Edition
  • Microsoft Excel 2001 for Mac
  • Microsoft Excel 98 for Macintosh
  • Microsoft Excel 2.2 for Macintosh
  • Microsoft Excel 3.0 for Macintosh
  • Microsoft Excel 4.0 for Macintosh
  • Microsoft Excel 5.0 for Macintosh
Keywords: 
kbdownload kbinfo KB142117
Retired KB Content Disclaimer
This article was written about products for which Microsoft no longer offers support. Therefore, this article is offered "as is" and will no longer be updated.

Give Feedback

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com