Resumo dos métodos para recuperar dados de ficheiros danificados

Traduções deste artigo Traduções deste artigo
ID do artigo: 142117 - Exibir os produtos aos quais esse artigo se aplica.
Para obter uma versão deste artigo do Microsoft Excel 2000, consulte 179871.
Expandir tudo | Recolher tudo

Neste artigo

Sumário

Há vários métodos que você pode usar para recuperar informações de arquivos danificados ou corrompidos. Este artigo discute esses métodos e pontos que você para outros Microsoft Knowledge Base artigos que discutem os métodos mais detalhadamente.

Métodos para recuperação de dados em arquivos corrompidos do Microsoft Excel

Salve o arquivo no formato SYLK

Se você conseguir abrir o arquivo corrompido do Microsoft Excel, você poderá "filtrá-lo" salvar o arquivo no formato SYLK, fechando o arquivo e reabri-la.

Use o reverter para documento salvo comando para recuperar dados

Se você estiver editando uma planilha do Microsoft Excel e o arquivo for corrompido acidentalmente antes de salvar as alterações no arquivo, você pode recuperar a planilha original, fazendo o seguinte:

  1. No menu Arquivo, clique em Abrir e selecione o nome do Oarquivo que você está editando. Observe que uma caixa de diálogo aparece com a mensagem "Reverter para documento salvo?"
  2. Clique em OK.

    O arquivo que você está editando a última versão salva do arquivo revertsto.

Utilizar uma Macro para extrair os dados em um gráfico

No Microsoft Excel versões 5.0 e posteriores, os dados podem ser recuperados de um gráfico, mesmo quando os dados estiverem em uma planilha externa ou pasta de trabalho. Esse comportamento pode ser útil em situações em que o gráfico foi criado a partir de ou vinculado a outro arquivo que está indisponível ou foi danificado de alguma forma.

Quando os dados de origem para um gráfico são perdidos, você ainda pode recuperar os dados do próprio gráfico usando um Visual Basic for Applications macro (VBA).

Para obter informações adicionais, consulte o seguinte artigo da Base de dados de Conhecimento da Microsoft:
137016 XL: Macro para extrair dados de um gráfico

Usar as macros de recuperação de arquivo do Microsoft Excel 97 para recuperar informações (somente no Excel 97)

Se você pode abrir a pasta de trabalho no Microsoft Excel 97, você pode usar as macros de recuperação de arquivo do Microsoft Excel 97 para recriar em planilhas do Excel, folhas de macro XLM e folhas de módulo em uma nova pasta de trabalho. Esta macro também cria um arquivo de log para que você possa identificar itens que causam problemas quando você usar a macro para transferi-los para a nova planilha. Se as macros de recuperação de arquivo do Microsoft Excel 97 falhar, exibir a última entrada no arquivo de log para determinar o item que causa o problema e, em seguida, crie novamente a pasta de trabalho sem esse item.

Você pode baixar essa macro da Microsoft. O seguinte arquivo está disponível para download no Microsoft Download Center:
Recover.exe
Para obter informações adicionais sobre como baixar arquivos do Microsoft Support, clique no número abaixo para ler o artigo na Base de dados de Conhecimento Microsoft:
119591 Como obter arquivos de suporte da Microsoft de serviços Online
Microsoft examinou esse arquivo em busca de vírus. A Microsoft usou o mais recente software de detecção de vírus que estava disponível na data em que o arquivo foi publicado. O arquivo está armazenado em servidores de segurança avançada que ajudam a evitar qualquer alteração não autorizada no arquivo.

Para obter informações sobre essa macro no livro "Office 97 Resource Kit", consulte o Apêndice A, páginas 1027-1028. Observe que a macro é referenciada pelo suplemento Cleaner.xla que o contém.

Para localizar essa macro no CD do Office Resource Kit, insira o disco e abra a seguinte pasta na unidade de CD-ROM (normalmente a unidade D):
Excel\Recover
A macro no disco está no suplemento Cleaner.xla.

Abra o arquivo no Microsoft Word ou no WordPad

Se você tiver o conversor do Microsoft Excel instalado, você poderá abrir a pasta de trabalho do Microsoft Excel no Microsoft Word. Se o arquivo abrir no Microsoft Word, você não poderá recuperar folhas de módulos, folhas de diálogo, planilhas de gráfico, folhas de macro ou os gráficos incorporados. Além disso, você não poderá recuperar quaisquer fórmulas das células, apenas os resultados dessas fórmulas que estão atualmente nas células.

Você também pode abrir sua pasta de trabalho do Microsoft Excel no WordPad. Se o arquivo for aberto, você poderá recuperar o código do Visual Basic em seus módulos e módulos de classe. Procure as palavras "Sub" ou "Function" para localizar o código.

Abra o arquivo no Microsoft Excel Viewer

Se o Microsoft Excel Viewer estiver instalado, você poderá abrir a pasta de trabalho do Microsoft Excel no Microsoft Excel Viewer, copiar as células e cola as células em uma nova pasta de trabalho. No entanto, você não poderá recuperar folhas de módulos, planilhas de diálogo, planilhas de gráfico ou folhas de macro. Além disso, você não poderá recuperar quaisquer fórmulas das células; Você pode recuperar somente os resultados das fórmulas que estão atualmente nas células.

Para obter mais informações sobre o Microsoft Excel Viewer, use seu navegador da Web para ir ao site da Microsoft:
Visualizador do Excel

Definir a opção de recálculo manual antes de abrir o arquivo.

Você poderá abrir o arquivo se você definir a opção de recálculo manual. Para fazer isso, execute as seguintes etapas:
  1. Inicie o Excel.

    Você deve ver uma pasta de trabalho em branco na tela.
  2. Sobre o Ferramentas menu, clique em Opções.
  3. Clique no Cálculo guia.
  4. Na Cálculo seção, clique em Manuale, em seguida, clique em OK.
  5. Sobre o Arquivo menu, clique em Abrir e tente abri-lo.

Referências

"Guia do usuário do Microsoft Excel 1," versão 4.0, páginas 157 158, 365-371

"Guia do usuário do Microsoft Excel 2," versão 4.0, páginas 126 132

"Guia do usuário do Microsoft Excel", versão 3.0, páginas 280 282, 316 307

Propriedades

ID do artigo: 142117 - Última revisão: domingo, 9 de fevereiro de 2014 - Revisão: 2.0
A informação contida neste artigo aplica-se a:
  • Microsoft Excel 97 Standard Edition
  • Microsoft Excel 95 Standard Edition
  • Microsoft Excel 2.0 Standard Edition
  • Microsoft Excel 3.0 Standard Edition
  • Microsoft Excel 4.0 Standard Edition
  • Microsoft Excel 5.0 Standard Edition
  • Microsoft Excel 2001 para Mac
  • Microsoft Excel 98 for Macintosh
  • Microsoft Excel 2.2 for Macintosh
  • Microsoft Excel 3.0 for Macintosh
  • Microsoft Excel 4.0 for Macintosh
  • Microsoft Excel 5.0 for Macintosh
Palavras-chave: 
kbdownload kbinfo kbmt KB142117 KbMtpt
Tradução automática
IMPORTANTE: Este artigo foi traduzido pelo software de tradução automática da Microsoft e eventualmente pode ter sido editado pela Microsoft Community através da tecnologia Community Translation Framework (CTF) ou por um tradutor profissional. A Microsoft oferece artigos traduzidos automaticamente por software, por tradutores profissionais e editados pela comunidade para que você tenha acesso a todos os artigos de nossa Base de Conhecimento em diversos idiomas. No entanto, um artigo traduzido pode conter erros de vocabulário, sintaxe e/ou gramática. A Microsoft não é responsável por qualquer inexatidão, erro ou dano causado por qualquer tradução imprecisa do conteúdo ou por seu uso pelos nossos clientes.
Clique aqui para ver a versão em Inglês deste artigo: 142117
Aviso de Isenção de Responsabilidade sobre Conteúdo do KB Aposentado
Este artigo trata de produtos para os quais a Microsoft não mais oferece suporte. Por esta razão, este artigo é oferecido "como está" e não será mais atualizado.

Submeter comentários

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com