Using the UNDELETE Command in Windows 95

Article translations Article translations
Article ID: 142189 - View products that this article applies to.
This article was previously published under Q142189
This article has been archived. It is offered "as is" and will no longer be updated.
Expand all | Collapse all

Symptoms

If you try to use the MS-DOS UNDELETE command in Windows 95, you may receive the following error message:
Windows has disabled direct disk access to protect long filenames. To override this protection, see the LOCK /? command for more information.

The system has been halted. Press CTRL+ALT+DEL to restart your computer.

Cause

The UNDELETE command requires direct access to the drive. You must lock the drive before you issue the UNDELETE command.

Resolution

NOTE: The UNDELETE command runs in MS-DOS mode by default. You should run these commands in MS-DOS mode.

Lock the drive before you issue the UNDELETE command. To lock the drive, type
   lock <x>:
				
where <x> is the letter of the drive you want to lock.

When you are done using the UNDELETE command, unlock the drive by typing
   unlock <x>:
				
where <x> is the letter of the drive you want to unlock.

WARNING: Using the LOCK command enables direct disk access. A program that accesses the disk directly can destroy long file names. You should back up long file names before running a program that could harm them. To back up long file names, use the Lfnbk.exe program located in the Admin\Apptools\ Lfnbk folder on the Windows 95 CD-ROM. See the Lfnbk.txt file in the same folder for information about this program.

The Lfnbk.exe program is included in the CD-ROM version of Windows 95, but not in the floppy disk version. If you are using the floppy disk version of Windows 95 and you want to use Lfnbk.exe, please see the following article in the Microsoft Knowledge Base for information about the availability of Lfnbk.exe:
135315 CD-ROM Extras for Microsoft Windows 95 Upgrade

Properties

Article ID: 142189 - Last Review: October 26, 2013 - Revision: 2.0
Applies to
  • Microsoft Windows 95
Keywords: 
kbnosurvey kbarchive KB142189

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com