XL: How to Create Multiple Views and Create and Print a Report

Article translations Article translations
Article ID: 142529 - View products that this article applies to.
This article was previously published under Q142529
For a Microsoft Excel 2002 version of this article, see 291072.
For a Microsoft Excel 2000 version of this article, see 214258.
Expand all | Collapse all

On This Page

SUMMARY

A view is a picture of the worksheet that has specific characteristics associated with it, such as print settings and whether to include hidden rows and columns. In View Manager, under View Includes, you can select two check boxes:
  • The Print Settings check box. This option saves the currently selected print options with the view.
  • The Hidden Rows & Columns check box. This option saves hidden rows and columns with the view.
Typically, a report is made of multiple views. The "More Information" section of this article demonstrates how to create multiple views, how to create a report from those views, and how to print the report.

Note To use Report Manager or View Manager, you must have the respective add-in installed. If the add-ins are not listed in the Add- Ins dialog box, run Setup in maintenance mode to install them.

MORE INFORMATION

Creating the Views

  1. Click New on the File menu to open a new workbook.
  2. Type the following data in Sheet1:
          A1: View1   B1:   C1: View2
          A2: 1       B2:   C2: 1
          A3: 2       B3:   C3: 2
          A4: 3       B4:   C4: 3
          A5: 4       B5:   C5: 4
    					
  3. Select the range A1:A5 and set the print area to this range of cells.
  4. On the View menu, click Custom Views (or click View Manager in Microsoft Excel 5.0 or 7.0)
  5. Click Add, type View1, and then click OK.
  6. Select range C1:C5, and set the print area to this range of cells.
  7. On the View menu, click Custom Views (or View Manager).
  8. Click Add, type View2, and then click OK.

Creating a Simple Report

  1. In Microsoft Excel 7.0, Microsoft Excel 97 or Microsoft Excel 98 Macintosh Edition, click Report Manager on the View menu.

    In Microsoft Excel 5.x, click Report Manager on the File menu.
  2. Click Add.
  3. In the Report Name box, type MyReport.
  4. Under Section To Add, make sure the View check box is selected, select View1, and then click Add. Repeat this step to select View2.
  5. Click OK.

Printing the Report

  1. In the Print Report dialog box, click Print.
  2. In the Print dialog box, click OK.

REFERENCES

"Microsoft Excel User's Guide," version 5.0, Chapter 14, "Creating and Printing Custom Reports" and Chapter 32, "Changing How to View Your Worksheet"

For more information about Views and Reports, click Answer Wizard on the Help menu, and then type:
How Do I Print a Report

Properties

Article ID: 142529 - Last Review: August 18, 2005 - Revision: 2.1
APPLIES TO
  • Microsoft Excel 97 Standard Edition
  • Microsoft Excel 95 Standard Edition
  • Microsoft Excel 98 for Macintosh
Keywords: 
kbhowto kbualink97 KB142529
Retired KB Content Disclaimer
This article was written about products for which Microsoft no longer offers support. Therefore, this article is offered "as is" and will no longer be updated.

Give Feedback

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com