Evitar conflictos de recursos PCI en equipos basados en Intel

Seleccione idioma Seleccione idioma
Id. de artículo: 148501 - Ver los productos a los que se aplica este artículo
Expandir todo | Contraer todo

En esta página

Síntomas

En su equipo basado en Intel (basadas en x 86 procesador-) que ejecutan Windows NT, después de agregar otro dispositivo PCI, el sistema deja de responder (se bloquea) o el dispositivo PCI puede no funcionar.

Causa

Windows hardware abstracción capa (HAL) HAL asigna un recurso de memoria o dirección de puerto de E/s para el dispositivo PCI nuevo que se superpone con un dispositivo PCI existente, por lo tanto, provoque un conflicto de recursos PCI en el sistema.

En el funcionamiento normal, el BIOS del sistema es responsable de establecer los requisitos de recursos de dispositivo PCI. Cuando Windows carga, la HAL de Windows NT mueve a veces los recursos del dispositivo PCI. Dispositivos PCI son configurables dinámicamente. Sin embargo, a veces la HAL de Windows NT asigna direcciones de puerto de E/s superpuestas o recursos de memoria para los dispositivos PCI.

Solución

Para resolver este problema, actualice a Windows NT 4.0 y siga las instrucciones bajo Windows NT 4.0 actualización información siguiente. Para solucionar esta problema, utilizar una de las siguientes soluciones.

Información de actualización de Windows NT 4.0

En Windows NT 4.0, una opción se ha agregado al archivo Boot.ini que la x 86 HAL pueden reconocer. Tenga en cuenta que sólo los HAL enviada por Microsoft reconocerá este modificador. Cuando una HAL reconoce el /PCILOCK cambiar (opción), la HAL no permite el sistema operativo cambie los recursos del dispositivo PCI, siempre que la configuración del BIOS del sistema parece ser correcta y completa.

Si la adición de un adaptador PCI causa un bloqueo durante el arranque, quitar la tarjeta de adaptador PCI incorrecta. Reinicie el sistema y modifique el archivo Boot.ini agregando la opción /PCILOCK. Apagar el sistema, agregar la nueva tarjeta de adaptador y reiniciar el sistema.

El HAL de Windows NT 4.0 que actualmente tiene esta revisión en son: HAL.dll, HALMPS.DLL y HALAPIC.DLL.

Soluciones provisionales

Para solucionar este problema, siga una de las instrucciones que se muestran a continuación:
  • Insertar las tarjetas de adaptador PCI en una ranura PCI distinta. Esta opción no se aplica a dispositivos PCI integradas en la placa principal del sistema (placa base).

    -o bien -
  • Cambiar el orden de carga controladores para los adaptadores PCI en conflicto. Esto no es siempre posible cuando los tipos de controladores cargados tienen que estar en un orden predeterminado. Tenga mucho cuidado al modificar el registro como una configuración incorrecta puede provocar que el sistema sea inestable o reinicio.

Estado

Microsoft ha confirmado que trata de un problema en las versiones 3.5 y 3.51 de Windows NT. Microsoft ha corregido este problema en Windows NT 4.0 y en el Service Pack más reciente de Windows NT 3.51 EE.UU.. Para obtener información acerca de cómo obtener el Service Pack, consulte la siguiente palabra en Microsoft Knowledge Base (sin los espacios en blanco):
K DE V P A C E R S

Más información

Al escribir controladores de dispositivo para Windows NT, recuerde que la llamada a HalAssignSlotResources es la API que mueve los recursos PCI. Algunos controladores utiliza IoReportResourceUsage, como una alternativa de HalAssignSlotResources, con la configuración de recursos actual obtenida del espacio de configuración del dispositivo PCI. Las llamadas a HalGetBusData y HalGetBusDataByOffset pueden utilizarse para leer el espacio de configuración de dispositivo PCI. Este método sólo debe utilizarse como último recurso, como contradice con la finalidad de disponer de un bus configurable dinámicamente.

Propiedades

Id. de artículo: 148501 - Última revisión: miércoles, 01 de noviembre de 2006 - Versión: 2.1
La información de este artículo se refiere a:
  • Microsoft Windows NT Workstation 3.5
  • Microsoft Windows NT Workstation 3.51
  • Microsoft Windows NT Workstation 4.0 Developer Edition
  • Microsoft Windows NT Server 3.5
  • Microsoft Windows NT Server 3.51
  • Microsoft Windows NT Server 4.0 Standard Edition
Palabras clave: 
kbmt kbhardware KB148501 KbMtes
Traducción automática
IMPORTANTE: Este artículo ha sido traducido por un software de traducción automática de Microsoft (http://support.microsoft.com/gp/mtdetails) en lugar de un traductor humano. Microsoft le ofrece artículos traducidos por un traductor humano y artículos traducidos automáticamente para que tenga acceso en su propio idioma a todos los artículos de nuestra base de conocimientos (Knowledge Base). Sin embargo, los artículos traducidos automáticamente pueden contener errores en el vocabulario, la sintaxis o la gramática, como los que un extranjero podría cometer al hablar el idioma. Microsoft no se hace responsable de cualquier imprecisión, error o daño ocasionado por una mala traducción del contenido o como consecuencia de su utilización por nuestros clientes. Microsoft suele actualizar el software de traducción frecuentemente.
Haga clic aquí para ver el artículo original (en inglés): 148501

Enviar comentarios

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com