Artigo: 148925 - Última revisão: sexta-feira, 11 de Agosto de 2006 - Revisão: 3.0

A palavra-passe de 'Acesso telefónico à rede' não é guardada

Dica do SistemaEste artigo aplica-se a um sistema operativo diferente do que está a utilizar. Foi desactivado o conteúdo do artigo, que pode não ser relevante para si.
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IMPORTANTE: Este artigo contém informações sobre a edição do registo. Antes de editar o registo, certifique-se de que compreende como o pode restaurar caso ocorra um problema. Para obter informações sobre como o fazer, consulte o tópico de ajuda Restaurar o registo no Regedit.exe ou o tópico de ajuda Restoring a Registry Key no Regedt32.exe.

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Sintomas

Quando tenta guardar a palavra-passe durante o estabelecimento de uma ligação de Acesso telefónico à rede clicando na caixa de verificação Guardar palavra-passe, a palavra-passe pode não ser guardada. Este problema pode ocorrer mesmo que tenha conseguido estabelecer ligação ao servidor com êxito e que a sua palavra-passe não tenha sido alterada. Este problema também pode ocorrer se o nome de utilizador contiver caracteres que não são permitidos num nome de ficheiro. Por exemplo, nome/utilizador teria como resultado um ficheiro .pwl chamado nome/utilizador.pwl

Causa

Este problema pode ser causado por qualquer uma das seguintes situações:
  • O ficheiro de lista de palavras-passe (.pwl) está danificado.
  • O ficheiro Rna.pwl (se existir) está danificado.
  • A colocação de palavras-passe em cache está desactivada.
  • O início de sessão automático está activado.
  • Um ou vários ficheiros associados à Ligação telefónica à rede está em falta ou danificado.
  • Os perfis de utilizador estão desactivados, mas a chave ProfilesList está presente no registo.
NOTA: Este problema pode ocorrer depois de instalar a actualização para a lista de palavras-passe do Microsoft Windows 95 que está incluída no Microsoft Windows 95 Service Pack 1 (SP1).

Para obter mais informações sobre esta actualização, consulte o seguinte artigo na Microsoft Knowledge Base:
143003  (http://support.microsoft.com/kb/143003/ ) Description of Microsoft Windows 95 Service Pack 1 Updates

Resolução

ATENÇÃO: A utilização incorrecta do Editor de registo pode causar problemas graves que poderão forçar a reinstalação do sistema operativo. A Microsoft não garante que os problemas resultantes da utilização incorrecta do Editor de registo possam ser resolvidos. Todo e qualquer risco decorrente da utilização do Editor de registo é da responsabilidade do utilizador.

Para obter informações sobre como editar o registo, consulte o tópico de ajuda Alterar chaves e valores do Editor de registo ou os tópicos de ajuda Add and Delete Information in the Registry e Edit Registry Data do Regedt32.exe. Não se esqueça de que deve efectuar uma cópia de segurança do registo antes proceder à respectiva edição. Se estiver a utilizar o Windows NT ou o Windows 2000, também deverá actualizar o disco de reparação de emergência (ERD, Emergency Repair Disk).

Windows 2000



Verifique as definições de Rede de Ligação de acesso telefónico. Para o fazer, clique com o botão direito do rato em Ligação de acesso telefónico e, em seguida, clique em Propriedades. No separador Rede, confirme que instalou o Cliente para redes Microsoft e que este está seleccionado.

Windows 95 e Windows 98



  1. Mude o nome ao ficheiro .pwl.

    NOTA: Se estiver a utilizar um certificado pessoal, deverá exportá-lo antes de mudar o nome ao ficheiro .pwl. Se não o fizer, o certificado pessoal poderá não estar disponível quando enviar correio electrónico. Para mais informações, consulte o seguinte artigo na Microsoft Knowledge Base:
    190296  (http://support.microsoft.com/kb/190296/PT/ ) OLEXP: Não é possível utilizar certificados pessoais no Outlook Express
    Para mudar o nome ao ficheiro .pwl, escreva o seguinte comando numa linha de comandos e, em seguida, prima ENTER:
    ren c:\<windows>\<nome_utilizador>.pwl<nome_utilizador>.xxx
    Onde <windows> é o nome da pasta do Windows e <nome_utilizador> é o nome de utilizador que utiliza para iniciar sessão no Windows 95. Depois de mudar o nome ao ficheiro .pwl, reinicie o computador.

    Quando a caixa de diálogo Introduza a palavra-passe de rede ou Bem-vindo ao Windows for apresentada, escreva a palavra-passe que utiliza normalmente e, em seguida, clique em OK. Quando lhe for pedido para confirmar a palavra-passe que acabou de introduzir, escreva a palavra-passe novamente na caixa Confirmar nova palavra-passe e, em seguida, clique em OK.

    NOTA: Se não existirem ficheiros .pwl na unidade (por exemplo, se o utilizador tiver premido a tecla ESC quando lhe foi pedida uma palavra-passe durante o arranque do Windows), a colocação de palavras-passe em cache não estará activa. O utilizador tem de iniciar sessão na rede primeiro para poder criar um ficheiro .pwl.
  2. Mude o nome ao ficheiro Rna.pwl na pasta do Windows. Para o fazer, escreva o seguinte comando numa linha de comandos e, em seguida, prima ENTER:
    ren c:\<windows>\rna.pwl rna.xxx
    Onde <windows> é o nome da pasta do Windows. Depois de mudar o nome ao ficheiro Rna.pwl, reinicie o computador.

    NOTA: O ficheiro Rna.pwl pode não existir no computador. Este ficheiro não é requerido em algumas configurações.
  3. Verifique se a colocação de palavras-passe em cache está activada. Para o fazer, utilize o Editor de registo para consultar o valor DWORD de DisablePwdCaching na seguinte chave do registo:
    HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Policies\Network
    Se a colocação de palavras-passe em cache estiver desactivada, DisablePwdCaching tem um valor de 1. Para activar a colocação de palavras-passe em cache, altere o valor para 0 .

    NOTA: Se o valor DisablePwdCaching não existir, adicione este valor DWORD de 0 à chave do registo listada acima. Poderá ter de remover este valor totalmente e, em seguida, reiniciar o computador para que a colocação de palavras-passe em cache funcione.
  4. Desactive o início de sessão automático. Para o fazer, elimine o valor binário de AutoLogon da seguinte chave do registo:
    HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Network\Real Mode Net
  5. Remova o Acesso telefónico à rede e, em seguida, reinstale-o. Para o fazer, siga estes passos:

    1. Nas Propriedades de rede, anote cada componente existente em Rede e as respectivas informações de configuração. Para o fazer, utilize os seguintes passos:
      1. Clique em Iniciar, aponte para Definições, clique em Painel de controlo e, em seguida, clique duas vezes em Rede.
      2. Clique num componente no separador Configuração, clique em Propriedades e, em seguida, anote todas as definições desse componente. Repita este processo com outro componente até ter anotado as informações de configuração de todos os componentes.
    2. Clique em Iniciar, aponte para Definições, clique em Painel de controlo e, em seguida, clique duas vezes em Adicionar/remover programas.
    3. Clique no separador Programa de configuração do Windows.
    4. Clique em Comunicações e, em seguida, clique em Detalhes.
    5. Clique na caixa de verificação Acesso telefónico à rede para o desmarcar, clique em OK e, em seguida, reinicie o computador se lhe for pedido para o fazer.
    6. Repita os passos A-C.
    7. Clique na caixa de verificação Acesso telefónico à rede para a seleccionar e, em seguida, clique em OK.

      NOTA: Poderá receber mensagens de erro conflito de versões durante este processo. Se tal acontecer, clique em Não quando lhe for perguntado se pretende manter a versão mais recente de cada ficheiro.
    8. Se estiver a utilizar a MSN, The Microsoft Network, versão 2.51, reinstale este programa.
  6. Mesmo que os perfis de utilizador estejam desactivados, siga os passos descritos no seguinte artigo da Microsoft Knowledge Base para remover a chave ProfilesList do registo:
    156826  (http://support.microsoft.com/kb/156826/ ) How to Disable and Delete User Profiles
Se estiver a executar o Windows 95, poderá ter de adicionar o TCP/IP nas Propriedades de rede. Para o fazer, siga estes passos:
  1. Clique em Iniciar, aponte para Definições, clique em Painel de controlo e, em seguida, clique duas vezes em Rede.
  2. Clique em Protocolo, clique em Adicionar, clique em Microsoft na caixa Fabricantes, clique em TCP/IP e, em seguida, clique em OK.

Mais Informação

Para obter informações adicionais sobre esta questão, consulte o seguinte artigo na Microsoft Knowledge Base:
141858  (http://support.microsoft.com/kb/141858/PT/ ) A caixa de diálogo 'Início de sessão do Windows' ou 'Início de sessão de rede' não é apresentada após o arranque do Windows
Para obter informações adicionais sobre problemas que podem ocorrer quando se tenta guardar palavras-passe no Windows 95, consulte os seguintes artigos na Microsoft Knowledge Base:
135197  (http://support.microsoft.com/kb/135197/ ) Damaged Password List File Does Not Save Passwords
137361  (http://support.microsoft.com/kb/137361/PT/ ) A caixa de verificação 'Guardar palavra-passe' não está disponível
141858  (http://support.microsoft.com/kb/141858/PT/ ) A caixa de diálogo 'Início de sessão do Windows' ou 'Início de sessão de rede' não é apresentada após o arranque do Windows

A informação contida neste artigo aplica-se a:
  • Microsoft Windows 95
  • Microsoft Windows 98 Standard Edition
  • Microsoft Windows 2000 Professional Edition
  • Microsoft Windows Millennium Edition
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