ID do artigo: 148925 - Última revisão: sexta-feira, 13 de julho de 2007 - Revisão: 4.0

Senha do sistema de rede dial-up não é salva

Dica do SistemaEste artigo aplica-se a um sistema operativo diferente do que está a utilizar. Foi desactivado o conteúdo do artigo, que pode não ser relevante para si.
IMPORTANTE: Este artigo contém informações sobre como modificar o Registro. Antes de modificá-lo, faça um backup e certifique-se de que saiba como restaurá-lo caso ocorra algum problema. Para obter informações adicionais sobre como fazer backup, restaurar e modificar o Registro, clique no número abaixo para ler o artigo na Base de Dados de Conhecimento Microsoft (a página pode estar em inglês):
256986  (http://support.microsoft.com/kb/256986/PT-BR/ ) Descrição do Registro do Microsoft Windows

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Sintomas

Ao fazer uma conexão de acesso ao sistema de rede dial-up, se você tentar salvar a senha marcando a caixa de seleção Salvar senha, será possível que a senha não seja salva. Isso pode acontecer mesmo ao se conectar com êxito ao servidor e quando a senha não foi alterada. Este problema também pode ocorrer se o nome de usuário apresentar caracteres não-permitidos em um nome de arquivo, por exemplo, o nome de usuário "user/name" pode resultar em um nome de arquivo .pwl de User/name.pwl.

Causa

Esse problema pode ser causado devido a uma das seguintes condições:
  • O arquivo de lista de senhas (.pwl) está danificado.
  • O arquivo Rna.pwl (se existir) está danificado.
  • O armazenamento de senhas em cache está desabilitado.
  • O login automático está habilitado.
  • Um ou mais dos arquivos associados ao sistema de rede dial-up não existe ou está danificado.
  • Os perfis de usuários estão desabilitados, mas ProfilesList está no Registro.
OBSERVAÇÃO: Esse problema pode ocorrer após a instalação da atualização da lista de senha do Windows 95 inclusa no Windows 95 Service Pack 1 (SP1).

Para obter informações adicionais sobre essa atualização, clique no número abaixo para ler o artigo na Base de Dados de Conhecimento Microsoft (a página pode estar em inglês):
143003  (http://support.microsoft.com/kb/143003/EN-US/ ) Descrição das atualizações do Microsoft Windows 95 Service Pack 1 (SP1)


OBSERVAÇÃO: Outra condição é se o cliente para redes Microsoft não estiver instalado. Para resolver este problema: instale o cliente para redes Microsoft.

Resolução

Windows 2000

Verifique se as configurações de rede do "conectóide" do sistema de rede dial-up estão corretas:
  1. Clique com o botão direito do mouse no "conectóide" do sistema de rede dial-up e clique em Propriedades.
  2. Clique na guia Rede e confirme se o Cliente para redes Microsoft está instalado e selecionado.

Windows 95 e Windows 98

  1. Renomeie o arquivo .pwl.

    OBSERVAÇÃO: Caso esteja usando um certificado pessoal, exporte-o antes de renomear o arquivo .pwl. Caso contrário, o certificado pessoal pode não estar disponível ao enviar um email. Para obter informações adicionais, clique no número abaixo para ler o artigo na Base de Dados de Conhecimento Microsoft (a página pode estar em inglês):
    190296  (http://support.microsoft.com/kb/190296/PT-BR/ ) OLEXP: Não é possível usar os certificados pessoais no Outlook Express
    Para renomear o arquivo .pwl, digite a seguinte linha no prompt de comando e pressione ENTER (onde Windows é o nome da pasta do Windows e nome_do_usuário é o nome de usuário que você usa para fazer login no Windows):
    ren c:\Windows\nome_do_usuário.pwlnome_do_usuário.xxx
    Após renomear o arquivo .pwl, reinicie o computador.

    Quando a caixa de diálogo Digite a senha de rede ou Bem-vindo ao Windows for exibida, digite a senha que geralmente é usada e clique em OK. Quando for necessário confirmar a senha digitada, redigite-a na caixa Confirmar nova senha e clique em OK.

    OBSERVAÇÃO: Caso não haja arquivo .pwl na unidade (por exemplo, se você pressionar ESC quando a senha for solicitada no momento em que o Windows inicia) o armazenamento de senhas em cache está desabilitado. Primeiramente, é necessário fazer login para criar um arquivo .pwl.
  2. Renomeie o arquivo RNA.pwl na pasta do Windows. Para fazer isto, digite a seguinte linha no prompt de comando e pressione ENTER (em que Windows é o nome da pasta do Windows):
    ren c:\Windows\rna.pwl rna.xxx
    Após renomear o arquivo Rna.pwl, reinicie o computador.

    OBSERVAÇÃO: O arquivo Rna.pwl pode não existir em seu computador. Este arquivo não é solicitado em algumas configurações.
  3. Verifique se o armazenamento de senhas em cache está habilitado. Para fazer isto, é necessário usar o Editor do Registro.

    AVISO: O uso incorreto do Editor do Registro pode causar sérios problemas que talvez exijam a reinstalação do sistema operacional. A Microsoft não garante que os problemas resultantes do uso incorreto do Editor do Registro possam ser solucionados. O uso do Editor do Registro é de sua responsabilidade.

    Veja o valor DisablePwdCaching (um valor DWORD) na seguinte chave do Registro:
    HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Policies\Network
    Se o armazenamento de senhas em cache estiver desabilitado, o valor DisablePwdCaching tem o valor dos dados igual 1. Para habilitar o armazenamento de senhas em cache, altere o valor dos dados para 0.

    OBSERVAÇÃO: Se o valor DisablePwdCaching não existir, adicione a esse valor DWORD um valor dos dados igual a 0 para a chave do Registro acima. Talvez seja necessário excluir esse valor e reiniciar o computador para que o cache funcione.
  4. Desabilite o logon automático. Para fazer isto, exclua o valor AutoLogon (um valor binário) da seguinte chave do Registro:
    HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Network\Real Mode Net
  5. Remova o sistema de rede dial-up e reinstale-o:
    1. Nas propriedades de rede, registre cada componente de rede e suas informações de configuração:
      1. Clique em Iniciar, aponte para Configurações, clique em Painel de controle e clique duas vezes em Rede.
      2. Clique em um componente na guia Configuração, em Propriedades e registre todas as configurações do componente. Repita esse processo com outro componente até registrar todas as informações de configuração.
    2. Clique em Iniciar, aponte para Configurações, clique em Painel de controle e clique duas vezes em Adicionar ou remover programas.
    3. Clique na guia Instalação do Windows.
    4. Clique em Comunicações e em Detalhes.
    5. Desmarque a caixa de seleção Acesso à rede dial-up, clique em OK e reinicie o computador caso seja solicitado.
    6. Repita as etapas a até c.
    7. Marque a caixa de seleção Acesso à rede dial-up e clique em OK.

      OBSERVAÇÃO: Talvez algumas mensagens de erro de conflito de versões sejam exibidas durante esse processo. Caso isso aconteça, clique em Não quando for solicitado para manter a versão mais recente de cada arquivo.
    8. Se você estiver usando a versão 2.51 do MSN, reinstale o programa MSN.
  6. Mesmo que os perfis de usuário estejam desabilitado, remova ProfilesList do Registro.Para obter informações adicionais sobre como remover essa chave do Registro, clique no número abaixo para ler o artigo na Base de Dados de Conhecimento Microsoft (a página pode estar em inglês):
    156826  (http://support.microsoft.com/kb/156826/PT-BR/ ) Como desabilitar ou excluir perfis de usuários
Se estiver executando o Windows 95, talvez seja necessário adicionar um Protocolo TCP/IP nas propriedades de rede:
  1. Clique em Iniciar, aponte para Configurações, clique em Painel de controle e clique duas vezes em Rede.
  2. Clique em Protocolo, em Adicionar, em Microsoft na caixa Fabricantes, clique em TCP/IP e em OK.

Mais Informações

Para obter informações adicionais, clique nos números abaixo para ler os artigos na Base de Dados de Conhecimento Microsoft (alguns artigos podem estar em inglês):
141858  (http://support.microsoft.com/kb/141858/EN-US/ ) Nenhuma caixa de diálogo de logon do Windows ou da rede na inicialização
Para obter informações adicionais sobre os problemas que podem ocorrer ao tentar salvar senhas no Windows, clique no número abaixo para ler o artigo na Base de Dados de Conhecimento Microsoft (a página pode estar em inglês):
135197  (http://support.microsoft.com/kb/135197/EN-US/ ) Lista de arquivos de senha danificado não salva a senha
137361  (http://support.microsoft.com/kb/137361/EN-US/ ) Caixa de verificação Salvar senha está indisponível
141858  (http://support.microsoft.com/kb/141858/EN-US/ ) Nenhuma caixa de diálogo de logon do Windows ou da rede na inicialização

A informação contida neste artigo aplica-se a:
  • Microsoft Windows 2000 Professional Edition
  • Microsoft Windows Millennium Edition
  • Microsoft Windows 98 Second Edition
  • Microsoft Windows 98 Standard Edition
  • Microsoft Windows 95
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