Jak sbírat data o síťovém provozu pomocí nástroje Sledování sítě

Překlady článku Překlady článku
ID článku: 148942 - Produkty, které se vztahují k tomuto článku.
Rozbalit všechny záložky | Minimalizovat všechny záložky

Na této stránce

Souhrn

Účelem tohoto článku je poskytnout informace potřebné ke sběru dat o síťovém provozu v síti LAN pomocí nástroje Sledování sítě společnosti Microsoft. Text tohoto článku je převzat přímo ze souboru nápovědy k nástroji Sledování sítě a zde také naleznete podrobnější pokyny.

Další informace

Program Sledování sítě je síťový diagnostický nástroj, který monitoruje sítě LAN a poskytuje grafické zobrazení statistických údajů o síti. Správci sítí mohou tyto statistiky využívat při provádění běžných úloh souvisejících s řešením potíží, jako je nalezení vypnutého serveru nebo serveru, kterému je zasílán neúměrný počet pracovních požadavků. Nástroj Sledování sítě shromažďuje informace z datového proudu sítě a zobrazuje následující typy údajů:
  • zdrojová adresa počítače, který odeslal rámec do sítě (Jedná se o jedinečné číslo v hexadecimálním tvaru (o základu 16), které slouží k identifikaci daného počítače v síti.),
  • cílová adresa počítače, který rámec přijal,
  • protokoly použité k odeslání rámce,
  • data nebo část odesílané zprávy.
Proces, kterým nástroj Sledování sítě tyto informace shromažďuje, se nazývá sběr dat. Nástroj Sledování sítě standardně shromažďuje statistické údaje o všech rámcích, které v síti zjistí, a ukládá je do vyrovnávací paměti pro sběr dat, což je vyhrazená úložná oblast v paměti. Chcete-li sbírat statistické údaje pouze pro určitou dílčí skupinu rámců, můžete je izolovat vytvořením filtru pro sběr dat. Po ukončení sběru informací můžete vytvořit filtr zobrazení, který určí, jaká část ze sebraných informací se zobrazí v okně prohlížeče rámců v nástroji Sledování sítě.

Nástroj Sledování sítě lze použít pouze v počítačích vybavených síťovou kartou, která podporuje smíšený režim. Pokud nástroj Sledování sítě používáte ve vzdáleném počítači, nemusí být síťovou kartou podporující smíšený režim vybavena místní pracovní stanice, ale vzdálený počítač.

Chcete-li sběr dat používat v prostředí více sítí nebo potřebujete-li šetřit prostředky místního počítače, použijte Agenta sledování sítě, který umožňuje sbírat informace pomocí vzdáleného počítače se systémem Windows NT. Při vzdáleném sběru dat shromažďuje Agent sledování sítě statistické údaje ze vzdáleného počítače, a poté je odesílá do místního počítače, kde se zobrazují v místním okně Sledování sítě.

Data sebraná v místním nebo vzdáleném režimu lze uložit do textového souboru nebo souboru pro sběr dat, který můžete později otevřít a dále prozkoumat.

Poznámka: Podpora pro produkty společnosti Microsoft pokrývá funkce jádra nástroje Sledování sítě. Úlohy závislé na síti, jako je interpretace dat sebraných v síti, nejsou touto službou podporovány. Agent sledování sítě je podporován v systému Windows NT, nikoli však na pracovních stanicích se systémy Windows 3.1 a Windows for Workgroups.

Vytvoření seznamu adres

Chcete-li ve filtru pro sběr dat používat dvojice adres, měli byste nejprve vytvořit databázi adres. Po vybudování této databáze můžete adresy, které jsou v ní uvedeny, používat k určování dvojic adres ve filtru pro sběr dat.

Chcete-li vytvořit seznam adres, postupujte takto:
  1. V nabídce Sběr vyberte příkaz Spustit. Volitelně můžete v okně prohlížeče rámců otevřít soubor CAP.
  2. Po dokončení sběru dat zobrazte okno prohlížeče rámců výběrem příkazů Zastavit a Zobrazit z nabídky Sběr.
  3. V nabídce Zobrazit klepněte na příkaz Najít všechny názvy. Nástroj Sledování sítě zpracuje rámce a přidá je do databáze adres.
  4. Zavřete okno prohlížeče rámců a zobrazte okno sběru dat.
  5. V nabídce Sběr vyberte příkaz Filtr. Zobrazí se dialogové okno Filtr pro sběr dat.
  6. V dialogovém okně Filtr pro sběr dat poklepejte na řádek Dvojice adres. Můžete také vybrat možnost Adresa ve skupinovém rámečku Přidat.
Zobrazí se databáze adres, kterou jste vytvořili. Pomocí názvů v této databázi můžete určovat dvojice adres ve filtru pro sběr dat.

Sběr dat mezi dvěma počítači

Chcete-li monitorovat výměnu dat mezi dvěma počítači, postupujte takto:
  1. V nabídce Sběr vyberte příkaz Filtr. Zobrazí se dialogové okno Filtr pro sběr dat.
  2. Poklepáním na řádek LIBOVOLNÝ<->LIBOVOLNÝ zobrazte dialogové okno Adresový výraz.
  3. V levém podokně dialogového okna Adresový výraz vyberte adresu počítače.
  4. V pravém podokně dialogového okna Adresový výraz vyberte adresu druhého počítače.
Po výběru obou adres klepněte na tlačítko Další v horní části tohoto okna. Zobrazí se další pokyny.
  1. V podokně Směr dialogového okna vyberte jeden z následujících symbolů:
    • Chcete-li monitorovat data procházející mezi vybranými adresami v obou směrech, vyberte symbol <-->.
    • Chcete-li monitorovat pouze data odsílaná z adresy vybrané v levém okně na adresu vybranou v pravém okně, vyberte symbol -->.
  2. Klepněte na tlačítko OK.
  3. V dialogovém okně Filtr pro sběr dat klepněte na tlačítko OK.
  4. V nabídce Sběr vyberte příkaz Spustit.

Ukládání sebraných dat

Chcete-li uložit statistiku sběru dat do souboru pro sběr dat nebo uložit změny, které jste v souborech pro sběr dat provedli, použijte příkaz Uložit jako. Budete-li si později chtít prohlédnout rámce uložené do souboru, můžete tento soubor otevřít a zobrazit statistické údaje v okně prohlížeče rámců nástroje Sledování sítě.

Chcete-li uložit sebrané rámce do souboru pro sběr dat nebo do textového souboru, postupujte takto:
  1. Proveďte jednu z těchto akcí:
    • Na panelu nástrojů klepněte na tlačítko Uložit soubor.
      nebo
    • V nabídce Soubor vyberte příkaz Uložit jako.
  2. Proveďte některou z následujících akcí:
    • Chcete-li soubor uložit na aktuální jednotku a do aktuálního adresáře, zadejte název a příponu souboru do pole Název souboru. Ukládáte-li soubor po úpravě, nemůžete jej uložit do stejného adresáře pod původním názvem.
    • Chcete-li soubor uložit do sdílené síťové složky, k níž nejste připojeni, klepněte na tlačítko Síť a poté pomocí dialogového okna Připojit síťovou jednotku vytvořte připojení.
    • Chcete-li soubor uložit na jinou jednotku nebo do jiného adresáře, postupujte takto:
      1. V poli Jednotky vyberte novou jednotku.
      2. V poli Adresáře vyberte nový adresář.
      3. Zadejte název souboru.
  3. Chcete-li uložit pouze statistiky rámců splňující kritéria aktuálního filtru zobrazení, vyberte možnost Filtrováno.

    Tato možnost je k dispozici jen tehdy, ukládáte-li data z okna prohlížeče rámců.
  4. Chcete-li uložit určitý rozsah rámců, zadejte počáteční a koncové číslo rámce do polí Od a Do.
  5. Klepněte na tlačítko OK.
Poznámka: Při uložení rozsahu rámců do souboru pro sběr dat se změní čísla přiřazená rámcům. V souboru pro sběr dat jsou rámce číslovány vždy od 1 bez ohledu na to, jaká čísla byla přiřazena původním rámcům. Podobně použijete-li filtr zobrazení a poté filtrované rámce uložíte, budou rámce v souboru pro sběr dat číslovány od 1. Použijete-li však možnost Tisk do souboru v dialogovém okně Tisk, zůstanou zachována čísla, která byla rámcům přiřazena původně.

Nastavení velikosti vyrovnávací paměti

Výchozí velikost vyrovnávací paměti je 1 MB. Chcete-li vyrovnávací paměť zvětšit, aby nedocházelo ke ztrátám informací, postupujte takto:
  1. V nabídce Sběr klepněte na příkaz Nastavení vyrovnávací paměti.
  2. Zvyšte hodnotu nastavení Velikost vyrovnávací paměti (MB) a poté klepněte na tlačítko OK.

Trasování v prostředí WAN

V některých situacích můžete být vyzváni ke sběru dat o síťovém provozu mezi dvěma konkrétními počítači, mezi nimiž leží jeden nebo více směrovačů. V těchto případech může mít pracovník technické podpory v úmyslu analyzovat veškerý síťový provoz mezi prvním počítačem a jeho nejbližším směrovačem a mezi druhým počítačem a jeho nejbližším směrovačem. Většinou se pomocí této analýzy zjišťuje, zda na trase mezi oběma směrovači nedochází ke ztrátám nebo poškozování paketů. Aby byla obě trasování konzistentní a aby bylo možné číst údaje z obou trasování souběžně, je třeba před zahájením trasování synchronizovat systémové hodiny obou počítačů. Při synchronizaci času ve dvou počítačích postupujte takto:
  1. Vyberte počítač, podle nějž bude čas synchronizován.
  2. V druhém počítači zadejte příkaz
    net time \\název_počítače /set /yes
    , kde název_počítače je název počítače, který jste vybrali v kroku 1.
  3. Zadáním příkazu TIME v obou počítačích zkontrolujte, zda udávají stejný čas.
  4. Přejděte k vlastnímu trasování.

Zjišťování adres MAC

Pokud monitorovaný počítač pracuje:
  • se síťovým klientem založeným na systému MS-DOS, spusťte v tomto počítači příkaz MSD.
  • se systémem Windows for Workgroups 3.11 (protokol TCP/IP), zadejte na příkazový řádek příkaz IPCONFIG /ALL.
  • se systémem Windows 95, zadejte na příkazový řádek v místní pracovní stanici příkaz WINIPCFG.
  • se systémem MacOS, otevřete ovládací panel AppleTalk. Vyberte příkaz Uživatelský režim z nabídky Úpravy a přejděte do rozšířeného režimu. Na ovládacím panelu AppleTalk se objeví tlačítko Informace. Klepnutím na toto tlačítko získáte adresu MAC.
  • se systémem Windows NT a máte-li přístup k místní konzole, použijte jednu z následujících možností:
    • příkaz NET CONFIG SERVER na příkazovém řádku,
    • příkaz IPCONFIG /ALL na příkazovém řádku,
    • příkaz IPXROUTE config na příkazovém řádku,
    • příkaz arp -a na příkazovém řádku,
    • program Getmac.exe ze sady Windows NT Resource Kit,
    • program WinMSD.
  • se systémem Windows NT a máte-li k němu pouze vzdálený přístup, spusťte soubor Getmac.exe ze sady Windows NT Resource Kit.

Vlastnosti

ID článku: 148942 - Poslední aktualizace: 13. března 2006 - Revize: 7.0
Informace v tomto článku jsou určeny pro produkt:
  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Professional Edition
  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows 2000 Datacenter Server
  • Microsoft Windows 2000 Professional Edition
  • Microsoft Windows 2000 Server
  • Microsoft Windows NT Advanced Server 3.1
  • Microsoft Windows NT Advanced Server 3.1
  • Microsoft Windows NT Server 3.5
  • Microsoft Windows NT Server 3.51
  • Microsoft Windows NT Server 4.0 Standard Edition
  • Microsoft Windows NT Workstation 3.1
  • Microsoft Windows NT Workstation 3.5
  • Microsoft Windows NT Workstation 3.51
  • Microsoft Windows NT Workstation 4.0 Developer Edition
  • Microsoft Windows 98 Standard Edition
  • Microsoft Windows 95
  • Microsoft SNA Server 2.1
  • Microsoft SNA Server 3.0
  • Microsoft LAN Manager to Windows NT Advanced Server Upgrade
  • Microsoft Systems Management Server 1.0 Standard Edition
  • Microsoft Systems Management Server 1.1 Standard Edition
  • Microsoft Systems Management Server 1.2 Standard Edition
  • Microsoft LAN Manager 2.2c
  • Protokol Microsoft TCP/IP pro systém Windows for Workgroups 3.11
  • Microsoft TCP/IP for Windows for Workgroups 3.11a
  • Protokol Microsoft TCP/IP pro systém Windows for Workgroups 3.11b
  • Microsoft Windows for Workgroups 3.11
  • Microsoft Internet Information Server 1.0
  • Microsoft Host Integration Server 2000 Standard Edition
Klíčová slova: 
kbhowto KB148942

Dejte nám zpětnou vazbu

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com