Comment faire pour capturer le trafic réseau à l'aide du Moniteur réseau

Traductions disponibles Traductions disponibles
Numéro d'article: 148942 - Voir les produits auxquels s'applique cet article
Agrandir tout | Réduire tout

Sommaire

Résumé

Le but de cet article est de vous fournir les informations nécessaires à la capture du trafic d'un réseau local à l'aide du Moniteur réseau Microsoft. Le texte de cet article est tiré directement du fichier d'aide du Moniteur réseau et doit être référencé pour des instructions plus détaillées.

Plus d'informations

Le Moniteur réseau est un outil de diagnostic réseau qui contrôle les réseaux locaux et fournit un affichage graphique des statistiques du réseau. Les administrateurs réseau peuvent utiliser ces statistiques pour exécuter des tâches de dépannage courantes, telles que l'identification d'un serveur en panne ou qui reçoit un nombre disproportionné de requêtes de travail. Lorsqu'il recueille des informations à partir du flux de données du réseau, le Moniteur réseau affiche les types d'informations suivants :
  • l'adresse source de l'ordinateur qui a envoyé une trame sur le réseau. (Cette adresse est un nombre hexadécimal (ou base 16) unique qui identifie cet ordinateur sur le réseau.) ;
  • l'adresse de destination de l'ordinateur qui a reçu la trame ;
  • les protocoles utilisés pour envoyer la trame ;
  • les données ou une partie du message envoyé.
Le processus utilisé par le Moniteur réseau pour recueillir ces informations se nomme « capture ». Par défaut, le Moniteur réseau rassemble des statistiques sur toutes les trames détectées sur le réseau dans une mémoire tampon de capture, qui est une zone de stockage réservée en mémoire. Pour capturer des statistiques sur un sous-ensemble spécifique de trames, vous pouvez sélectionner ces trames en créant un filtre de capture. Lorsque vous avez fini de capturer des informations, vous pouvez créer un filtre d'affichage pour spécifier la proportion des informations capturées devant être affichées dans la fenêtre Observateur de trames du Moniteur réseau.

Pour utiliser le Moniteur réseau, votre ordinateur doit disposer d'une carte réseau qui prend en charge le mode de proximité. Si vous utilisez le Moniteur réseau sur un ordinateur distant, la station de travail locale n'a pas besoin de carte réseau qui prend en charge le mode de proximité, mais l'ordinateur distant doit disposer d'une telle carte.

Pour capturer des informations de plusieurs réseaux ou pour préserver les ressources locales, utilisez l'Agent du Moniteur réseau pour capturer des informations à l'aide d'un ordinateur Windows NT distant. Lorsque vous capturez à distance, l'Agent du Moniteur réseau rassemble des statistiques d'un ordinateur distant, puis envoie ces statistiques à votre ordinateur local où elles sont affichées dans une fenêtre Moniteur réseau locale.

Une fois les données capturées localement ou à distance, elles peuvent être enregistrées dans un fichier texte ou un fichier de capture et elles peuvent être ouvertes et examinées ultérieurement.

Remarque La fonctionnalité de base du Moniteur réseau, décrite dans l'aide, est prise en charge par les Services de support technique de Microsoft. Les tâches dépendant du réseau, telles que l'interprétation des données capturées, ne sont pas prises en charge. L'Agent du Moniteur réseau est pris en charge pour Windows NT, mais pas pour les stations de travail Windows 3.1 ni Windows pour Workgroups.

Création d'une liste d'adresses

Pour utiliser des paires d'adresses dans un filtre de capture, vous devez tout d'abord créer une base de données d'adresses. Une fois cette base de données créée, vous pouvez utiliser les adresses répertoriées dans la base de données pour spécifier des paires d'adresses dans un filtre de capture.

Pour créer une liste d'adresses, procédez comme suit :
  1. Dans le menu Capture, sélectionnez Démarrer. Si vous le souhaitez, ouvrez un fichier .cap dans la fenêtre Observateur de trames.
  2. Une fois la capture terminée, sélectionnez Arrêter et Affichage dans le menu Capture pour afficher la fenêtre Observateur de trames.
  3. Dans le menu Affichage, sélectionnez Rechercher tous les noms. Le Moniteur réseau traite les trames, puis les ajoute à la base de données d'adresses.
  4. Fermez la fenêtre Observateur de trames et affichez la fenêtre Capture.
  5. Dans le menu Capture, sélectionnez Filtre pour afficher la boîte de dialogue Filtre de capture.
  6. Dans la boîte de dialogue Filtre de capture, double-cliquez sur la ligne Paires d'adresses. Ou sélectionnez Adresse dans la zone de groupe Ajouter.
Le Moniteur réseau affiche la base de données d'adresses que vous avez créée. Vous pouvez utiliser les noms de cette base de données pour spécifier des paires d'adresses dans le filtre de capture.

Capture de données entre deux ordinateurs

Pour surveiller le trafic entre deux ordinateurs, procédez comme suit :
  1. Dans le menu Capture, sélectionnez Filtre pour afficher la boîte de dialogue Filtre de capture.
  2. Double-cliquez sur la ligne N'IMPORTE LAQUELLE <-> N'IMPORTE LAQUELLE pour afficher la boîte de dialogue Expression de l'adresse.
  3. Dans la fenêtre gauche de la boîte de dialogue Expression de l'adresse, sélectionnez l'adresse d'un ordinateur.
  4. Dans la fenêtre droite de la boîte de dialogue Expression de l'adresse, sélectionnez l'adresse d'un ordinateur.
Ensuite, sélectionnez le bouton Suivant en haut de cette fenêtre pour obtenir des instructions supplémentaires.
  1. Dans la fenêtre Direction de la boîte de dialogue, sélectionnez l'un des symboles :
    • Sélectionnez le symbole <--> pour contrôler le trafic dans les deux sens entre les adresses sélectionnées.
    • Sélectionnez le symbole --> pour contrôler uniquement le trafic qui circule de l'adresse sélectionnée dans la fenêtre gauche vers l'adresse sélectionnée dans la fenêtre droite.
  2. Sélectionnez OK.
  3. Dans la boîte de dialogue Filtre de capture, sélectionnez OK.
  4. Dans le menu Capture, sélectionnez Démarrer.

Enregistrement des donnés capturées

Utilisez la commande Enregistrer sous pour enregistrer des statistiques de capture dans un fichier de capture ou pour enregistrer des modifications apportées à des fichiers de capture. Ultérieurement, si vous souhaitez afficher des trames enregistrées dans un fichier, il vous suffit d'ouvrir ce fichier et d'afficher les statistiques dans la fenêtre Observateur de trames du Moniteur réseau.

Pour enregistrer les trames capturées dans un fichier de capture ou un fichier texte
  1. Effectuez l'une des opérations suivantes :
    • Dans la barre d'outils, cliquez sur le bouton Enregistrer le fichier.
      -ou-
    • Dans le menu Fichier, sélectionnez Enregistrer sous.
  2. Effectuez l'une des opérations suivantes :
    • Pour enregistrer le fichier sur le lecteur et le répertoire actifs, dans la zone Nom de fichier, spécifiez un nom de fichier et une extension. Si vous enregistrez les données dans un fichier que vous avez modifié, vous ne pouvez pas l'enregistrer sous son nom d'origine dans le même répertoire.
    • Pour enregistrer le fichier sur un partage réseau auquel vous n'êtes pas connecté, sélectionnez le bouton Réseau, puis utilisez la boîte de dialogue Connexion à un lecteur réseau pour établir la connexion.
    • Pour enregistrer le fichier sur un lecteur ou dans un répertoire différent, procédez comme suit :
      1. Dans la zone Lecteurs, sélectionnez un nouveau lecteur.
      2. Dans la zone Répertoires, sélectionnez un nouveau répertoire.
      3. Tapez le nom du fichier.
  3. Pour enregistrer uniquement les statistiques de trames qui satisfont aux spécifications du filtre d'affichage actif, sélectionnez Filtré.

    Cette option est disponible uniquement si vous enregistrez des données à partir de la fenêtre Observateur de trames.
  4. Pour enregistrer une plage de trames spécifique, tapez les numéros des trames de début et de fin dans les zones De et À.
  5. Sélectionnez OK.
Remarque Lorsqu'une plage de trames est enregistrée dans un fichier de capture, les numéros associés aux trames sont modifiés ; dans un fichier de capture, les numéros de trames commencent toujours par 1, quel que soit le numéro associé à la trame d'origine. De même, si vous appliquez un filtre d'affichage, puis que vous enregistrez les trames filtrées, les numéros de trames répertoriés dans le fichier de capture commencent par 1. Si toutefois vous utilisez l'option Imprimer dans un fichier de la boîte de dialogue Imprimer, les numéros de trames d'origine associés aux trames sont conservés.

Paramètres de taille de tampon

La taille de tampon par défaut est de 1 mégaoctet (Mo). Pour accroître la taille du tampon de façon à ne pas perdre d'informations, procédez comme suit :
  1. Cliquez sur Capturer, puis sur Paramètres de la zone de mémoire tampon.
  2. Augmentez la valeur du paramètre Taille de la mémoire tampon (Mo), puis cliquez sur OK.

Traçage dans un environnement de réseau étendu

Parfois, il peut vous être demandé d'effectuer une capture du trafic réseau entre deux ordinateurs spécifiques séparés par un ou plusieurs routeurs. Dans ces cas-là, le professionnel de support technique peut souhaiter analyser tout le trafic réseau entre le premier ordinateur et son routeur le plus proche et tout le trafic réseau entre le deuxième ordinateur et son routeur le plus proche. La plupart du temps, cette opération permet de vérifier l'éventuelle perte ou endommagement de paquets réseau entre les routeurs. Pour rendre ces traces cohérentes et être en mesure de lire ces traces simultanément, les horloges système doivent être synchronisées entre les deux ordinateurs avant d'effectuer le traçage. Pour synchroniser l'heure entre deux ordinateurs, procédez comme suit :
  1. Sélectionnez l'ordinateur par rapport auquel synchroniser l'heure.
  2. Sur l'autre ordinateur, tapez la commande
    net time \\nom_ordinateur /set /yes
    nom_ordinateur est le nom de l'ordinateur de l'étape 1.
  3. Vérifiez que les ordinateurs ont la même heure en tapant TIME sur chacun d'eux.
  4. Effectuez le traçage.

Recherche d'adresses MAC

Si l'ordinateur à contrôler exécute :
  • un client réseau MS-DOS, exécutez MSD sur cet ordinateur ;
  • Windows pour Workgroups 3.11 (exécutant le protocole TCP/IP), tapez IPCONFIG /ALL à partir de la ligne de commande ;
  • Windows 95, exécutez WINIPCFG à partir de la ligne de commande sur la station de travail locale ;
  • MacOS, ouvrez le Tableau de bord Appletalk. Sélectionnez Mode utilisateur dans le menu Edition et basculez en mode Avancé. Le Tableau de bord AppleTalk révèle maintenant le bouton Infos. Cliquez sur ce bouton pour obtenir l'adresse MAC ;
  • Windows NT, sur la console locale, utilisez une des options suivantes :
    • NET CONFIG SERVER à partir de la ligne de commande
    • IPCONFIG /ALL à partir de la ligne de commande
    • IPXROUTE config à partir de la ligne de commande
    • arp -a à partir de la ligne de commande
    • Getmac.exe à partir du Kit de ressources de Windows NT
    • WinMSD ;
  • Windows NT, à distance, exécutez Getmac.exe à partir du Kit de ressources de Windows NT.

Propriétés

Numéro d'article: 148942 - Dernière mise à jour: lundi 23 avril 2007 - Version: 7.0
Les informations contenues dans cet article s'appliquent au(x) produit(s) suivant(s):
  • Microsoft Windows XP Édition familiale
  • Microsoft Windows XP Professional
  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows 2000 Datacenter Server
  • Microsoft Windows 2000 Professionnel
  • Microsoft Windows 2000 Server
  • Microsoft Windows NT Advanced Server 3.1
  • Microsoft Windows NT Advanced Server 3.1
  • Microsoft Windows NT Server 3.5
  • Microsoft Windows NT Server 3.51
  • Microsoft Windows NT Server 4.0 Standard Edition
  • Microsoft Windows NT Workstation 3.1
  • Microsoft Windows NT Workstation 3.5
  • Microsoft Windows NT Workstation 3.51
  • Microsoft Windows NT Workstation 4.0 Édition Développeur
  • Microsoft Windows 98 Standard Edition
  • Microsoft Windows 95
  • Microsoft SNA Server 2.1
  • Microsoft SNA Server 3.0
  • Microsoft LAN Manager to Windows NT Advanced Server Upgrade
  • Microsoft Systems Management Server 1.0 Standard Edition
  • Microsoft Systems Management Server 1.1 Standard Edition
  • Microsoft Systems Management Server 1.2 Standard Edition
  • Microsoft LAN Manager 2.2c
  • Microsoft TCP/IP for Windows for Workgroups 3.11
  • Microsoft TCP/IP pour Windows for Workgroups 3.11a
  • Microsoft TCP/IP for Windows for Workgroups 3.11b
  • Microsoft Windows for Workgroups 3.11
  • Microsoft Internet Information Server 1.0
  • Microsoft Host Integration Server 2000 Standard Edition
Mots-clés : 
kbhowto KB148942
L'INFORMATION CONTENUE DANS CE DOCUMENT EST FOURNIE PAR MICROSOFT SANS GARANTIE D'AUCUNE SORTE, EXPLICITE OU IMPLICITE. L'UTILISATEUR ASSUME LE RISQUE DE L'UTILISATION DU CONTENU DE CE DOCUMENT. CE DOCUMENT NE PEUT ETRE REVENDU OU CEDE EN ECHANGE D'UN QUELCONQUE PROFIT.

Envoyer des commentaires

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com