ネットワーク モニターを使ってネットワーク トラフィックをキャプチャする方法

文書翻訳 文書翻訳
文書番号: 148942 - 対象製品
Notice
この資料は Windows 2000 に適用されます。Windows 2000 のサポートは2010 年の 7 月 13 日で終了しました。Windows 2000 からの移行戦略を計画する場合は、最初に Windows 2000 エンド オブ サポート ソリューションセンターにアクセスしてください。詳細については、マイクロソフト サポート ライフサイクル ポリシーを参照してください。
すべて展開する | すべて折りたたむ

目次

概要

この資料では、Microsoft ネットワーク モニターを使って、ローカル エリア ネットワークからネットワーク トラフィックをキャプチャするのに必要な情報について説明します。この資料の説明は、ネットワーク モニターのヘルプ ファイルから直接取得されたものであり、より詳細な手順についてはヘルプ ファイルを参照してください。

詳細

ネットワーク モニターは、ローカル エリア ネットワークを監視して、ネットワーク統計情報を表形式で示すネットワーク診断ツールです。ネットワーク管理者は、これらの統計情報を使用して、定型化したトラブルシューティング タスクを実行することができます。たとえば、ダウンしている、または異常に多くの作業要求を受信しているサーバーの検索を行うことができます。ネットワーク モニターは、ネットワークのデータ ストリームから情報を収集して、次の種類の情報を表示します。
  • ネットワーク上にフレームを送信したコンピューターの発信元アドレス (このアドレスは、一意の 16 進数 (16 が基数) で表され、ネットワーク上のコンピューターを識別します)
  • フレームを受信したコンピューターの宛先アドレス
  • フレームの送信に使用されたプロトコル
  • 送信されたデータまたはメッセージの一部
ネットワーク モニターがこれらの情報を収集するプロセスをキャプチャといいます。既定ではネットワーク モニターは、ネットワーク上で検出したすべてのフレームの統計情報をキャプチャ バッファーに収集します。キャプチャ バッファーは、メモリ内の格納領域に確保されています。特定のフレーム セットに関する統計情報をキャプチャする場合、キャプチャ フィルターを作成して、これらのフレームを選別することができます。統計情報のキャプチャが完了したら、ディスプレイ フィルターを設計して、ネットワーク モニターの [フレーム ビューアー] ウィンドウに表示される情報量を指定することができます。

ネットワーク モニターを使用するには、無作為検出モードをサポートするネットワーク カードがコンピューターにインストールされている必要があります。リモートでネットワーク モニターを使用している場合、ローカル ワークステーションは、無作為検出モードをサポートするネットワーク アダプター カードをインストールしている必要はありませんが、リモート コンピューターでは必要となります。

ネットワーク全体をキャプチャする、またはローカル リソースを保持するには、リモート Windows NT コンピューターでネットワーク モニター エージェントを使用して情報をキャプチャします。リモートでキャプチャした場合、ネットワーク モニター エージェントは、リモート コンピューターから統計情報を収集し、これらの統計情報をローカル コンピューターに送信します。統計情報はローカルの [ネットワーク モニター] ウィンドウに表示されます。

ローカルかリモートでデータをキャプチャすると、そのデータは、テキスト ファイルまたはキャプチャ ファイルに保存され、後で開いて調べることができます。

注: ヘルプで説明されているネットワーク モニターのコア機能は、Microsoft Product Support Services によりサポートされています。ネットワークからキャプチャしたデータの分析などのネットワーク依存タスクはサポートされていません。ネットワーク モニター エージェントは、Windows NT ではサポートされていますが、Windows 3.1 および Windows for Workgroups ワークステーションではサポートされていません。

アドレス一覧を作成する

キャプチャ フィルターでアドレスの組み合わせを使用するには、まずアドレス データベースを構築する必要があります。このデータベースの構築後、データベースに一覧表示されているアドレスを使用して、キャプチャ フィルターのアドレスの組み合わせを指定することができます。

アドレス一覧を作成するには、次の手順を実行します。
  1. [キャプチャ] メニューの [開始] をクリックします。または、[キャプチャ] ウィンドウまたは [フレーム ビューアー] ウィンドウから .cap ファイルを開きます。
  2. キャプチャが完了したら、[キャプチャ] メニューの [停止して表示] をクリックして、[フレーム ビューアー] ウィンドウを表示します。
  3. [表示] メニューの [すべての名前を検索] をクリックします。ネットワーク モニターによりフレーム処理が実行され、フレームがアドレス データベースに追加されます。
  4. [フレーム ビューアー] ウィンドウを閉じ、[キャプチャ] ウィンドウを表示します。
  5. [キャプチャ] メニューの [フィルター] をクリックして、[キャプチャ フィルター] ダイアログ ボックスを表示します。
  6. [キャプチャ フィルター] ダイアログ ボックスの [(アドレスの組み合わせ)] (または [アドレス ペア]) をダブルクリックします。または、[追加] の [アドレス] をクリックします。
ネットワーク モニターに、作成したデータベースが表示されます。このデータベース内の名前を使用して、キャプチャ フィルターのアドレスの組み合わせを指定できます。

2 台のコンピューター間のデータをキャプチャする

2 台のコンピューター間のトラフィックを監視するには、次の手順を実行します。
  1. [キャプチャ] メニューの [フィルター] をクリックして、[キャプチャ フィルター] ダイアログ ボックスを表示します。
  2. [(アドレスの組み合わせ)] (または [アドレス ペア]) をダブルクリックして、[アドレス式] ダイアログ ボックスを表示します。
  3. [アドレス式] ダイアログ ボックスの左ウィンドウで、コンピューターのアドレスを選択します。
  4. [アドレス式] ダイアログ ボックスの右ウィンドウで、コンピューターのアドレスを選択します。
この操作を実行した後、詳細な指示を参照するには、このウィンドウの上部にある [アドレスの編集] をクリックします。
  1. ダイアログ ボックスの [方向] ウィンドウで、記号を選択します。
    • 選択したアドレス間の両方向のトラフィックを監視するには、[<-->] をクリックします。
    • 左ウィンドウで選択したアドレスから右ウィンドウで選択したアドレスに向かうトラフィックのみを監視するには、[--->] をクリックします。
  2. [OK] をクリックします。
  3. [キャプチャ フィルター] ダイアログ ボックスで [OK] をクリックします。
  4. [キャプチャ] メニューの [開始] をクリックします。

キャプチャしたデータを保存する

キャプチャした統計情報や変更をキャプチャ ファイルに保存するには、[名前を付けて保存] コマンドを実行します。ファイルに保存したフレームを後で表示するには、このファイルを開いて、ネットワーク モニターの [フレーム ビューアー] ウィンドウで統計情報を表示します。

キャプチャしたフレームをキャプチャ ファイルまたはテキスト ファイルに保存する方法
  1. 以下のいずれかの手順を実行します。
    • ツール バーの [名前を付けて保存] (または [ファイルの保存]) ボタンをクリックします。
      または
    • [ファイル] メニューの [名前を付けて保存] をクリックします。
  2. 次のいずれかの操作を行います。
    • 現在のドライブとディレクトリにファイルを保存するには、[ファイル名] ボックスおよび [ファイルの種類] ボックスでファイル名と拡張子を指定します。変更したファイルを保存する場合、同じディレクトリに元の名前で保存することはできません。
    • Windows NT 4.0 の場合、接続されていないネットワーク共有にファイルを保存するには、[ネットワーク] をクリックし、[ネットワーク ドライブの割り当て] ダイアログ ボックスを使用して接続を確立します。
    • Windows NT 4.0 の場合、異なるドライブやディレクトリにファイルを保存するには、次の操作を実行します。
      1. [ドライブ] ボックスで新しいドライブを選択します。
      2. [ディレクトリ] ボックスで新しいディレクトリを選択します。
      3. ファイル名を入力します。
  3. 現在のディスプレイ フィルターの要件を満たすフレーム統計情報のみを保存するには、[フィルター] チェック ボックスをオンにします。

    このオプションは、[フレーム ビューアー] ウィンドウでデータを保存しようとしている場合にのみ使用することができます。
  4. 特定の範囲のフレームを保存するには、フレーム番号の最初と最後を [から] ボックスと [まで] ボックスにそれぞれ入力します。
  5. [OK] をクリックします。
注: フレーム範囲がキャプチャ ファイルに保存されると、そのフレームに関連付けられた番号は変更されます。キャプチャ ファイルでは、フレーム番号は、元のフレームに関連付けられた番号に関係なく、常に 1 から始まります。同様に、ディスプレイ フィルターを適用して、フィルター処理されたフレームを保存する場合、キャプチャ ファイルのフレーム番号は 1 で始まります。しかし、[印刷] ダイアログ ボックスの [ファイルへ出力] を使用した場合、そのフレームに関連付けられた元のフレーム番号が保持されます。

バッファー サイズの設定

既定のバッファー サイズは 1 MB です。情報の損失を防ぐためにバッファー サイズを増やすには、次の手順を実行します。
  1. [キャプチャ] をクリックし、[バッファーの設定] をクリックします。
  2. [バッファー サイズ (MB)] の値を増やし、[OK] をクリックします。

WAN 環境でのトレース

1 つ以上のルーターで分離された 2 台の特定のコンピューター間のネットワーク トラフィックをキャプチャするよう依頼されることがあります。この場合、サポート エンジニアは、1 台目のコンピューターとそのコンピューターに最も近いルーターの間、および 2 台目のコンピューターとそのコンピューターに最も近いルーターの間にあるすべてのネットワーク トラフィックを分析します。これはほとんどの場合、ルーター間のどこかでネットワーク パケットの損失や破損がないかどうかをチェックするために行います。これらのトレースの整合性を持たせて、同時に読み取れるようにするには、トレースする前に、2 台のコンピューターのシステム クロックを同期させる必要があります。2 台のコンピューターの時計を同期させるには、次の手順を実行します。
  1. 時刻を同期させるための基準となるコンピューターを選択します。
  2. もう一方のコンピューターから次のコマンドを実行します。
    net time \\コンピューター名 /set /yes
    ここでコンピューター名には手順 1. のコンピューター名が入ります。
  3. 各コンピューターで「TIME」と入力して、同じ時刻を示すことを確認します。
  4. トレースを続行します。

MAC アドレスの確認方法

監視するコンピューターが何を実行しているかに応じて、次の処理を行います。
  • MS-DOS ベースのクライアントでは、コンピューターで MSD を実行します。
  • TCP/IP を実行している Windows for Workgroup 3.11 では、コマンド ラインから IPCONFIG /ALL を入力します。
  • Windows 95 では、ローカル ワークステーションのコマンド ラインから WINIPCFG を実行します。
  • MacOS を実行している場合は、Appletalk コントロール パネルを開きます。[編集] メニューの [利用者モード] をクリックし、モードを [詳しい情報も指定] に変更します。Appletalk コントロール パネルに [情報] ボタンが表示されます。このボタンをクリックして、MAC アドレスを取得します。
  • Windows NT を実行している場合は、ローカル コンソールで次のいずれかの操作を実行します。
    • NET CONFIG SERVER をコマンド ラインから入力します。
    • IPCONFIG /ALL をコマンド ラインから入力します。
    • IPXROUTE config をコマンド ラインから入力します。
    • arp -a をコマンド ラインから入力します。
    • Getmac.exe を Windows NT リソース キットから実行します。
    • WinMSD を実行します。
  • リモートで Windows NT を実行している場合は、Windows NT リソース キットから Getmac.exe を実行します。
注意 : これは、マイクロソフトのサポート組織内で直接作成された "緊急公開" の資料です。 この資料には、確認中の問題に関する現状ベースの情報が記載されています。 情報提供のスピードを優先するため、資料には誤植が含まれる可能性があり、予告なしに随時改定される場合があります。 その他の考慮事項については、使用条件を参照してください。

プロパティ

文書番号: 148942 - 最終更新日: 2014年1月30日 - リビジョン: 1.0
この資料は以下の製品について記述したものです。
  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Professional
  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows 2000 Professional
  • Microsoft Windows 2000 Server
  • Microsoft Windows NT Server 3.51
  • Microsoft Windows NT Server 4.0 Standard Edition
  • Microsoft Windows NT Workstation 3.1
  • Microsoft Windows NT Workstation 3.5
  • Microsoft Windows NT Workstation 3.51
  • Microsoft Windows NT Workstation 4.0 Developer Edition
  • Microsoft Windows 95
  • Microsoft SNA Server 2.1
  • Microsoft Systems Management Server 1.0 Standard Edition
  • Microsoft Systems Management Server 1.1 Standard Edition
  • Microsoft Systems Management Server 1.2 Standard Edition
  • Microsoft TCP/IP for Windows for Workgroups 3.11
  • Microsoft Windows for Workgroups 3.11
  • Microsoft Internet Information Server 1.0
  • Microsoft Host Integration Server 2000 Standard Edition
キーワード:?
kbhowto KB148942
Microsoft Knowledge Base の免責: Microsoft Knowledge Baseに含まれている情報は、いかなる保証もない現状ベースで提供されるものです。Microsoft Corporation及びその関連会社は、市場性および特定の目的への適合性を含めて、明示的にも黙示的にも、一切の保証をいたしません。さらに、Microsoft Corporation及びその関連会社は、本文書に含まれている情報の使用及び使用結果につき、正確性、真実性等、いかなる表明・保証も行ないません。Microsoft Corporation、その関連会社及びこれらの権限ある代理人による口頭または書面による一切の情報提供またはアドバイスは、保証を意味するものではなく、かつ上記免責条項の範囲を狭めるものではありません。Microsoft Corporation、その関連会社 及びこれらの者の供給者は、直接的、間接的、偶発的、結果的損害、逸失利益、懲罰的損害、または特別損害を含む全ての損害に対して、状況のいかんを問わず一切責任を負いません。(Microsoft Corporation、その関連会社 またはこれらの者の供給者がかかる損害の発生可能性を了知している場合を含みます。) 結果的損害または偶発的損害に対する責任の免除または制限を認めていない地域においては、上記制限が適用されない場合があります。なお、本文書においては、文書の体裁上の都合により製品名の表記において商標登録表示、その他の商標表示を省略している場合がありますので、予めご了解ください。

フィードバック

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com