Ağ İzleyicisi ile ağ trafiği nasıl yakalanır

Makale çevirileri Makale çevirileri
Makale numarası: 148942 - Bu makalenin geçerli olduğu ürünleri görün.
Hepsini aç | Hepsini kapa

Bu Sayfada

™zet

Bu makalenin amacı, Microsoft'un Ağ İzleyicisi'ni kullanarak yerel bir ağda ağ trafiğini yakalamak için gereken bilgileri sağlamaktır. Bu makalenin metni doğrudan Ağ İzleyicisi'nin Yardım dosyasından gelmektedir ve daha ayrıntılı yönergeler için bu dosyaya başvurulması gerekir.

Daha fazla bilgi

Ağ İzleyicisi, yerel ağları izleyen ve ağ istatistiklerinin grafik görünümünü sağlayan bir ağ tanılama aracıdır. Ağ yöneticileri kapalı olan veya aşırı miktarda iş isteği alan bir sunucuyu bulmak gibi genel sorun giderme görevlerini gerçekleştirmek için bu istatistikleri kullanabilir. Ağ İzleyicisi ağın veri akışından bilgi toplarken aşağıdaki türdeki bilgileri görüntüler:
  • Ağa çerçeve gönderen bilgisayarın kaynak adresi. (Bu adres bilgisayarı ağda tanımlayan benzersiz bir onaltılık (veya 16 tabanlı) sayıdır.)
  • Çerçeveyi alan bilgisayarın hedef adresi.
  • Çerçeveyi göndermek için kullanılan protokol.
  • Veri veya gönderilen iletinin bir bölümü.
Ağ İzleyicisi'nin bu bilgileri toplama işlemi yakalama olarak anılır. Varsayılan olarak, Ağ İzleyicisi ağda algıladığı tüm çerçevelerle ilgili istatistikleri bellekte ayrılmış bir depolama alanı olan yakalama arabelleğinde toplar. Çerçevelerin yalnızca belirli alt kümesiyle ilgili istatistikleri yakalamak için, bir yakalama filtresi tasarlayarak bu çerçeveleri ayırabilirsiniz. Bilgi yakalamayı tamamladığınızda, yakaladığınız bilgilerinin ne kadarının Ağ İzleyicisi'nin Frame Viewer (Çerçeve Görüntüleyicisi) ekranında görüntüleneceğini belirtmek için görüntü filtresi tasarlayabilirsiniz.

Ağ İzleyicisi'ni kullanabilmek için bilgisayarınızda çoklu modu destekleyen bir ağ kartı olması gerekir. Ağ İzleyicisi'ni bir uzak makinede kullanıyorsanız, yerel iş istasyonu çoklu modu destekleyen bir ağ bağdaştırıcısına gerek duymaz ancak uzak bilgisayar duyar.

Ağlar arasında yakalamak veya yerel kaynakları korumak amacıyla uzak Windows NT bilgisayarı kullanarak bilgi yakalamak için Ağ İzleyicisi Aracısı'nı kullanın. Uzaktan yakalama yaptığınızda, Ağ İzleyicisi Aracısı uzak bilgisayardan istatistikleri toplar ve sonra bu istatistikleri yerel Ağ İzleyicisi penceresinde görüntülenmek üzere yerel bilgisayarınıza gönderir.

Veriler, yerel olarak veya uzaktan yakalandıktan sonra, bir metin veya yakalama dosyasına kaydedilebilir ve daha sonra açılabilir ve incelenebilir.

Not Ağ İzleyicisi'nin Yardım'da açıklanan temel işlevi Microsoft Ürün Destek Hizmetleri tarafından desteklenmektedir. Ağınızdan yakaladığınız verileri yorumlama gibi ağa bağımlı görevler desteklenmez. Ağ İzleyicisi Aracısı Windows NT için desteklenmektedir, ancak Windows 3.1 ve Windows for Workgroups iş istasyonlarında desteklenmemektedir.

Adres listesi oluşturma

Bir Yakalama filtresinde adres çiftlerini kullanmak için, ilk olarak bir adres veritabanı oluşturmalısınız. Bu veritabanı oluşturulduktan sonra, yakalama filtresinde adres çiftlerini belirtmek için veritabanındaki adresleri kullanabilirsiniz.

Adres listesi oluşturmak için aşağıdaki adımları izleyin:
  1. Yakala menüsünden Başlat'ı seçin. İsteğe bağlı olarak, Çerçeve Görüntüleyicisi penceresinde bir .cap penceresi açın.
  2. Yakalamayı tamamladığınızda, Çerçeve Görüntüleyicisi penceresini görüntülemek için Yaka menüsünden Durdur'u ve Görüntüle'yi seçin.
  3. Görüntü menüsünde Tüm Adları Bul'u seçin. Ağ İzleyicisi çerçeveleri işler ve sonra bunları adres veritabanına ekler.
  4. Çerçeve Görüntüleyicisi penceresini kapatın ve Yakala penceresini görüntüleyin.
  5. Yakalama Filtresi iletişim kutusunu görüntülemek için, Yakala menüsünden Filtre'yi seçin.
  6. Yakalama Filtresi iletişim kutusunda, Adres Çiftleri satırını çift tıklatın. Ekle grup kutusunda Adres'i de seçebilirsiniz.
Ağ İzleyicisi oluşturduğunuz adres veritabanını görüntüler. Yakalama filtresinde adres çiftlerini belirtmek için bu veritabanındaki adları kullanabilirsiniz.

İki bilgisayar arasındaki verileri yakalama

İki bilgisayar arasındaki trafiği izlemek için aşağıdaki adımları izleyin:
  1. Yakalama Filtresi iletişim kutusunu görüntülemek için, Yakala menüsünden Filtre'yi seçin.
  2. Adres İfadesi iletişim kutusunu görüntülemek için ANY<->ANY satırını çift tıklatın.
  3. Adres İfadesi iletişim kutusunun sol penceresinde, bir bilgisayarın adresini seçin.
  4. Adres İfadesi iletişim kutusunun sağ penceresinde, bir bilgisayarın adresini seçin.
Bunu yaptığınızda, daha fazla yönerge için bu pencerenin üstündeki İleri düğmesini seçin.
  1. İletişim kutusunun Yön penceresinde, simgelerden birini seçin:
    • Seçtiğiniz adresler arasında her iki yönde gerçekleşen trafiği izlemek için <--> simgesini seçin.
    • Yalnızca sol pencerede seçilen adresten sağ pencerede seçilen adrese giden trafiği izlemek için --> simgesini seçin.
  2. Tamam'ı seçin.
  3. Yakalama Filtresi iletişim kutusunda, Tamam'ı seçin.
  4. Yakala menüsünden Başlat'ı seçin.

Yakalanan verileri kaydetme

Yakalama istatistiklerini yakalama dosyasına kaydetmek veya değiştirdiğiniz yakalama dosyalarındaki değişiklikleri kaydetmek için Farklı Kaydet komutunu kullanın. Daha sonra, dosyaya kaydedilen çerçeveleri görüntülemek için bu dosyayı açabilir ve istatistikleri Ağ İzleyicisi'nin Çerçeve Görüntüleyicisi penceresinde görüntüleyebilirsiniz.

Yakalanan çerçeveleri bir yakalama dosyasına veya metin dosyasına kaydetmek için:
  1. Aşağıdakilerden birini yapın:
    • Araç Çubuğunda, Dosya Kaydet düğmesini tıklatın.
      -veya-
    • Dosya menüsünden, Farklı Kaydet'i seçin.
  2. Aşağıdakilerden birini yapın:
    • Dosyayı geçerli sürücü ve dizine kaydetmek için, Dosya Adı kutusunda dosya adını ve uzantıyı belirtin. Değiştirdiğiniz bir dosyayı kaydediyorsanız, özgün adıyla aynı dizinin altına kaydedemezsiniz.
    • Dosyayı bağlı olmadığınız bir ağ paylaşımına kaydetmek için, düğmesini seçin ve bağlantıyı kurmak için Ağ Sürücüsüne Bağlan iletişim kutusunu kullanın.
    • Dosyayı farklı bir sürücüye veya dizine kaydetmek için aşağıdakileri yapın:
      1. Sürücüler kutusunda, yeni bir sürücü seçin.
      2. Dizinler kutusunda, yeni bir dizin seçin.
      3. Dosya adını yazın.
  3. Yalnızca geçerli görüntü filtresinin belirtimleriyle eşleşen çerçeve istatistiklerini kaydetmek için, Filtre Uygulanan'ı seçin.

    Bu seçenek yalnızca Çerçeve Görüntüleyicisi penceresinden veri kaydederken kullanılabilir.
  4. Belirli bir çerçeve aralığını kaydetmek için başlangıç ve bitiş çerçeve numaralarını İlk ve Son kutularına yazın.
  5. Tamam'ı seçin.
Not Yakalama dosyasına bir çerçeve aralığı kaydedildiğinde, çerçevelerle ilişkili numaralar değiştirilir; yakalama dosyasında çerçeve numaraları özgün çerçeveyle ilişkili numaraya bakılmaksızın her zaman 1 ile başlar. Benzer şekilde, görüntü filtresi uygular ve sonra filtre uygulanan çerçeveleri kaydederseniz, yakalama dosyasındaki çerçeve numaraları 1 ile başlar. Ancak, Yazdır iletişim kutusundaki Dosyaya Yazdır seçeneğini kullanırsanız çerçevelerle ilişkili özgün çerçeve numaraları korunur.

Arabellek boyutu ayarları

Varsayılan arabellek boyutu 1 megabayttır (MB). Bilgi kaybetmeyecek şekilde arabellek boyutunu artırmak için aşağıdaki adımları izleyin:
  1. Yakala'yı ve sonra Arabellek Ayarları'nı tıklatın.
  2. Arabellek Boyutu (MB) ayarının değerini artırın ve Tamam'ı tıklatın.

WAN Ortamında İzleme

Bazen, aralarında bir veya daha fazla yönlendirici bulunan belirli iki bilgisayar arasındaki ağ trafiğini yakalamanız istenebilir. Bu durumda, destek uzmanı ilk bilgisayarla bu bilgisayara en yakın yönlendiricisi arasındaki tüm ağ trafiğini ve ikinci bilgisayarla bu bilgisayara en yakın yönlendiricisi arasındaki tüm ağ trafiğini analiz etmek isteyebilir. Çoğu durumda, bu işlem ağ paketlerinin yönlendiriciler arasında kaybolup kaybolmadığını veya bozulup bozulmadığını denetlemek için yapılır. Bu izleri tutarlı hale getirmek ve aynı anda okuyabilmek için, izi oluşturmadan önce iki bilgisayarın sistem saatlerinin senkronize edilmesi gerekir. İki bilgisayarın saatlerini senkronize etmek için şu adımları kullanın:
  1. Kendisinden saati eşitlemek istediğiniz bilgisayarı seçin.
  2. Diğer bilgisayarda,
    net time \\BilgisayarAdı /set /yes
    yazın. Burada BilgisayarAdı, 1. adımdaki bilgisayarın adıdır.
  3. Her birinde TIME yazarak bilgisayarların saatlerinin aynı olduğunu doğrulayın.
  4. İzleme işlemine devam edin.

Medya Erişimi Denetim Adreslerini Bulma

İzlenecek bilgisayar:
  • MS-DOS tabanlı ağ istemcisi çalıştırıyorsa, ilgili bilgisayarda MSD'yi çalıştırın.
  • Windows for Workgroups 3.11 (TCP/IP çalıştıran) çalıştırıyorsa, komut satırında IPCONFIG /ALL yazın.
  • Windows 95 çalıştırıyorsa, yerel iş istasyonunda komut satırından WINIPCFG'yi çalıştırın.
  • MacOS çalıştırıyorsa, Appletalk Control Panel'i açın. Edit menüsünden User Mode seçeneğini seçin ve Advanced olarak değiştirin. Appletalk Control Panel'de şimdi Info düğmesi görünür. MAC adresini almak için bu düğmeyi tıklatın.
  • Windows NT çalıştırıyorsa, yerel konsolsa aşağıdaki seçeneklerden birini kullanın:
    • Komut satırından NET CONFIG SERVER
    • Komut satırından IPCONFIG /ALL
    • Komut satırından IPXROUTE config
    • Komut satırından arp -a
    • Windows NT Kaynak Seti'nden Getmac.exe
    • WinMSD
  • Windows NT çalıştırıyorsa, uzaktan, Windows NT Kaynak Seti'nden Getmac.exe'yi çalıştırın.

Özellikler

Makale numarası: 148942 - Last Review: 22 Ocak 2007 Pazartesi - Gözden geçirme: 7.0
Bu makaledeki bilginin uygulandigi durum:
  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Professional Edition
  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows 2000 Datacenter Server
  • Microsoft Windows 2000 Professional Edition
  • Microsoft Windows 2000 Server
  • Microsoft Windows NT Advanced Server 3.1
  • Microsoft Windows NT Advanced Server 3.1
  • Microsoft Windows NT Server 3.5
  • Microsoft Windows NT Server 3.51
  • Microsoft Windows NT Server 4.0 Standard Edition
  • Microsoft Windows NT Workstation 3.1
  • Microsoft Windows NT Workstation 3.5
  • Microsoft Windows NT Workstation 3.51
  • Microsoft Windows NT Workstation 4.0 Developer Edition
  • Microsoft Windows 98 Standard Edition
  • Microsoft Windows 95
  • Microsoft SNA Server 2.1
  • Microsoft SNA Server 3.0
  • Microsoft LAN Manager to Windows NT Advanced Server Upgrade
  • Microsoft Systems Management Server 1.0 Standard Edition
  • Microsoft Systems Management Server 1.1 Standard Edition
  • Microsoft Systems Management Server 1.2 Standard Edition
  • Microsoft LAN Manager 2.2c
  • Microsoft TCP/IP for Windows for Workgroups 3.11
  • Microsoft TCP/IP for Windows for Workgroups 3.11a
  • Microsoft TCP/IP for Windows for Workgroups 3.11b
  • Microsoft Windows for Workgroups 3.11
  • Microsoft Internet Information Server 1.0
  • Microsoft Host Integration Server 2000 Standard Edition
Anahtar Kelimeler: 
kbhowto KB148942

Geri Bildirim Ver

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com