Mensaje de error: No hay páginas de pila de reserva

Seleccione idioma Seleccione idioma
Id. de artículo: 149083 - Ver los productos a los que se aplica este artículo
Este artículo se ha archivado. Se ofrece "tal cual" y no se volverá a actualizar.
Expandir todo | Contraer todo

Síntomas

Cuando utiliza un equipo donde se ejecuta Windows 95, Windows 98 o Windows Millennium Edition (Me), es posible que reciba uno de los siguientes mensajes de error:
No hay páginas de pila de reserva. Quizá necesite incrementar el valor de 'MinSPs' en System.ini para evitar posibles errores en la pila. Ahora haynnn SP asignadas.
El subproceso terminó por un problema de desbordamiento de la pila. Un VxD ocupa demasiado espacio en la pila. Aumente el valor de MinSPs en el archivo System.ini o quite algunos VxD recién instalados. Ahora hay nnn SP asignadas. Presione cualquier tecla para continuar.

Causa

Este comportamiento puede ocurrir cuando Windows encuentra un desbordamiento interno de las pilas utilizadas por los controladores de dispositivos basados en Windows de 32 bits. Tenga en cuenta que esto no está relacionado con la línea "Stacks=" del archivo Config.sys, utilizado para los controladores de dispositivos basados en MS-DOS de 16 bits.

Las condiciones de desbordamiento indican errores en el controlador de dispositivos. Los controladores de dispositivos disponen de un espacio de 4 kilobytes (KB), o una página, para utilizarlo como pila. Si el controlador de dispositivos utiliza más de 4 KB de memoria, tendrá lugar una condición de desbordamiento de pila.

Windows reserva un número de páginas de memoria adicionales, o de páginas de pila de reserva, para que se utilicen temporalmente. De esta manera, el equipo no dejará de responder (no se bloqueará) por una condición de desbordamiento de pila. Una vez solucionada la condición de desbordamiento de pila, Windows reclama la página temporal. El número predeterminado de páginas de pila de reserva es dos.

Si Windows detecta que ya no tiene páginas de pila de reserva, recibirá el mensaje de error mencionado en la sección "Síntomas" de este artículo. Windows continúa funcionando correctamente a menos que el controlador de dispositivos detecte una condición de desbordamiento de pila cuando no haya páginas de pila de reserva.

Solución

Para resolver este comportamiento, agregue la siguiente línea a la sección [386Enh] del archivo System.ini y, a continuación, reinicie el equipo:
MinSPs=4
Si el comportamiento persiste, aumente el número de páginas de pila de reserva en incrementos de 4 (por ejemplo, 8, 12, 16).

NOTA: cada página de pila de reserva requiere 4 KB de memoria.

Para modificar el archivo System.ini para Windows 95, Windows 98 y Windows 98 Segunda edición:
  1. Haga clic en Inicio y en Ejecutar, en el cuadro Abrir escriba sysedit y, a continuación, haga clic en Aceptar.
  2. En el menú Ventana, haga clic en System.ini.
  3. En la sección [386Enh], escriba la línea siguiente:
    MinSPs=4
  4. En el menú Archivo, haga clic en Salir y, a continuación, haga clic en para guardar los cambios.
  5. Reinicie el equipo.
Para modificar el archivo System.ini en Windows Millennium Edition:

  1. Haga clic en Inicio y, a continuación, en Buscar archivos o carpetas.
  2. En el cuadro "Buscar archivos o carpetas con el nombre" escriba "System.ini" (sin comillas) y asegúrese de que en el cuadro desplegable "Buscar en" aparece "Disco duro local (C:)". Haga clic en el botón Buscar ahora.
  3. Cuando los resultados de la búsqueda aparezcan en el panel del lateral derecho, haga doble clic en el archivo System.ini que aparece en "En la carpeta" C:\Windows. De esta manera se abrirá el archivo System.ini dentro del Bloc de notas.
  4. En la sección [386Enh], agregue o modifique la siguiente línea, según proceda:
    "MinSPs=4" (sin comillas)
  5. En el menú Archivo, haga clic en Guardar; a continuación, haga clic de nuevo en el menú Archivo y, después, en Salir.
  6. Reinicie el equipo.

Más información

Nota: el origen de la siguiente información es externo a Microsoft. Esta información es cortesía de Microsoft y no se ha comprobado ni su precisión ni su validez.

Si está ejecutando Norton AntiVirus de Symantec, visite la siguiente dirección URL para obtener información del sitio Web de Symantec:
http://service1.symantec.com/SUPPORT/nav.nsf/aab56492973adccd8825694500552355/7c1f9d53b991d7c688256541006b00c3?OpenDocument

Propiedades

Id. de artículo: 149083 - Última revisión: martes, 11 de febrero de 2014 - Versión: 1.2
La información de este artículo se refiere a:
  • Microsoft Windows Millennium Edition
  • Microsoft Windows 98 Second Edition
  • Microsoft Windows 98 Standard Edition
  • Microsoft Windows 95
Palabras clave: 
kbnosurvey kbarchive kberrmsg kbenv kbprb KB149083

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com