Message d'erreur : Il n'y a plus de page de pile en réserve

Traductions disponibles Traductions disponibles
Numéro d'article: 149083 - Voir les produits auxquels s'applique cet article
Ancien nº de publication de cet article : F149083
Cet article a été archivé. Il est proposé « en l'état » et ne sera plus mis à jour.
Agrandir tout | Réduire tout

Symptômes

Lorsque vous utilisez un ordinateur fonctionnant sous Windows 95, Windows 98, ou Windows Millennium Edition (Me), vous pouvez recevoir un des messages d'erreur suivants :
Il n'y a plus de page de pile en réserve. Il est peut-être nécessaire d'augmenter le paramètre de 'MinSPs' dans System.ini pour empêcher des erreurs de pile. nnn SPs sont actuellement alloués.
Fin de thread en raison d'un problème de dépassement de pile. Un VxD utilise trop de pile. Augmentez l'espace pile de MinSPs dans System.ini ou supprimez les VxD récemment installés. Il y a actuellement nnn SPs alloués. Appuyez sur une touche pour poursuivre.

Cause

Ce problème peut se produire lorsque Windows rencontre un débordement interne des piles utilisées par les pilotes de périphériques Windows en 32 bits. Sachez qu'il n'est pas lié à la ligne " Stacks= " dans le fichier Config.sys, laquelle est utilisée pour les pilotes de périphériques MS-DOS en 16 bits.

Une situation de débordement de piles indique des erreurs dans un pilote de périphérique. 4 kilooctets (Ko), ou une page, d'espace à utiliser comme pile sont alloués aux pilotes de périphériques. Si un pilote utilise plus de 4 Ko de mémoire, cela provoque un débordement de pile.

Windows garde en réserve un certain nombre de pages de mémoire supplémentaires à utiliser temporairement pour éviter que votre ordinateur cesse de répondre (se bloque) dans une situation de débordement de pile. Lorsque la situation de débordement est résolue, Windows récupère la page temporaire. Par défaut, les pages de pile en réserve sont au nombre de deux.

Le message d'erreur mentionné dans la section " Symptômes " de cet article s'affiche lorsque Windows détecte qu'il n'existe plus de page de pile en réserve. Windows continue toutefois à fonctionner normalement, à moins qu'un pilote de périphérique ne provoque une nouvelle situation de débordement de pile alors qu'aucune page de réserve n'est disponible.

Résolution

Pour résoudre ce problème, ajoutez la ligne suivante à la section [386Enh] du fichier System.ini, puis redémarrez votre ordinateur :
MinSPs=4
Si le problème persiste, augmentez le nombre de pages de pile en réserve par multiples de quatre (par exemple 8, 12, 16).

REMARQUE : Chaque page de pile en réserve nécessite 4 Ko de mémoire.

Procédez comme suit pour modifier le fichier System.ini sous Windows 95, 98 et 98de :
  1. Cliquez sur Démarrer, sur Exécuter, tapez sysedit dans la zone Ouvrir, puis cliquez sur OK.
  2. Cliquez sur System.ini dans le menu Windows.
  3. Dans la section [386Enh], tapez la ligne suivante :
    MinSPs=4
  4. Dans le menu Fichier, cliquez sur Quitter, puis cliquez sur Oui pour enregistrer les modifications.
  5. Redémarrez votre ordinateur.
Procédez comme suit pour modifier le fichier System.ini dans Windows Me :

  1. Cliquez sur Démarrer, puis sur Rechercher, Des fichiers ou des dossierss.
  2. Dans la zone " Rechercher les fichiers ou les dossiers nommés ", tapez " System.ini " (sans les guillemets), et assurez-vous que la liste déroulante " Rechercher dans " contient " Disque dur local (C:) ". Cliquez sur le bouton Rechercher.
  3. Lors de l'affichage des résultats dans le volet droit, double-cliquez sur le fichier System.ini qui se trouve " Dans le dossier " C:\Windows. Vous ouvrirez ainsi le fichier System.ini dans le Bloc-Notes.
  4. Dans la section [386Enh], ajoutez ou modifier la ligne suivante selon le cas :
    " MinSPs=4 " (sans les guillemets)
  5. Dans le menu Fichier, cliquez sur Enregistrer, puis à nouveau dans le menu Fichier, cliquez sur Quitter.
  6. Redémarrez votre ordinateur.

Plus d'informations

Remarque : Les informations ci après proviennent de sources extérieures à Microsoft. Microsoft vous les fournit gracieusement mais n'a pas vérifié l'exactitude ou la validité de ces informations.

Si vous exécutez Norton AntiVirus de Symantec, vous pouvez consulter le site suivant de Symantec pour plus d'informations :
http://service1.symantec.com/SUPPORT/nav.nsf/aab56492973adccd8825694500552355/7c1f9d53b991d7c688256541006b00c3?OpenDocument

Propriétés

Numéro d'article: 149083 - Dernière mise à jour: jeudi 13 février 2014 - Version: 1.2
Les informations contenues dans cet article s'appliquent au(x) produit(s) suivant(s):
  • Microsoft Windows Millennium Edition
  • Microsoft Windows 98 Deuxième Édition
  • Microsoft Windows 98 Standard Edition
  • Microsoft Windows 95
Mots-clés : 
kbnosurvey kbarchive kberrmsg kbwin98 kbwinme kbenv win98se win98 kbprb win95 KB149083
L'INFORMATION CONTENUE DANS CE DOCUMENT EST FOURNIE PAR MICROSOFT SANS GARANTIE D'AUCUNE SORTE, EXPLICITE OU IMPLICITE. L'UTILISATEUR ASSUME LE RISQUE DE L'UTILISATION DU CONTENU DE CE DOCUMENT. CE DOCUMENT NE PEUT ETRE REVENDU OU CEDE EN ECHANGE D'UN QUELCONQUE PROFIT.

Envoyer des commentaires

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com