Como resolver problemas relacionados com mensagens de erro de protecção do Windows

Traduções de Artigos Traduções de Artigos
Artigo: 149962 - Ver produtos para os quais este artigo se aplica.
Este artigo foi publicado anteriormente em PT149962
Se este artigo não descrever a mensagem de erro que está a receber, consulte o seguinte artigo da base de dados de conhecimento da Microsoft (KB, Microsoft Knowledge Base) para visualizar mais artigos que descrevem mensagens de erro:
315854 Windows 98 and Windows Me Error Message Resource Center
Expandir tudo | Reduzir tudo

Sintomas

Quando inicia o Windows, pode receber uma das seguintes mensagens de erro, em que nome_do_dispositivo é o nome de um dispositivo:
Ocorreu um erro de protecção do Windows durante a inicialização do dispositivo nome_do_dispositivo
- ou -
Erro de protecção do Windows
Ao encerrar o computador, poderá receber a seguinte mensagem de erro:
Erro de protecção do Windows
NOTA: Para efectuar uma procura na base de dados de conhecimento da Microsoft (KB, Microsoft Knowledge Base) com mais eficácia, utilize as palavras-chave relacionadas com o problema ao efectuar a procura. Se procura informações de resolução de problemas que não estejam mencionadas neste artigo, experimente fazer novas procuras na base de dados de conhecimento da Microsoft (KB, Microsoft Knowledge Base) utilizando as palavras-chave listadas no seguinte artigo da mesma:
242450 Como consultar a Microsoft Knowledge Base através da utilização de palavras-chave

Causa

Este comportamento pode ocorrer quando o computador carrega ou descarrega um controlador de dispositivo virtual (VxD). Em muitos casos, o VxD que não foi carregado ou descarregado é mencionado na mensagem de erro. Em outros casos, poderá não conseguir determinar qual o VxD que provocou o comportamento.

As mensagens de erro de protecção do Windows podem ocorrer em qualquer das seguintes circunstâncias:
  • Se um controlador de modo real e um controlador de modo protegido estiverem em conflito.
  • Se o registo estiver danificado.
  • Se o ficheiro Win.com ou o ficheiro Command.com estiverem infectados com vírus ou se qualquer um deles estiver danificado.
  • Se um controlador de modo protegido for carregado a partir do ficheiro System.ini e o controlador já tiver sido inicializado.
  • Se existir um conflito de endereços de entrada/saída (E/S) físicos ou um conflito de endereços de memória de acesso aleatório (RAM).
  • Se existirem definições incorrectas no CMOS (Complementary Metal Oxide Semiconductor) para um dispositivo periférico incorporado (tais como, definições de cache, temporização da CPU, discos rígidos, etc.).
  • Se a funcionalidade Plug and Play do BIOS (Basic Input/Output System) do computador não estiver a funcionar correctamente.
  • Se a cache ou a memória do computador não estiverem a funcionar correctamente.
  • Se a placa principal do computador não estiver a funcionar correctamente.
  • Se tiver instalado o Microsoft Office 97 e estiver a utilizar o software Novell Client 32.

Resolução

Para resolver o problema associado a uma mensagem de erro de protecção do Windows:
  1. Inicie o computador no Modo de segurança. Para obter informações sobre como iniciar o computador em Modo de segurança, consulte uma das seguintes secções, em função do sistema operativo.

    Windows 95
    Para iniciar o Windows 95 em Modo de segurança, prima a tecla F8 quando visualizar a mensagem "A iniciar o Windows 95" e, em seguida, seleccione Modo de segurança no menu de arranque.
    Windows 98 e Windows 98 Segunda Edição
    Para iniciar o Windows 98 em Modo de segurança, reinicie o computador, mantenha premida a tecla CTRL até que o menu de arranque do Windows 98 seja apresentado e, em seguida, seleccione Modo de segurança.
    Windows Millennium Edition (Me)
    Para iniciar o Windows Me em Modo de segurança, mantenha premida a tecla CTRL enquanto reinicia o computador e, em seguida, seleccione Modo de segurança no menu de arranque do Windows Me.
  2. Se não receber a mensagem de erro ao iniciar o computador em Modo de segurança ou quando encerrar o computador a partir do Modo de segurança, consulte um dos seguintes artigos na base de dados de conhecimento da Microsoft (KB, Microsoft Knowledge Base): Windows 95:
    136337 Troubleshooting Windows 95 Startup Problems
    145926 Como resolver problemas de encerramento do Windows 95
    Windows 98:
    188867 Troubleshooting Windows 98 Startup Problems
    202633 Como resolver problemas de encerramento do Windows 98
    Windows Millennium Edition (Me):
    273738 TITLE: Troubleshooting Windows Me Startup Problems
    273746 Como resolver problemas de encerramento do Windows Me
  3. Se receber a mensagem ao tentar iniciar o computador em Modo de segurança, siga os passos abaixo indicados para restaurar o registo:
    1. Inicie o computador a partir de uma disquete de arranque de emergência (EBD, Emergency Boot Disk). Se não tiver uma EBD, consulte um dos seguintes artigos na base de dados de conhecimento da Microsoft (KB, Microsoft Knowledge Base):
      267287 How to Create a Startup Disk in Windows Millennium Edition
      NOTA: O artigo indicado anteriormente também se aplica ao Windows 98.
      284943 How to Create a Windows 95 Startup Disk in MS-DOS
      187632 Como criar uma disquete de arranque do Windows 98 que suporte FAT32
    2. Siga os passos dos artigos seguintes que correspondam ao sistema operativo.
      221512 How to Manually Restore the Windows 98/Me Registry
      132332 How to back up the Registry (Windows 95)
  4. Se tiver um computador Plug and Play, reinstale o Windows utilizando o comando setup /p I.Para obter informações adicionais sobre como instalar o Windows 95, clique no número de artigo existente abaixo para visualizar o artigo na base de dados de conhecimento da Microsoft (KB, Microsoft Knowledge Base):
    129260 Windows 95 Setup: Description and Troubleshooting Steps
  5. Se estiver a utilizar o software Novell Client 32, remova-o e, em seguida, instale o Cliente Microsoft para redes Novell.
  6. Verifique se as definições do CMOS do computador estão correctas. Para obter informações sobre como alterar as definições do CMOS do computador, consulte a documentação do computador ou contacte o fabricante.
  7. Instale uma cópia limpa do Windows numa pasta vazia. Para obter mais informações, consulte um dos seguintes artigos:
277648 How to Install Windows Millennium Edition in a New Folder
193902 How to Install Windows 98 Into a New Folder
142096 How to Reinstall Windows 95 to a New Folder
IMPORTANT: Se a mensagem de erro persistir, é provável que seja causada por problemas de hardware.

Mais Informação

O VxD que está a gerar a mensagem de erro pode ser qualquer VxD, seja um VxD instalado por predefinição, seja um controlador .386 de outro fornecedor que carregado a partir do ficheiro System.ini. Se não sabe qual o controlador que está a causar a apresentação da mensagem de erro, crie um ficheiro Bootlog.txt e, em seguida, examine esse ficheiro para averiguar qual o último controlador inicializado. Normalmente, este é o controlador que está a causar o problema.

NOTA: Também pode receber uma mensagem de erro de protecção do Windows quando reinicia o Windows 95 após instalar um programa ou efectuar um alteração à configuração do computador. Para obter informações adicionais sobre este problema, clique no número de artigo existente abaixo para visualizar o artigo na base de dados de conhecimento da Microsoft (KB, Microsoft Knowledge Base):
157924 Err Msg: "IOS Failed to Initialize" on Boot
Para obter informações adicionais sobre como resolver erros de protecção do Windows, clique no número de artigo existente abaixo para visualizar o artigo na base de dados de conhecimento da Microsoft (KB, Microsoft Knowledge Base):
131431 How to Troubleshoot Registry Errors in Windows 95

Propriedades

Artigo: 149962 - Última revisão: 30 de dezembro de 2004 - Revisão: 1.4
A informação contida neste artigo aplica-se a:
  • Microsoft Windows Millennium Edition
  • Microsoft Windows 98 Segunda Edição
  • Microsoft Windows 98 Standard Edition
  • Microsoft Windows 95
Palavras-chave: 
kberrmsg kbtshoot kbprb kbprod2web kbdiskmemory KB149962

Submeter comentários

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com