Felsökning vid meddelanden om Windows skyddsfel

Artikelöversättning Artikelöversättning
Artikel-id: 149962 - Visa produkter som artikeln gäller.
Om den här artikeln inte innehåller en beskrivning av felmeddelandet som visas, kan du besöka följande Microsoft-webbplats och läsa fler artiklar om felmeddelanden:
315854Resurscenter för felmeddelanden i Windows 98 och Windows ME
Visa alla | Dölj alla

Symptom

Vid start av Windows visas något av följande felmeddelanden, där enhetsnamn är ett enhetsnamn:
Windows skyddsfel när enhetsnamn skulle startas
eller
Windows skyddsfel
När du stänger av datorn visas följande felmeddelande:
Windows skyddsfel
Obs! Om du vill söka mer effektivt i Microsoft Knowledge Base kan du använda nyckelord med anknytning till problemet. Om du söker efter felsökningsinformation som inte behandlas i den här artikeln, kan du söka i Microsoft Knowledge Base igen med hjälp av nyckelord från följande artikel i Microsoft Knowledge Base:
242450 Söka i Microsoft Knowledge Base med nyckelord

Orsak

Det här problemet kan uppstå när en virtuell drivrutin (VxD) laddas eller tas bort. I många fall nämns den virtuella drivrutinen som inte laddades eller togs bort i felmeddelandet. I andra fall går det inte att fastställa vilken drivrutin som orsakade problemet.

Meddelanden om Windows skyddsfel kan visas under något av följande förhållanden:
  • Det finns en konflikt mellan en drivrutin för realläge och en drivrutin för skyddat läge.
  • Registret är skadat.
  • Filen Win.com eller Command.com file har angripits av ett virus eller skadats.
  • En drivrutin för skyddat läge laddas från filen System.ini, och drivrutinen har redan initierats.
  • Det finns en fysisk I/O-adresskonflikt (Input/output) eller en RAM-adresskonflikt (Random Access Memory).
  • Det finns felaktiga CMOS-inställningar (Complementary Metal Oxide Semiconductor) för inbyggd kringutrustning (till exempel cache-inställning, CPU-tidsinställning eller hårddiskar).
  • Plug and play-funktionen i datorns BIOS (Basic Input/Output System) fungerar inte korrekt.
  • En cache eller ett minne fungerar inte.
  • Datorns moderkort fungerar inte.
  • Du har installerat Microsoft Office 97 och använder programmet Novell Client 32.

Lösning

Så här gör du vid ett meddelande om Windows skyddsfel:
  1. Starta datorn i felsäkert läge. Gör så här:

    Windows 95
    Tryck på F8 när meddelandet "Startar Windows 95" visas och välj sedan Felsäkert lägeStart-menyn.
    Windows 98 och Windows 98, andra utgåvan
    Starta om datorn, håll CTRL nedtryckt tills Start-menyn visas och välj sedan Felsäkert läge.
    Windows Millennium Edition (ME)
    Håll CTRL nedtryckt medan du startar om datorn, och välj Felsäkert lägeStart-menyn.
  2. Om inget felmeddelande visas när datorn startas eller stängs av i felsäkert läge läser du någon av följande artiklar i Microsoft Knowledge Base: Windows 95:
    136337Felsökning av startproblem i Windows 95
    145926 Så här felsöker du avstängningsproblem i Windows 95
    Windows 98:
    188867Felsökning av startproblem i Windows 98
    202633 Så här felsöker du avstängningsproblem i Windows 98
    Windows Millennium Edition (ME):
    273738 TITEL: Felsökning av startproblem i Windows ME
    273746 TITEL: Så här felsöker du avstängningsproblem i Windows ME
  3. Om felmeddelandet visas när du försöker starta datorn i felsäkert läge återställer du registret så här:
    1. Starta datorn med en reparationsstartdiskett. Om du inte har någon reparationsstartdiskett läser du en av följande artiklar i Microsoft Knowledge Base:
      267287 Skapa en startdiskett i Windows Millennium Edition
      Obs! Föregående artikel gäller även Windows 98.
      284943 Skapa en startdiskett för Windows 95 i MS-DOS
      187632 Skapa en startdiskett för Windows 98 som stöder
    2. Följ anvisningarna för ditt operativsystem i följande artiklar:
      221512 Återställa registret i Windows 98/ME manuellt
      132332 Säkerhetskopiera registret (Windows 95)
  4. Om du har en Plug and play-dator installerar du om Windows med hjälp av kommandot setup /p I.Om du vill veta mer om hur du installerar Windows 95 klickar du på artikelnumret nedan och läser artikeln i Microsoft Knowledge Base:
    129260 Installation av Windows 95: Beskrivning och felsökning
  5. Om du använder programmet Novell Client 32 tar du bort det och installerar sedan Microsoft Client for Novell Networks.
  6. Kontrollera att datorns CMOS-inställningar är korrekta. Information om ändring av CMOS-inställningarna finns i dokumentationen till datorn eller kan fås från datortillverkaren.
  7. Installera en "ren" kopia av Windows i en tom mapp. Mer information finns i följande artiklar:
277648 Installera Windows Millennium Edition i en ny mapp
193902 Installera Windows 98 i en ny mapp
142096 Installera om Windows 95 i en ny mapp
VIKTIGT! Om felmeddelandet återkommer beror det sannolikt på ett maskinvarufel.

Mer Information

Den virtuella drivrutinen som orsakar felmeddelandet kan vara en standarddrivrutin som är installerad eller en .386-drivrutin från en annan tillverkare som laddas från filen System.ini. Om du inte vet vilken drivrutin som orsakar felmeddelandet skapar du en Bootlog.txt-fil, och kontrollerar sedan vilken drivrutin som initierades senast. Det brukar vara den drivrutinen som orsakar problemet.

Obs! Ett meddelande om Windows skyddsfel kan också visas vid omstart av Windows 95 efter installation av ett program eller en konfigurationsändring av datorn. Om du vill veta mer om det här problemet klickar du på artikelnumret nedan och läser artikeln i Microsoft Knowledge Base:
157924 Felmeddelande: "Det gick inte att initiera IOS" visas vid start
Om du vill veta mer om hur du löser Windows-skyddsproblem klickar du på artikelnumret nedan och läser artikeln i Microsoft Knowledge Base:
131431 Felsökning vid registerfel i Windows 95

Egenskaper

Artikel-id: 149962 - Senaste granskning: den 30 december 2004 - Revision: 1.1
Informationen i denna artikel gäller:
  • Microsoft Windows Millennium Edition
  • Microsoft Windows 98 Second Edition
  • Microsoft Windows 98 Standard Edition
  • Microsoft Windows 95
Nyckelord: 
kberrmsg kbtshoot kbprb kbprod2web kbdiskmemory KB149962

Ge feedback

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com