Hard Disk Errors Caused by Damaged Data or Physical Damage

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Article ID: 150532 - View products that this article applies to.
This article was previously published under Q150532
If this article does not describe your hardware-related issue, please see the following Microsoft Web site to view more articles about hardware:
http://support.microsoft.com/default.aspx/w98?sid=460
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SYMPTOMS

You may receive one of the following error messages when you are starting or using your computer:
  • Serious Disk Error Writing Drive <X>
  • Data Error Reading Drive <X>
  • Error Reading Drive <X>
  • I/O Error
  • Seek Error - Sector not found

CAUSE

These error messages indicate either damaged data or physical damage on the hard disk.

RESOLUTION

To test the hard disk, run ScanDisk. To run ScanDisk from within Windows, follow these steps:
  1. Click Start, point to Programs, point to Accessories, point to System Tools, and then click ScanDisk.
  2. Click the drive you want to examine for errors.
  3. Click Thorough, and then click Start.
Running ScanDisk with the Thorough option selected examines the hard disk for physical damage. If damaged data is detected, ScanDisk gives you the option to save the damaged data to a file or to discard the data. The ScanDisk surface scan may take a considerable amount of time on large hard disks.

To run ScanDisk from a command prompt outside of Windows, follow these steps:
  1. Click the Start button, click Shut Down, click Restart The Computer In MS-DOS Mode, and then click Yes.
  2. Type the following command at the command prompt, and then press ENTER

    scandisk <x>:

    where <x> is the letter of the hard disk you want to check.
  3. When ScanDisk finishes its initial check, it prompts you to perform a surface scan on the drive. Click Yes or press ENTER.
If ScanDisk is unable to repair damaged data, or indicates that the hard disk has physical damage, you may need to have the hard disk checked by a qualified service professional.

Properties

Article ID: 150532 - Last Review: January 19, 2007 - Revision: 2.1
APPLIES TO
  • Microsoft Windows Millennium Edition
  • Microsoft Windows 98 Second Edition
  • Microsoft Windows 98 Standard Edition
  • Microsoft Windows 95
Keywords: 
kbfaq kbhardware kbprb kbscandisk KB150532

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