XL: Cómo crear un cuadro de diálogo dinámica

Seleccione idioma Seleccione idioma
Id. de artículo: 151343 - Ver los productos a los que se aplica este artículo
Expandir todo | Contraer todo

En esta página

Resumen

En el ejemplo siguiente se explica cómo crear un cuadro de diálogo dinámico que cambia de tamaño para mostrar más opciones al hacer clic en un botón en el cuadro de diálogo.

Más información

Microsoft proporciona ejemplos de programación con fines ilustrativos únicamente, sin ninguna garantía tanto expresa como implícita. Esto incluye, entre otras, las garantías implícitas de comerciabilidad e idoneidad para un fin determinado. Este artículo se supone que está familiarizado con el lenguaje de programación que se muestra y con las herramientas que se utilizan para crear y depurar procedimientos. Los ingenieros de soporte técnico de Microsoft pueden explicarle la funcionalidad de un determinado procedimiento, pero no modificarán estos ejemplos para ofrecer mayor funcionalidad ni crearán procedimientos que cumplan sus requisitos específicos.

Crear el cuadro de diálogo

Para crear el cuadro de diálogo, siga estos pasos:

  1. En un libro nuevo, en el menú Insertar , haga clic en macro y, a continuación, cuadro de diálogo .
  2. En la barra de herramientas formularios , haga clic en el botón Botón de opción . El puntero del mouse (ratón) cambiará a una cruz. Sitúe el puntero media pulgada por debajo la parte inferior del Dialog1. Presione y mantenga presionado el botón primario del mouse y arrastre hacia abajo de un cuarto de pulgada y a través de uno y-a-Media pulgadas. Suelte el botón del mouse (ratón). Ahora debería ser un botón de opción debajo Dialog1.
  3. En la barra de herramientas formularios haga clic en el botón Crear . Dentro de Dialog1, centrar las pulgadas y-un-semestre de puntero desde la parte inferior y pulgadas de uno y medio desde el lado derecho del cuadro de diálogo. Arrastre hacia abajo tres cuartos de pulgada y sobre a la derecha tres cuartos de pulgada. Suelte el botón del mouse (ratón). Ahora debe haber un botón rectangular en Dialog1.

Crear el código

Para crear el código, siga estos pasos:
  1. En el menú Insertar , haga clic en macro y, a continuación, en el módulo .
  2. Escriba el siguiente código:
          Sub Show_Dialog()
          DialogSheets(1).Show
          DialogSheets(1).DialogFrame.Height = 147
          End Sub
    
          Sub Expand()
          DialogSheets(1).DialogFrame.Height = 200
          End Sub
    					

Asociar el expandir procedimiento al botón de cuadro de diálogo

Para adjuntar el procedimiento de expandir el botón de diálogo, siga estos pasos:
  1. Activar la hoja Dialog1 haciendo clic en su ficha de hoja.
  2. Sitúe el puntero del mouse (ratón) encima del botón que creó en la esquina inferior derecha del Dialog1. Haga clic una vez con el botón secundario del mouse. Haga clic en Asignar Macro en el menú contextual y, en la lista de macros disponibles, seleccione Expandir . Haga clic en Aceptar .

Ejecuta la macro

Para ejecutar la macro, siga estos pasos:

  1. Activar una hoja de cálculo dentro del libro. En la barra de herramientas formularios , haga clic en el botón Crear y cree un botón en la hoja de cálculo actual. Aparecerá el cuadro de diálogo Asignar Macro . Seleccione Show_Dialog y, a continuación, haga clic en Aceptar .
  2. Haga clic con el botón primario del mouse una vez en un área en blanco de la hoja de cálculo actual.
  3. Haga clic con el botón primario del mouse una vez en el botón para ejecutar la macro.
  4. Cuando aparezca el cuadro de diálogo, haga clic en con el botón primario del mouse una vez en el botón que ha creado para mostrar el botón de opción. Haga clic en Aceptar para cerrar el cuadro de diálogo.

Referencias

"Del usuario de Visual Basic manual,"versión 5.0, capítulo 11,"controles y cuadros de diálogo"

Para obtener más información acerca de cuadros de diálogo de Microsoft Excel versión 7.0, haga clic en Asistente para Ayuda en el menú Ayuda y el tipo:
   Dialog boxes
				
para obtener más información acerca de cuadros de diálogo de Microsoft Excel versión 5.0, haga clic en Ayuda y escriba en el botón de búsqueda :
   Dialog boxes
				

Propiedades

Id. de artículo: 151343 - Última revisión: miércoles, 11 de octubre de 2006 - Versión: 2.3
La información de este artículo se refiere a:
  • Microsoft Excel 5.0 Standard Edition
  • Microsoft Excel 5.0c
  • Microsoft Excel 95 Standard Edition
Palabras clave: 
kbmt kbhowto kbprogramming KB151343 KbMtes
Traducción automática
IMPORTANTE: Este artículo ha sido traducido por un software de traducción automática de Microsoft (http://support.microsoft.com/gp/mtdetails) en lugar de un traductor humano. Microsoft le ofrece artículos traducidos por un traductor humano y artículos traducidos automáticamente para que tenga acceso en su propio idioma a todos los artículos de nuestra base de conocimientos (Knowledge Base). Sin embargo, los artículos traducidos automáticamente pueden contener errores en el vocabulario, la sintaxis o la gramática, como los que un extranjero podría cometer al hablar el idioma. Microsoft no se hace responsable de cualquier imprecisión, error o daño ocasionado por una mala traducción del contenido o como consecuencia de su utilización por nuestros clientes. Microsoft suele actualizar el software de traducción frecuentemente.
Haga clic aquí para ver el artículo original (en inglés): 151343
Renuncia a responsabilidad de los contenidos de la KB sobre productos a los que ya no se ofrece asistencia alguna
El presente artículo se escribió para productos para los que Microsoft ya no ofrece soporte técnico. Por tanto, el presente artículo se ofrece "tal cual" y no será actualizado.

Enviar comentarios

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com