Errore -1018 (JET_errReadVerifyFailure) in Exchange Server 4.0, in Exchange Server 5.0 e in Exchange Server 5.5

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Sintomi

Sintomi includono qualsiasi operazione di database JET che i risultati in un ? 1018 (JET_errReadVerifyFailure) e/o qualsiasi visualizzatore degli eventi applicazione log errore segnalato incluso il codice di errore ? 1018 nella relativa descrizione, come quella riportata di seguito:
ID evento: 23
Origine: EDB
Tipo: errore
Categoria: Cache pagina di database
Descrizione: Direct MSExchangeIS ((455)) lettura trovato pagina danneggiato errore -1018 ((1:251563) (0-2295758) 251563 379225672 381322824). Ripristinare il database da un backup precedente.

Cause

Quando si esegue una transazione con il database Jet, nell'archivio di informazioni o l'archivio di directory viene scrive la transazione in un file di registro delle transazioni (Edb*.log in Mdbdata o Dsadata). La transazione Ŕ impegnata quindi del database Jet. Durante questo processo, di Jet calcola il valore di checksum della pagina deve essere scritto, Registra nell'intestazione della pagina e quindi richiede che il file system scrive la pagina di 4 KB di dati nel database sul disco. In breve, il file system accetta questa chiamata e utilizza servizi di sistema di Windows per inoltrare la richiesta al driver di periferica hardware corrispondente per eseguire effettivamente la scrittura. Il driver di periferica hardware restituisce le informazioni nel file System, quindi restituisce di Microsoft Jet. Se la chiamata ha esito positivo, continua Jet.

Hardware difettoso o driver di periferica hardware potrebbero restituire SUCCESS per chiamate effettuate a essi prima che effettivamente eseguire l'operazione fisica. Quando l'operazione fisica effettiva viene eseguita, tuttavia, si verifica un errore e i dati non vengono scritti correttamente come previsto.

In alcuni database delle operazioni, ad esempio, ma non Ŕ limitata alla Online, la routine di backup effettua una chiamata al sistema operativo per leggere una pagina di 4 KB di dati dal database sul disco e scriverli su nastro. Prima che il commit dei dati restituito dalla chiamata di sistema operativo sul nastro, il processo di backup in linea confronta il valore di checksum nell'intestazione della pagina (registrati quando questa pagina Ŕ stato scritto su disco) a quello restituito dalla lettura chiamare. Se i valori di checksum non corrispondono, il motore di database JET rileva questo e restituisce ? 1018 (JET_errReadVerifyFailure).

Risoluzione

Per risolvere il problema, utilizzare uno dei metodi seguenti.

Ripristino da un backup

Quando si verifica l'errore, il consigliata e pi¨ affidabile per recuperare il database consiste nel ripristinare dal backup buona noti l'ultimo.

NOTES :

Anche dopo il ripristino da un backup noto valido, tuttavia, gli errori ? 1018 potrebbe essere visualizzato nuovamente a meno che non fa sý che la directory principale della scrittura di dati fisici vengono risolti i problemi.

Il Registro di sistema di Windows NT dovrÓ essere esaminato per gli errori segnalati dai dischi rigidi e controller del disco rigido nonchÚ al sottosistema di dischi a tolleranza di errore di NT (FTDISK). In particolare, potrebbe essere visualizzato errori correlati al hardware quali errori di timeout, errori di memoria o errori di danneggiamento unitÓ SCSI. Questi errori devono essere affrontati e risolti prima di ripristinare il database Ŕ a questo server.

Anche nel se in cui nel Registro di sistema di Windows vengono visualizzati il non errori relativi ai componenti hardware, potrebbe esistere un problema hardware del computer.

Contattare il fornitore dell'hardware per ulteriori aggiornamenti riguardanti l'hardware recommendeds di Microsoft.

Utilizzare Edbutil.exe o Eseutil.exe

Un metodo alternativo per ripristinare la pagina errata dei dati consiste utilizzare Edbutil.exe per Exchange Server 4.0 e 5.0 o Eseutil.exe per Exchange Server 5.5.

importante : crea un backup di file non in linea completa dei file di database e di registro prima di eseguire questo processo. Questo include il backup di file a livello di cartelle Exchsrvr\Dsadata ed Exchsrvr\Mdbdata. Questo garantisce che vi sia un modo per passare nuovamente in caso di edbutil/eseutil.

Edbutil.exe (ed Eseutil.exe) Ŕ una versione a basso livello del database di utilitÓ di Jet consente di deframmentare che verifica la coerenza del database. ╚ inoltre disponibile un'opzione di ripristino (Edbutil /d /r <dbname>, Eseutil /p <dbname>) che tenta di ripristinare le pagine non valide ed eventualmente rimuoverli se il ripristino ha esito negativo. Se una pagina viene rimosso utilizzando l'opzione di ripristino, si verificherÓ una perdita di dati. Una pagina in un database pu˛ contenere messaggi, cartelle, tabelle, indici di master e cosý via. Non Ŕ possibile stabilire quali EDBUTIL o Eseutil Ŕ rimossa perchÚ Jet visualizzati dati come non elaborati. Al termine ripristino sul database Jet, eseguire una deframmentazione non in linea (EDBUTIL /D <dbname> o Eseutil /p <dbname>) per ripristinare le strutture di spazio. Immediatamente dopo la deframmentazione, Ŕ necessario eseguire Isinteg.exe in modalitÓ di correzione sul database stesso eseguito sul EDBUTIL o Eseutil. Isinteg elimina eventuali incoerenze tra i puntatori dall'archivio informazioni ai dati effettivi nel database Jet. Se Isinteg non viene eseguito immediatamente ripristino seguenti, nelle cassette postali degli utenti potrebbero essere danneggiati. Gli utenti avranno i messaggi che non possono essere aperto, conteggi letto/non corretti e cosý via. Dopo l'esecuzione di EDBUTIL o Eseutil, eseguire backup del database che Ŕ stato ripristinato un FULL.

Vedere il Manuale dell'amministratore di Microsoft Exchange Server per ulteriori informazioni sull'utilizzo di Edbutil.exe e Isinteg.exe.

Risolvere il problema

Se si riesce a risolvere il problema tramite il ripristino da un backup utilizzando Edbutil.exe o Eseutil.exe, attenersi alla seguente procedura per risolvere il problema. Dopo aver eseguito ciascun passaggio, verificare se il problema Ŕ stato risolto.
  1. Riavviare il computer. Se non si desidera riavviare il computer in questa fase, arrestare e riavviare i servizi di archivio e la directory di informazioni invece. Per effettuare questa operazione:
    1. Nel Pannello di controllo, fare doppio clic su servizi .
    2. Fare clic su Directory di Microsoft Exchange e quindi scegliere Arresta . Se una finestra di dialogo appare indicante la che ulteriori servizi verranno interrotti, prendere nota dei servizi che verranno arrestati, quindi fare clic su OK . Il servizio Archivio informazioni deve essere inclusa nell'elenco dei servizi che verranno arrestati.
    3. Fare clic su Directory di Microsoft Exchange e fare clic sul pulsante Start .
    4. Avviare i servizi aggiuntivi sono stati interrotti nel passaggio b, incluso il servizio Archivio informazioni.
  2. Utilizzare l'utilitÓ Chkdsk.exe per verificare l'integritÓ del disco rigido.
  3. Se la cartella Exchsrvr si trova su un'unitÓ di sistema di file NTFS compressa, decomprimere l'unitÓ.
  4. Se la cache write-back Ŕ attivata in un controller di disco rigido SCSI installato nel computer, verificare che la cache non volatile. Cache non volatile sono protetti da una batteria, RAM flash o un altro metodo.
  5. Disattivare i programmi che consente di mantenere aperto il file per un lungo periodo di tempo, ad esempio programmi antivirus, utilitÓ di gestione file e il disco o i programmi di backup. Se la disattivazione di un programma impedisce il problema, Ŕ necessario verificare che il programma sia completamente compatibile con Exchange Server prima di abilitarlo nuovamente.
  6. Eseguire l'ottimizzazione delle prestazioni (PerfWiz.exe) sul server.
  7. Verificare che le impostazioni memoria virtuale in Windows NT Server siano corrette. Per visualizzare le impostazioni di memoria virtuale, nel Pannello di controllo, fare doppio clic sull'icona sistema , scegliere la scheda prestazioni e quindi fare clic su Cambia .
  8. Se si eseguono le utilitÓ disco ottenute le apparecchiature originale (OEM), Ŕ necessario verificare che si eseguano la versione pi¨ recente dei programmi.
  9. Utilizzare i contatori di prestazioni associati i seguenti oggetti per rilevare potenziali problemi:
    • Cache
    • Database
    • Disco logico
    • Memoria
    • MSExchangeIS
    • File di paging
    • Disco fisico
    • Processo
    • Code di lavoro server
    • Server
    • Sistema
    • Thread

ProprietÓ

Identificativo articolo: 151789 - Ultima modifica: sabato 28 ottobre 2006 - Revisione: 4.4
Le informazioni in questo articolo si applicano a:
  • Microsoft Exchange Server 4.0 Standard Edition
  • Microsoft Exchange Server 5.0 Standard Edition
  • Microsoft Exchange Server 5.5 Standard Edition
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