Fout-1018 (JET_errReadVerifyFailure) in Exchange Server 4.0 en Exchange Server 5.0 en Exchange Server 5.5

Vertaalde artikelen Vertaalde artikelen
Artikel ID: 151789 - Bekijk de producten waarop dit artikel van toepassing is.
Alles uitklappen | Alles samenvouwen

Op deze pagina

Symptomen

Symptomen omvatten de JET database-bewerking die resulteert in een-1018 (JET_errReadVerifyFailure) en/of een Windows NT-Logboeken logboek toepassingsfout gemeld die opgenomen de foutcode-1018 in de Beschrijving de volgende:
Gebeurtenis-ID: 23
Bron: EDB
Type: fout
Categorie: Database pagina Cache
Beschrijving: Directe lezen MSExchangeIS ((455)) gevonden beschadigde paginafout-1018 ((1:251563) (0-2295758) 251563 379225672 381322824). Herstel de een database uit een vorige back-up.

Oorzaak

Wanneer u een transactie met de Jet-database de informatie-archief of het maparchief schrijft de transactie een transactielogbestand (Edb*.log in Mdbdata- of Dsadata). De transactie is de Jet-database wordt doorgevoerd. Tijdens dit proces berekend de Jet engine de controlesom van de pagina worden geschreven, vastgelegd in de paginakoptekst en vraagt dat het bestandssysteem de pagina van 4 KB gegevens naar de database schrijft op schijf. In het kort het bestandssysteem neemt deze aanroep en gebruikt het Windows NT-systeem Services voor het doorsturen van de bijbehorende apparaatstuurprogramma op verzoek voeren het schrijven. Het apparaatstuurprogramma wordt deze informatie het bestandssysteem dat wordt geretourneerd met de Jet-engine. Als de aanroep succesvolle, Jet blijft.

Defecte hardware of stuurprogramma's voor hardwareapparaten SUCCES kan terugkeren naar oproepen naar hen voordat zij daadwerkelijk uitvoeren de fysieke bewerking. Wanneer u de werkelijke fysieke bewerking plaatsvindt, echter een fout optreedt en de gegevens is niet geschreven zoals verwacht.

In bepaalde bewerkingen, zoals database, maar niet beperkt tot Online back-up, de back-up routine belt naar het besturingssysteem een pagina van 4 KB gegevens lezen uit de database op de schijf te schrijven naar tape. Voordat de gegevens de aanroep van het besturingssysteem op de band de online back-up wordt geretourneerd De controlesomwaarde in de paginakoptekst (vastgelegd wanneer deze pagina is vergeleken naar de schijf geschreven) aanroepen die wordt geretourneerd door het lezen. Als de controlesom waarden niet overeenkomen, de JET database engine gedetecteerd en retourneert-1018 (JET_errReadVerifyFailure).

Oplossing

Gebruik een van de volgende methoden het probleem op te lossen.

Een back-up terugzetten

Wanneer het optreden van de fout, aanbevolen en meest betrouwbare manier om te herstellen van de database is terugzetten vanaf de laatst bekende goede back-up.

Notities:

Zelfs nadat u een goede reservekopie, terugzetten echter, 1018-fouten opnieuw weergegeven tenzij de hoofdoorzaken van de fysieke gegevens schrijven problemen zijn opgelost.

Het systeemlogboek van Windows NT moeten worden gecontroleerd op fouten die door de vaste schijven en de vaste schijf controllers, alsmede op de NT-fouttolerantie, schijf subsysteem (FTDISK). In name, hardware-gerelateerde fouten zoals SCSI-time-outfouten, geheugen fouten of het station beschadigd fouten weergegeven. Deze fouten moeten worden behandeld. met en opgelost voordat de database wordt hersteld met deze server.

Zelfs als er geen hardware-gerelateerde fouten in het systeemlogboek van Windows NT weergegeven een hardwareprobleem optreden op uw computer.

Microsoft recommendeds u contact met de hardwarefabrikant voor verdere updates met betrekking tot de hardware.

Gebruik Edbutil.exe of Eseutil.exe

Een alternatieve manier om te herstellen van beschadigde pagina van gegevens is het gebruik van Edbutil.exe voor Exchange Server 4.0 en 5.0 of Eseutil.exe voor Exchange Server 5.5.

Belangrijk: een volledige back-up van de database en logboekbestanden maken voordat u dit proces. Dit omvat bestandsniveau back-ups van de De mappen Exchsrvr\Dsadata en Exchsrvr\Mdbdata. Hierdoor is er een manier Ga terug als Edbutil/eseutil mislukt.

Edbutil.exe (en Eseutil.exe) is een low-level hulpprogramma voor Jet-database defragmenteren en controleert de consistentie van de database. Er is ook een hersteloptie (Edbutil /d /r <dbname>, Eseutil /p <dbname>) die probeert te herstellen van beschadigde pagina's en verwijderen het herstel is mislukt. Als een pagina wordt verwijderd met de optie herstellen, gegevens zullen verloren gaan. Een pagina in een database kan bevatten berichten, mappen, tabellen, master indexen, enzovoort. Er is geen manier om te zien welke Edbutil of Eseutil is verwijderd omdat Jet als onbewerkte gegevens ziet. Nadat het herstellen is voltooid op de Jet-database, een offline defragmentatie uitvoert (Edbutil /D <dbname>of Eseutil /p <dbname>) ruimte bomen te herstellen. Onmiddellijk na de defragmentatie, Isinteg.exe uitgevoerd in de modus correctie op dezelfde database die Edbutil of Eseutil is uitgevoerd op. Isinteg ruimt inconsistenties tussen de aanwijzers uit het informatiearchief de werkelijke gegevens in de Jet-database. Als Isinteg onmiddellijk na de reparatie, beschadiging optreden in de gebruiker wordt niet uitgevoerd postvakken. Gebruikers hebben de berichten die niet kunnen geopend, is onjuist worden Lees/ongelezen tellingen, enzovoort. Na Edbutil of Eseutil uitvoert, moet u een volledige back-up van de database is hersteld.

Raadpleeg de Microsoft Exchange Server Administrator's Guide voor meer informatie over het gebruik van Edbutil.exe en Isinteg.exe. </dbname></dbname></dbname></dbname>

Het probleem oplossen

Als u nog niet het probleem oplossen door het herstellen van een back-up of Edbutil.exe of Eseutil.exe, gebruiken de volgende stappen het probleem oplossen. Controleer na elke stap of het probleem is opgelost.
  1. Start de computer opnieuw op. Als u niet wilt opstarten de stop en start het informatiearchief en de map computer op dit moment Services in plaats daarvan. Om dit te doen:
    1. Dubbelklik op Servicesin het Configuratiescherm.
    2. Klik op de Microsoft Exchange-mapen klik vervolgens op stoppen. Als er een dialoogvenster weergegeven waarin wordt gemeld dat er extra services zal gestopt, Let op de services die worden gestopt en vervolgens op OK. De information store-service moet worden opgenomen in de lijst met Services die worden gestopt.
    3. Klik op de Microsoft Exchange-mapen klik op starten.
    4. Eventuele extra services die zijn gestopt in stap starten b, inclusief de information store-service.
  2. Gebruik het hulpprogramma Chkdsk.exe uit om te controleren of de integriteit van uw harde schijven.
  3. Als de map Exchsrvr zich op een gecomprimeerd NTFS-bestand systeem station, het station te decomprimeren.
  4. Als write-back cachegebruik is ingeschakeld op een SCSI-vaste schijf controller geïnstalleerd in uw computer controleren of de cache is niet vluchtig. Niet-vluchtige cache worden beschermd door een batterij, Flash RAM-geheugen of een ander methode.
  5. Programma's die bestanden openen voor een uitgebreide houden uitschakelen periode van tijd, zoals antivirusprogramma's bestand en Schijfbeheer hulpprogramma's of back-upprogramma's. Als u een programma uit te schakelen voorkomt u dat het probleem van optreedt, Controleer of het programma is volledig compatibel met Exchange De server voordat u deze opnieuw inschakelen.
  6. Performance Optimizer (Perfwiz.exe) uitvoeren op de Server.
  7. Controleer de instellingen van het virtuele geheugen in Windows NT Server juist zijn. De instellingen van het virtuele geheugen in het Configuratiescherm weergeven Dubbelklik op systeem, klik op het tabblad prestaties en klik vervolgens op wijzigen.
  8. Als u een vaste schijf utilities verkregen uit Controleer uw original equipment manufacturer (OEM), of u de meest recente versie van de programma's.
  9. Gebruik de prestatiemeters die is gekoppeld aan de objecten van de volgende mogelijke problemen te detecteren:
    • Cache
    • Database
    • Logische schijf
    • Geheugen
    • MSExchangeIS
    • Wisselbestand
    • Fysieke schijf
    • Proces
    • Serverwerkwachtrijen
    • Server
    • Systeem
    • Thread

Eigenschappen

Artikel ID: 151789 - Laatste beoordeling: dinsdag 17 juli 2012 - Wijziging: 4.0
De informatie in dit artikel is van toepassing op:
  • Microsoft Exchange Server 4.0 Standard Edition
  • Microsoft Exchange Server 5.0 Standard Edition
  • Microsoft Exchange Server 5.5 Standard Edition
Trefwoorden: 
kbprb kbusage kbmt KB151789 KbMtnl
Automatisch vertaald artikel
BELANGRIJK: Dit artikel is vertaald door de vertaalmachine software van Microsoft in plaats van door een professionele vertaler. Microsoft biedt u professioneel vertaalde artikelen en artikelen vertaald door de vertaalmachine, zodat u toegang heeft tot al onze knowledge base artikelen in uw eigen taal. Artikelen vertaald door de vertaalmachine zijn niet altijd perfect vertaald. Deze artikelen kunnen fouten bevatten in de vocabulaire, zinsopbouw en grammatica en kunnen lijken op hoe een anderstalige de taal spreekt en schrijft. Microsoft is niet verantwoordelijk voor onnauwkeurigheden, fouten en schade ontstaan door een incorrecte vertaling van de content of het gebruik ervan door onze klanten. Microsoft past continue de kwaliteit van de vertaalmachine software aan door deze te updaten.
De Engelstalige versie van dit artikel is de volgende: 151789
Vrijwaring inhoud KB-artikelen over niet langer ondersteunde producten
Dit artikel heeft betrekking op producten waarvoor Microsoft geen ondersteuning meer biedt. Daarom wordt dit artikel alleen in de huidige vorm aangeboden en wordt het niet meer bijgewerkt.

Geef ons feedback

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com