Macro para guardar automáticamente personal.xls sin preguntar

Seleccione idioma Seleccione idioma
Id. de artículo: 153893 - Ver los productos a los que se aplica este artículo
Expandir todo | Contraer todo

En esta página

Resumen

Cuando se edita el archivo personal.xls en Microsoft Excel para Windows (o el libro macros personales en Microsoft Excel para Macintosh), pide guardar los cambios al salir de Microsoft Excel.

En este artículo se describe cómo crear una macro que impide el mensaje que aparezca y que guarda los cambios automáticamente al cerrar el archivo.

Para obtener información sobre el propósito y la ubicación de este archivo, vea la sección "Background" más adelante en este artículo.

Más información

Microsoft proporciona ejemplos de programación con fines ilustrativos únicamente, sin ninguna garantía tanto expresa como implícita. Esto incluye, entre otras, las garantías implícitas de comerciabilidad e idoneidad para un fin determinado. Este artículo se supone que está familiarizado con el lenguaje de programación que se muestra y con las herramientas que se utilizan para crear y depurar procedimientos. Los ingenieros de soporte técnico de Microsoft pueden explicarle la funcionalidad de un determinado procedimiento, pero no modificarán estos ejemplos para ofrecer mayor funcionalidad ni crearán procedimientos que cumplan sus requisitos específicos. Para guardar el archivo de macro automáticamente cuando salga de Microsoft Excel, utilice el método apropiado para su situación.

Microsoft Excel 97 para Windows

  1. En el menú Ventana, haga clic en mostrar.
  2. En la lista "Mostrar libro", haga clic en personal.xls y haga clic en Aceptar.
  3. En el menú Herramientas, seleccione Macro y haga clic en Editor de Visual Basic.

    Aparecerá el Editor de Visual Basic.
  4. En el panel proyecto, haga clic en el signo más junto a "VBAProject (personal.xls)". A continuación, haga clic en el signo más junto a "Módulos". Haga doble clic en uno de los módulos que aparece como parte de personal.xls.
  5. En el panel de código, escriba el siguiente código:
          Sub Auto_Close()
             ThisWorkbook.Save
          End Sub
    						
  6. En el menú Archivo, haga clic en "cerrar y volver a Microsoft Excel.
  7. En el menú Ventana, haga clic en ocultar.
  8. En el menú Archivo, haga clic en Salir para salir de Microsoft Excel.
No se le debe guardar el archivo personal.xls cuando salga de Microsoft Excel.

Microsoft Excel 5.0 y 7.0 para Windows

  1. En el menú Ventana, haga clic en mostrar.

    Si tiene un archivo personal.xls, éste aparece en Mostrar el cuadro de diálogo.
  2. Haga clic en personal.xls y haga clic en mostrar.
  3. En el menú Insertar, haga clic en macro y, a continuación, haga clic en módulo.
  4. Escriba el siguiente código de macro en la hoja de módulo:
          Sub Auto_Close()
             ThisWorkbook.Save  'Saves the workbook the macro is in.
          End Sub
    						
  5. En el menú Archivo, haga clic en Guardar.
  6. En el menú Ventana, haga clic en ocultar.
  7. En el menú Archivo, haga clic en salir.
Cuando salga de Microsoft Excel, deberá no para guardar los cambios en el archivo personal.xls. En su lugar, los cambios se guardan automáticamente.

Microsoft Excel 5.0 para Macintosh

  1. En el menú Ventana, haga clic en mostrar.

    Si dispone de un libro de macros personal, éste aparece en Mostrar el cuadro de diálogo.
  2. Haga clic en libro de macros personal y haga clic en mostrar.
  3. En el menú Insertar, haga clic en macro y, a continuación, haga clic en módulo.
  4. Escriba el siguiente código de macro en la hoja de módulo:
          Sub Auto_Close()
             ThisWorkbook.Save  'Saves the workbook the macro is in.
          End Sub
    						
  5. En el archivo de menú, haga clic en Guardar.
  6. En el menú Ventana, haga clic en ocultar.
  7. En el menú Archivo, haga clic en salir.
Cuando salga de Microsoft Excel, deberá no para guardar los cambios en el archivo de libro de macros personal. En su lugar, los cambios se guardan automáticamente.

Fondo

Excel almacena las macros personalizadas en el archivo personal.xls en Microsoft Excel para Windows y el libro macros personales en Microsoft Excel para Macintosh.

En Microsoft Excel para Windows, el archivo de personal.xls normalmente reside en la carpeta \Excel\Xlstart. En Microsoft Excel para Macintosh, el libro macros personales normalmente reside en la carpeta "Folder(5) de inicio de Excel de sistema: opciones de carpeta:".

Cuando abra Microsoft Excel, la macro personal libro se abre automáticamente pero está oculto. Si graba una nueva macro y especificar que la macro se graba en el personal.xls o libro de macros personal, o si modifica de alguna manera, se se le pedirá que lo guarde al salir de Microsoft Excel. Simplemente Mostrar libro y rehiding a continuación, se considera un cambio, y se le preguntará para guardar los cambios al salir de Microsoft Excel.

Referencias

Para obtener más información sobre el evento Close en Microsoft Excel 97, haga clic en el Ayudante, escriba Cerrar evento , haga clic en Buscar y, a continuación, haga clic para ver "Evento WorkbookBeforeClose."

Nota: Si el Ayudante está oculto, haga clic en el botón Ayudante de Office en la barra de herramientas estándar. Si el Ayudante no es capaz de responder la consulta, consulte en contacto con el siguiente artículo en Microsoft Knowledge Base:
176476OFF: Ayudante de Office respuesta no preguntas de Visual Basic
"Guía del programador de Visual Basic de Microsoft Excel", páginas 205-210

"Manual del usuario de Visual Basic", versión 5.0, capítulo 13, creación automática procedimientos y de aplicaciones

Para obtener más información acerca de las macros Auto_Close, haga clic en la ficha de índice en la Ayuda de Microsoft Excel y escriba el texto siguiente:
Auto_Close

Propiedades

Id. de artículo: 153893 - Última revisión: miércoles, 11 de octubre de 2006 - Versión: 2.3
La información de este artículo se refiere a:
  • Microsoft Excel 97 Standard Edition
  • Microsoft Excel 95 Standard Edition
  • Microsoft Excel 5.0 Standard Edition
Palabras clave: 
kbmt kbdtacode kbhowto kbprogramming KB153893 KbMtes
Traducción automática
IMPORTANTE: Este artículo ha sido traducido por un software de traducción automática de Microsoft (http://support.microsoft.com/gp/mtdetails) en lugar de un traductor humano. Microsoft le ofrece artículos traducidos por un traductor humano y artículos traducidos automáticamente para que tenga acceso en su propio idioma a todos los artículos de nuestra base de conocimientos (Knowledge Base). Sin embargo, los artículos traducidos automáticamente pueden contener errores en el vocabulario, la sintaxis o la gramática, como los que un extranjero podría cometer al hablar el idioma. Microsoft no se hace responsable de cualquier imprecisión, error o daño ocasionado por una mala traducción del contenido o como consecuencia de su utilización por nuestros clientes. Microsoft suele actualizar el software de traducción frecuentemente.
Haga clic aquí para ver el artículo original (en inglés): 153893
Renuncia a responsabilidad de los contenidos de la KB sobre productos a los que ya no se ofrece asistencia alguna
El presente artículo se escribió para productos para los que Microsoft ya no ofrece soporte técnico. Por tanto, el presente artículo se ofrece "tal cual" y no será actualizado.

Enviar comentarios

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com