[IE] "サイトを開けません" というエラー メッセージが表示される

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文書番号: 153967 - 対象製品
この記事は、以前は次の ID で公開されていました: JP153967
重要 : この資料には、レジストリの編集に関する情報が含まれています。レジストリを編集する前に、問題が発生した場合に備えて、レジストリの復元方法を理解しておいてください。 復元方法の詳細については、Regedit.exe のヘルプ トピック「レジストリを復元する」、またはRegedt32.exe のヘルプ トピック「レジストリ キーを復元する」を参照してください。
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目次

現象

インターネットへの接続が確立された後、Internet Explorer を使用して World Wide Web サイトへ接続しようとすると、次のどちらかのエラー メッセージが表示される場合があります。
http://<サイト> を開けません。
または
インターネット サイト http:// <サイト> を開けません。サイトが見つかりませんでした。アドレスを確かめてから、やり直してください。

原因

これらのエラーは、次のいずれかの理由で発生する可能性があります。

  • Transmission Control Protocol/Internet Protocol (TCP/IP) のプロパティで、ドメイン ネーム サーバー (DNS) を使用するよう正しく設定されていません。
  • 接続しようとしている Web サイトがインターネット サービス プロバイダ (ISP) のドメイン外にあり、TCP/IP のプロパティで、リモート ネットワークにアクセスする際にデフォルト ゲートウェイを使用するよう正しく設定されていません。
  • 接続しようとしている Web サイトが利用できません。
  • 1 つ以上の グローバル TCP/IP 設定が、ISP へ接続する際に使用される TCP/IP 設定と競合しています。
  • Internet Explorer がダイヤルアップ ネットワークとプロキシ サーバー (クライアントがモデムを使用せずにインターネットに接続できるようにする LAN 上のサーバー) の両方を使用してインターネットに接続するように設定されています。バージョン 3.0 より前の Internet Explorer では、[インターネットのプロパティ] ダイアログ ボックスで [オートダイヤルを使う] および [代理サーバーを使用する] オプションを両方ともオンにしている場合にこの現象が発生します。Internet Explorer 3.0 では、[インターネットのプロパティ] ダイアログ ボックスで [必要時にインターネットに接続する] および [プロキシ サーバー経由で接続する] オプションを両方ともオンにしている場合にこの現象が発生します。
  • Windows 95 に付属する Wsock32.dll が、サードパーティのプログラムと置き換えられています。
  • Internet Explorer のキャッシュがいっぱいになっているか、またはキャッシュ内に壊れたファイルがあります。
  • 1 つ以上の TCP/IP コンポーネントが正しく機能していません。
  • レジストリの HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Winsock キーに Autodial キーがありません。

解決方法

この問題を回避するには、誤ったデフォルト ゲートウェイ設定または DNS サーバー設定によって問題が引き起こされているかどうかを、Ping コマンドを使用して判断します。これを行うには、[スタート] ボタンをクリックし、[プログラム] をポイントし、[コマンド プロンプト] をクリックして、コマンド プロンプトで次のコマンドを入力します (各コマンドの後で Enter キー を押します)。
cd \<windows>
ping <サイト>
<windows> は Windows がインストールされているフォルダの名前で、<サイト> はアクセスしようとしているドメインの名前です。

"Bad IP Address" エラー メッセージが表示された場合は、誤った DNS サーバー設定が原因であると考えられます。この問題を回避するには、この資料の「DNS サーバー設定」を参照してください。

"Reply from <xxx.xxx.xxx.xxx>: Destination net unreachable" エラー メッセージ (<xxx.xxx.xxx.xxx> は接続しようとしているサイトの IP アドレス) が表示された場合は、誤ったデフォルト ゲートウェイ設定が原因であると考えられます。この問題を回避するには、この資料の「デフォルト ゲートウェイ設定」を参照してください。

「DNS サーバー設定」または「デフォルト ゲートウェイ設定」に記載されている手順を実行しても問題が解決しない場合は、「その他のトラブルシューティング」を参照してください。

DNS サーバー設定

ダイヤルアップ ネットワークを使用してインターネットにアクセスする場合は、次の手順に従ってください。
  1. [マイ コンピュータ] アイコンをダブルクリックし、[ダイヤルアップ ネットワーク] アイコンをダブルクリックします。
  2. ISP への接続に使用される接続のアイコンを右クリックし、表示されるメニューから [プロパティ] をクリックします。
  3. [サーバーの種類] ボタンをクリックし、[TCP/IP 設定] をクリックして、ISP から提供された DNS サーバーの設定を入力します。
プロキシ サーバーまたはほかの LAN ベースの接続を使用してインターネットにアクセスする場合は、次の手順に従ってください。
  1. コントロール パネルで、[ネットワーク] アイコンをダブル クリックします。
  2. [TCP/IP] プロトコルをクリックし、[プロパティ] をクリックします。
  3. [DNS 設定] タブをクリックし、ISP から提供された DNS サーバーの設定を入力します。

デフォルト ゲートウェイ設定

ダイヤルアップ ネットワークを使用してインターネットにアクセスする場合は、次の手順に従ってください。
  1. [スタート] ボタンをクリックし、[プログラム]、[アクセサリ] の順にポイントして、[ダイヤルアップ ネットワーク] をクリックします。
  2. ISP への接続に使用される接続のアイコンを右クリックし、表示されるメニューから [プロパティ] をクリックします。
  3. [サーバーの種類]、[TCP/IP 設定] の順にクリックして、[リモート ネットワークでデフォルト ゲートウェイを使用] チェック ボックスをクリックして選択します。
プロキシ サーバーまたはほかの LAN ベースの接続を使用してインターネットにアクセスする場合は、次の手順に従ってください。
  1. コントロール パネルで、[ネットワーク] アイコンをダブル クリックします。
  2. [TCP/IP] プロトコルをクリックし、[プロパティ] をクリックします。
  3. [ゲートウェイ] タブをクリックし、[新しいゲートウェイ] ボックスに ISP から提供されたゲートウェイの IP アドレスを入力し、[追加] ボタンをクリックします。
注 : プロキシ サーバーを使用してインターネットへアクセスするとき、デフォルト ゲートウェイを使用するように TCP/IP を構成しなくても、リモート ネットワークへアクセスできる場合があります。プロキシ サーバーにデフォルト ゲートウェイが必要かどうかについては、ネットワーク管理者に問い合わせてください。

その他のトラブルシューティング

この問題のトラブルシューティングを進めるには、次の手順に従ってください。各手順を実行した後、問題が解決されたかどうかを確認してください。
  1. 別の Web サイトに接続して、問題が別のサイトでも発生しないか確認します。別のサイトで問題が発生しない場合は、最初に接続したサイトの管理者に問い合わせて、そのサイトが現在使用可能かどうかを確認します。
  2. グローバル TCP/IP 設定が ISP への接続に使用される接続の TCP/IP 設定と競合していないかどうかを判断します。次の手順を実行します。注 : 次の手順を実行するとき、削除する設定を必ずメモしておいてください。コンピュータがネットワークに接続されていて、TCP/IP プロトコルを使用してネットワーク (さらにインターネット) に接続している場合は、問題が解決された後で設定を元に戻す必要があります。

    1. コントロール パネルで、[ネットワーク] アイコンをダブル クリックします。
    2. [TCP/IP] プロトコルをクリックし、[プロパティ] をクリックします。
    3. [IP アドレス] タブで [IP アドレスを指定] が選択されていて、[IP アドレス] ボックスに IP アドレスが入力されている場合は、[IP アドレス] ボックスから IP アドレスを削除します。
    4. [ゲートウェイ] タブをクリックし、[インストールされているゲートウェイ] ボックスからすべてのゲートウェイを削除します。
    5. [DNS 設定] タブをクリックします。 [DNS を使う] オプションが選択されている場合は、[DNS を使わない] をクリックします。
    この手順で問題が解決した場合、削除したグローバル TCP/IP 設定が、ISP への接続に使用される接続の TCP/IP 設定と競合しています。コンピュータがネットワークに接続されていない場合、または TCP/IP プロトコルを使用してネットワークにアクセスしない場合は、これ以上トラブルシューティングを行う必要はありません。削除した TCP/IP 設定を元に戻す必要もありません。

    しかし、コンピュータがネットワークに接続されていて、TCP/IP を使用してネットワークにアクセスする場合は、削除した TCP/IP 設定を元に戻すまでネットワークにアクセスできないことがあります。設定を元に戻した後にこの問題が再発しないようにするには、システム管理者またはネットワーク管理者に問い合わせて、設定が正しいかどうかを確認します。
  3. Internet Explorer がダイヤルアップ ネットワークとプロキシ サーバーの両方を使用してインターネットに接続するように構成されていないかどうかを確認します。次の手順を実行します。

    1. デスクトップ上の [インターネット] アイコンを右クリックし、表示されるメニューから [プロパティ] をクリックします。
    2. バージョン 3.0 より前の Internet Explorer を使用している場合は、[オートダイヤル] タブの [オートダイヤルを使う] チェック ボックスと [詳細設定] タブの [代理サーバーを使用する] チェック ボックス両方が同時にオンになっていないことを確認します。
    Internet Explorer 3.0 を使用している場合は、[接続] タブで [必要時にインターネットに接続する] および [プロキシ サーバー経由で接続する] チェック ボックス両方が同時にオンになっていないことを確認します。

    注 : ダイヤルアップ ネットワーク接続を使用してインターネットに接続する場合、[代理サーバーを使用する] または [プロキシ サーバーを経由して接続する] チェック ボックスが選択されていると Web サイトにアクセスできません。プロキシ サーバーを使用してインターネットに接続する場合は、[オートダイヤルを使う] または [必要時にインターネットに接続する] チェック ボックスがオンになっていても Web サイトへアクセスできることがありますが、このような形の Internet Explorer の構成はお勧めできません。

    プロキシ サーバーを使用してインターネットに接続していて、この資料に記載されている手順に従っても問題が解決しない場合、誤ったプロキシ サーバー設定が原因である可能性があります。プロキシ サーバー設定のトラブルシューティングについては、次の Microsoft Knowledge Base の資料を参照してください。
    139546 Troubleshooting Internet Explorer and Proxy Servers
  4. オリジナルの Windows 95 ディスクまたは CD-ROM から Wsock32.dll ファイルを抽出します。Wsock32.dll ファイルは、CD-ROM の Win95_11.cab キャビネット ファイルまたはディスク 12 の Win95_12.cab キャビネット ファイルに入っています。

    抽出ツールの使用方法については、コマンド プロンプトで extract と入力するか、次の Microsoft Knowledge Base の資料を参照してください。
    129605 How to Extract Original Compressed Windows Files
  5. Internet Explorer のキャッシュを空にします。バージョン 3.0 より前の Internet Explorer を使用している場合、キャッシュを空にするには、Internet Explorer の [表示] メニューの [オプション] をクリックし、[詳細設定] タブを選択し、[Cache] の [Empty] をクリックします。Internet Explorer 3.0 を使用している場合、キャッシュを空にするには、Internet Explorer の [表示] メニューの [オプション]、[詳細設定] タブ、[インターネット一時ファイル] の [設定] の順にクリックし、[フォルダを空にする] をクリックします。
  6. Ping コマンドを使用して、TCP/IP プロトコルが正しく機能しているかどうかを確認します。これを行うには、[スタート] ボタンをクリックし、[プログラム] にポイントし、[コマンド プロンプト] をクリックして、コマンド プロンプトで次のコマンドを入力します (各コマンドの後で Enter を押します)。
    ping 127.0.0.1
    ping <アドレス>
    <アドレス> はコンピュータの IP アドレスです。TCP/IP プロトコルが正しく機能している場合は、次のような 4 行が表示されます。
    Reply from <アドレス>: bytes=32 time=1ms TTL=32
    <アドレス> は Ping コマンドで使用した IP アドレスです。"Request times out" またはその他のエラー メッセージが表示された場合は、TCP/IP が正しく動作していない可能性があり、再インストールしなければならないことがあります。

    注 : コンピュータの IP アドレスがわからない場合は、[スタート] ボタン、[ファイル名を指定して実行] の順にクリックし、[名前] ボックスに winipcfg と入力して [OK] をクリックします。[IP 設定] ダイアログ ボックスが表示されたら、アダプタの一覧から [PPP Adapter] を選択します。コンピュータの IP アドレスが [IP アドレス] ボックスに表示されます。

レジストリに Autodial キーがない場合

警告 : レジストリ エディタの使い方を誤ると、深刻な問題が発生することがあります。最悪の場合、オペレーティング システムの再インストールが必要です。Microsoft は、レジストリ エディタの誤用により発生した問題に関しては、一切責任を負わないものとします。レジストリ エディタは、自己の責任においてご使用ください。

レジストリの編集方法の詳細については、レジストリ エディタ (Regedit.exe) のヘルプ トピック「キーと値の変更」、または Regedt32.exe のヘルプ トピック「レジストリ情報の追加と削除」と「レジストリ情報の編集」を参照してください。編集する前にレジストリのバックアップを行うようにしてください。
  1. レジストリ エディタを使用して、次のレジストリ キーをデスクトップに書き出します。
    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Winsock
  2. 上記のレジストリ キーに "Autodial" という名前の新規のキーを作成します。
  3. Autodial キーに "AutodialDllName32" という文字列値を作成します。データ値を wininet.dll に設定します。
  4. Autodial キーに "AutodialFcnName32" という新規の文字列値を作成します。データ値を InternetAutodialCallback に設定します。
  5. レジストリ エディタを終了し、コンピュータを再起動します。

詳細

上記のエラー メッセージは、ネットワークのプロパティで FTP Software の PPP/SLIP アダプタがインストールされている場合にも表示されることがあります。PPP/SLIP アダプタと TCP/IP スタックを削除すると、問題が解決されます。後で FTP Software の PPP/SLIP アダプタを使用することになった場合は、ネットワークのプロパティで再度追加できます。

プロパティ

文書番号: 153967 - 最終更新日: 2003年8月13日 - リビジョン: 1.0
この資料は以下の製品について記述したものです。
  • Microsoft Internet Explorer 2.0
キーワード:?
kbprb kbfaq KB153967
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