Procédure pour modifier le client de messagerie par défaut dans Internet Explorer

Traductions disponibles Traductions disponibles
Numéro d'article: 154359 - Voir les produits auxquels s'applique cet article
Ancien nº de publication de cet article : F154359
IMPORTANT : cet article contient des informations sur la modification du Registre. Avant de modifier le Registre, assurez-vous que vous savez le restaurer en cas de problème. Pour plus d'informations sur la procédure à suivre, consultez la rubrique d'aide "Restaurer le Registre" dans Regedit.exe ou "Restaurer une clé de Registre" dans Regedt32.exe.
Agrandir tout | Réduire tout

Sommaire

Résumé

Cet article décrit comment modifier le client de messagerie par défaut dans Internet Explorer.

Plus d'informations

Modification du client de messagerie par défaut

Pour modifier le client de messagerie par défaut dans Internet Explorer, procédez comme suit :

Internet Explorer 5

  1. Démarrez Internet Explorer.
  2. Dans le menu Outils, cliquez sur Options Internet.
  3. Cliquez sur l'onglet Programmes.
  4. Dans les zones Courrier électronique et Groupes de discussion, cliquez sur le programme de votre choix.
  5. Cliquez sur OK.

Internet Explorer 4.0, 4.01

  1. Démarrez Internet Explorer.
  2. Dans le menu Affichage, cliquez sur Options Internet.
  3. Cliquez sur l'onglet Programmes.
  4. Dans les zones Courrier et News, cliquez sur le programme de votre choix.
  5. Cliquez sur OK.

Internet Explorer 3.0

  1. Démarrez Internet Explorer.
  2. Dans le menu Affichage, cliquez sur Options.
  3. Cliquez sur l'onglet Programmes.
  4. Dans les zones Courrier et Mail And News, cliquez sur le programme de votre choix.
  5. Cliquez sur OK.

Types de fichiers enregistrés modifiés en cas de redéfinition du client de messagerie par défaut

Dans Internet Explorer, ces modifications altèrent le type de fichier enregistré URL:MailToProtocol que vous pouvez afficher en procédant comme suit :

Internet Explorer 4.0, 4.01, 5 pour Windows 95/98 et Windows NT 4.0

  1. Dans Poste de travail, cliquez sur Options (ou sur Options des dossiers) dans le menu Affichage, puis cliquez sur Types de fichiers.
  2. Sélectionnez la ligne URL:MailToProtocol, cliquez sur Modifier, sur Ouvrir dans la zone Actions, puis sur Modifier. La ligne de commande qui contrôle le programme utilisé pour ouvrir une adresse URL MailTo apparaît dans la zone Application utilisée pour effectuer l'action.

Internet Explorer 4.0 pour Windows 3.1

  1. Dans Internet Explorer, cliquez sur Options Internet dans le menu Affichage, cliquez sur l'onglet Programmes, puis sur Types de fichiers.
  2. Sélectionnez la ligne URL:MailToProtocol, cliquez sur Modifier, sur Ouvrir dans la zone Actions, puis sur Modifier. La ligne de commande qui contrôle le programme utilisé pour ouvrir une adresse URL MailTo apparaît dans la zone Application utilisée pour effectuer l'action.

Internet Explorer 3.0

  1. Dans Internet Explorer, cliquez sur Options dans le menu Affichage, cliquez sur l'onglet Programmes, puis sur Types de fichiers.
  2. Sélectionnez la ligne URL:MailToProtocol, cliquez sur Modifier, sur Ouvrir dans la zone Actions, puis sur Modifier. La ligne de commande qui contrôle le programme utilisé pour ouvrir une adresse URL MailTo apparaît dans la zone Application utilisée pour effectuer l'action.
Il est possible que certains programmes modifient ce paramètre sans mettre à jour la liste des programmes disponibles dans les options de Microsoft Internet Explorer pour cette fonction. Par exemple, le client de messagerie Internet Eudora modifie le type de fichier enregistré URL:MailToProtcol en :
C:\ Dossier_Eudora \EUDORA.EXE /m
Pour plus d'informations sur l'impact de l'installation d'Eudora dans Internet Explorer, cliquez sur le numéro ci-dessous pour afficher l'article correspondant dans la Base de connaissances Microsoft :
149617 Eudora modifie le gestionnaire MailTo par défaut
Vous pouvez aussi restaurer le programme par défaut (Messagerie Internet ou Windows Messaging) dans la zone Courrier ou sous l'onglet Programmes.

En sélectionnant Messagerie Internet dans la zone Courrier, le type de fichier enregistré URL:MailToProtcol devient :
rundll32.exe C:\WINDOWS\SYSTEM\mailnews.dll,Mail_RunDLL
En sélectionnant Windows Messaging dans la zone Courrier, le type de fichier enregistré devient :
rundll32.exe url.dll,MailToProtocolHandler %l

Définition de Microsoft Outlook comme client de messagerie par défaut

Pour spécifier Microsoft Outlook 97 comme programme par défaut pour ouvrir les adresses URL MailTo, procédez comme suit :

Internet Explorer 4.0, 4.01, 5 pour Windows 95/98 et Windows NT 4.0

  1. Dans le Poste de travail, cliquez sur Options (ou sur Options des dossiers) dans le menu Affichage, puis cliquez sur Types de fichiers.
  2. Sélectionnez la ligne URL:MailToProtocol, cliquez sur Modifier, sur Ouvrir dans la zone Actions, puis sur Modifier. Cliquez sur la zone Application utilisée pour exécuter cette action et appuyez sur SUPPR. pour supprimer les données dans la zone.
  3. Tapez la ligne suivante pour la zone Application utilisée pour exécuter cette action pour la commande Ouvrir :
    C:\Program Files\Microsoft Office\Office\OUTLOOK.EXE" -c IPM.Note /m "%1
    REMARQUE : tapez les guillemets dans la zone.
  4. Pour enregistrer les modifications, cliquez sur OK autant de fois qu'il est nécessaire pour retourner au Poste de travail.

Internet Explorer 4.0 pour Windows 3.1

  1. Dans Internet Explorer, cliquez sur Options Internet dans le menu Affichage, cliquez sur l'onglet Programmes, puis cliquez sur Types de fichiers.
  2. Sélectionnez la ligne URL:MailToProtocol, cliquez sur Modifier, sur Ouvrir dans la zone Actions, puis sur Modifier. Cliquez sur la zone Application utilisée pour exécuter cette action et appuyez sur SUPPR. pour supprimer les données dans la zone.
  3. Tapez la ligne suivante pour la zone Application utilisée pour exécuter cette action pour la commande Ouvrir :
    C:\OUTLOOK\EXCHNG.EXE /m
  4. Pour enregistrer les modifications, cliquez sur OK autant de fois qu'il est nécessaire pour retourner à Internet Explorer.

Internet Explorer 3.0

  1. Dans Internet Explorer, cliquez sur Options dans le menu Affichage, cliquez sur l'onglet Programmes, puis cliquez sur Types de fichiers.
  2. Sélectionnez la ligne URL:MailToProtocol, cliquez sur Modifier, sur Ouvrir dans la zone Actions, puis sur Modifier. Cliquez sur la zone Application utilisée pour exécuter cette action et appuyez sur SUPPR. pour supprimer les données dans la zone.
  3. Tapez la ligne suivante pour la zone Application utilisée pour exécuter cette action pour la commande Ouvrir :
    C:\Program Files\Microsoft Office\Office\OUTLOOK.EXE" -c IPM.Note /m "%1
    REMARQUE : tapez les guillemets dans la zone.
  4. Pour enregistrer les modifications, cliquez sur OK autant de fois qu'il est nécessaire pour retourner à Internet Explorer.

Définition de Microsoft Outlook Express comme client de messagerie par défaut

Pour spécifier Microsoft Outlook Express comme programme par défaut pour ouvrir les adresses URL MailTo, procédez comme suit :

Internet Explorer 4.0, 4.01, 5 pour Windows 95/98 et Windows NT 4.0

  1. Dans Poste de travail, cliquez sur Options (ou sur Options des dossiers) dans le menu Affichage, puis cliquez sur Types de fichiers.
  2. Sélectionnez la ligne URL:MailToProtocol, cliquez sur Modifier, sur Ouvrir dans la zone Actions, puis sur Modifier. Cliquez sur la zone Application utilisée pour exécuter cette action et appuyez sur SUPPR. pour supprimer les données dans la zone.
  3. Tapez la ligne suivante pour la zone Application utilisée pour exécuter cette action pour la commande Ouvrir :
    "C:\Program Files\Outlook Express\Msimn.exe" /mailurl:%1
    REMARQUE : tapez les guillemets dans la zone.
  4. Pour enregistrer les modifications, cliquez sur OK autant de fois qu'il est nécessaire pour retourner au Poste de travail.

Internet Explorer 4.0 pour Windows 3.1

  1. Dans Internet Explorer, cliquez sur Options Internet dans le menu Affichage, cliquez sur l'onglet Programmes, puis sur Types de fichiers.
  2. Sélectionnez la ligne URL:MailToProtocol, cliquez sur Modifier, sur Ouvrir dans la zone Actions, puis sur Modifier. Cliquez sur la zone Application utilisée pour exécuter cette action et appuyez sur SUPPR. pour supprimer les données dans la zone.
  3. Tapez la ligne suivante pour la zone Application utilisée pour exécuter cette action pour la commande Ouvrir :
    "C:\Program Files\Outlook Express\Msimn.exe" /mailurl:%1"
    REMARQUE : tapez les guillemets dans la zone.
  4. Pour enregistrer les modifications, cliquez sur OK autant de fois qu'il est nécessaire pour retourner au Poste de travail.

Utilisation d'anciennes versions de programmes de messagerie

La liste des programmes de messagerie que vous pouvez choisir dans les options de Microsoft Internet Explorer est constituée de clés de Registre qui déterminent le comportement du programme que vous souhaitez utiliser. Le programme doit être développé de manière à s'inscrire automatiquement dans le Registre. Si vous utilisez une ancienne version d'un programme de messagerie, nous vous recommandons de contacter l'éditeur du logiciel afin de déterminer comment le configurer comme client de messagerie par défaut.

Modification du Registre

AVERTISSEMENT : toute mauvaise utilisation de l'Éditeur du Registre peut générer des problèmes sérieux, pouvant vous obliger à réinstaller votre système d'exploitation. Microsoft ne peut pas garantir que les problèmes résultant d'une mauvaise utilisation de l'Éditeur du Registre puissent être résolus. Vous assumez l'ensemble des risques liés à l'utilisation de cet outil.

Pour plus d'informations sur la procédure à suivre pour modifier le Registre, consultez la rubrique d'aide "Modification des clés et des valeurs" dans l'Éditeur du Registre (Regedit.exe) ou les rubriques d'aide "Ajout et suppression d'informations dans le Registre" et "Modification des données de Registre" dans Regedt32.exe. Pensez à sauvegarder le Registre avant de le modifier. Si vous travaillez sous Windows NT ou Windows 2000, nous vous conseillons de mettre à jour votre disquette de réparation d'urgence.

Cette section explique comment ajouter votre programme à la liste des programmes de services Internet disponibles dans Internet Explorer.

Si vous modifiez les valeurs inscrites dans le Registre pour des services étendus tels que le courrier et les groupes de discussion, Microsoft Internet Explorer peut démarrer des programmes qui fournissent des services Internet spécialisés. En définissant de nouvelles clés à la fin du chemin d'accès du Registre, vous pouvez ajouter d'autres programmes aux éléments de menu disponibles dans Internet Explorer.

Par exemple, pour inclure un programme client de messagerie dans la liste des programmes disponibles, inscrivez votre programme client dans la clé de Registre suivante :
HKLM\SOFTWARE\Clients\Mail\ Nom_de_votre_client_de_messagerie
Définissez le client et le chemin d'accès du programme qu'Internet Explorer doit démarrer :
Clé : HKLM\SOFTWARE\Clients\Mail\ Nom_de_votre_client_de_messagerie\shell\open\command
Valeur : "C:\Program Files\ Nom de votre dossier\ NOM_DE_VOTRE_CLIENT_DE_MESSAGERIE.EXE"
Les produits tiers mentionnés dans cet article proviennent de fournisseurs indépendants de Microsoft ; nous n'accordons aucune garantie, implicite ou autre, en ce qui concerne le fonctionnement ou la fiabilité de ces produits.

Propriétés

Numéro d'article: 154359 - Dernière mise à jour: jeudi 15 janvier 2004 - Version: 3.0
Les informations contenues dans cet article s'appliquent au(x) produit(s) suivant(s):
  • Microsoft Internet Explorer 5.0
  • Microsoft Internet Explorer 4.0 Édition 128 bits
  • Microsoft Internet Explorer 3.01
  • Microsoft Internet Explorer 3.0
  • Microsoft Internet Explorer 2.1
  • Microsoft Internet Explorer 2.01
  • Microsoft Internet Explorer 3.0
  • Microsoft Internet Explorer 5.5
  • Microsoft Internet Explorer 2.0
  • Microsoft Internet Explorer 5.0
Mots-clés : 
kbhowto msiew31 msiew95 msiew98 KB154359
L'INFORMATION CONTENUE DANS CE DOCUMENT EST FOURNIE PAR MICROSOFT SANS GARANTIE D'AUCUNE SORTE, EXPLICITE OU IMPLICITE. L'UTILISATEUR ASSUME LE RISQUE DE L'UTILISATION DU CONTENU DE CE DOCUMENT. CE DOCUMENT NE PEUT ETRE REVENDU OU CEDE EN ECHANGE D'UN QUELCONQUE PROFIT.
Exclusion de responsabilité concernant les contenus obsolètes dans la Base de connaissances
Cet article concerne des produits pour lesquels Microsoft n'offre plus de support. Il est par conséquent fourni « en l'état » et ne sera plus mis à jour.

Envoyer des commentaires

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com