Fehlermeldung: ScanDisk kann Laufwerk nicht überprüfen

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Artikel-ID: 154998 - Produkte anzeigen, auf die sich dieser Artikel bezieht
Dieser Artikel wurde zuvor veröffentlicht unter D35679
Dieser Artikel ist eine Übersetzung des folgenden englischsprachigen Artikels der Microsoft Knowledge Base:
154998 Error Message: ScanDisk Cannot Check Drive
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Problembeschreibung

Wenn Sie versuchen, ScanDisk auszuführen, wird Ihnen möglicherweise eine der folgenden Fehlermeldungen angezeigt:
  • ScanDisk kann Laufwerk <Laufwerkbuchstabe> nicht prüfen:
Diese Version von Microsoft ScanDisk wird nur von den MS-DOS-Versionen 5.0 und höher unterstützt.
  • Dieses Laufwerk kann nicht geprüft werden, da es nicht richtig formatiert oder durch ein Datenträgerprogramm blockiert ist. Formatieren Sie den Datenträger oder warten Sie, bis das Programm beendet ist. Starten Sie dann ScanDisk erneut.

Ursache

Diese Symptome können aus einem der folgenden Gründe auftreten:
  • Sie führen eine veraltete Version von ScanDisk in Verbindung mit OEM Service Release 2 (OSR2) oder Windows 98 aus. Dies kann zum Beispiel dann der Fall sein, wenn Sie ScanDisk von einer Notfalldiskette ausführen, die erstellt wurde, als Sie eine frühere Version von Windows 95 ausführten.
  • Sie führen eine OSR2- oder Windows 98-Version von ScanDisk in Windows 95 aus. Dies kann zum Beispiel dann der Fall sein, wenn Sie auf einem mit Windows 95 ausgerüsteten Computer ScanDisk von einer Notfalldiskette ausführen, die bei der Ausführung von OSR2 oder Windows 98 erstellt wurde.

Lösung

Um dieses Problem zu beheben, wenden Sie das jeweils anwendbare der nachstehenden Verfahren an:

Für Windows 95 OSR2

Die folgenden Dateien werden von der Windows 95-OSR2-Version von ScanDisk benötigt:
  • Windows\Scandskw.exe 4.896 Byte
  • Windows\System\Dskmaint.dll 214.048 Byte
  • Windows\Command\Scandisk.exe 142.353 Byte
Stellen Sie die entsprechenden Dateien von der Windows 95-OSR2-CD-ROM wieder her. Hierzu führen Sie folgende Schritte durch:
  1. Starten Sie eine MS-DOS-Eingabeaufforderung in Windows 95.
  2. Geben Sie dort "cd windows" ein und drücken Sie dann ENTER.
  3. Geben Sie folgende Zeilen ein und drücken Sie nach jeder Zeile ENTER:
       ren scandskw.exe *.bak
       ren system\dskmaint.dll *.bak
       ren command\scandisk.exe *.bak
  4. Legen Sie die Microsoft Windows 95-OSR2-CD-ROM in das CD-ROM-Laufwerk ein.
  5. Geben Sie folgende Zeilen ein und drücken Sie nach jeder Zeile ENTER:
       extract <drive>:\win95\win95_16.cab scandskw.exe /L %windir%
       extract <drive>:\win95\precopy2.cab dskmaint.dll /L %windir%\system
       copy <drive>:\win95\scandisk.exe %windir%\command
wobei <Laufwerk> für den Laufwerkbuchstaben Ihres CD-ROM-Laufwerks steht.

Für Windows 95

Die folgenden Dateien werden von der Windows 95-Version von ScanDisk benötigt:
  • Windows\Scandskw.exe 4.608 Byte
  • Windows\System\Dskmaint.dll 189.456 Byte
  • Windows\Command\Scandisk.exe 134.738 Byte
Stellen Sie die entsprechenden Dateien von der Windows 95-CD-ROM oder den Windows 95-Disketten wieder her. Hierzu führen Sie folgende Schritte durch:
  1. Starten Sie eine MS-DOS-Eingabeaufforderung in Windows 95.
  2. Geben Sie dort "cd windows" ein und drücken Sie dann ENTER.
  3. Geben Sie folgende Zeilen ein und drücken Sie nach jeder Zeile ENTER:
       ren scandskw.exe *.bak
       ren system\dskmaint.dll *.bak
       ren command\scandisk.exe *.bak
Extrahieren Sie die Dateien mit dem jeweils anwendbaren der nachstehend beschriebenen Verfahren:

Windows 95-CD-ROM:
  1. Legen Sie die Microsoft Windows 95-CD-ROM in das CD-ROM-Laufwerk ein.
  2. Geben Sie folgende Zeilen ein und drücken Sie nach jeder Zeile ENTER:
       extract <drive>:\win95\win95_09.cab scandskw.exe /l %windir%
       extract <drive>:\win95\precopy2.cab dskmaint.dll /l %windir%\system
       copy <drive>:\win95\scandisk.exe %windir%\command
wobei <Laufwerk> für den Laufwerkbuchstaben Ihres CD-ROM-Laufwerks steht.
  1. Geben Sie "exit" (ohne Anführungszeichen) ein und drücken Sie dann ENTER, um zu Windows zurückzukehren.
Windows 95-Disketten:
  1. Geben Sie "cd\" (ohne Anführungszeichen) ein und drücken Sie dann ENTER.
  2. Legen Sie Diskette Nr. 9 der Windows 95-Disketten in das Diskettenlaufwerk ein.
  3. Geben Sie in der Eingabeaufforderung folgende Zeile ein und drücken Sie dann ENTER:
       extract /a <drive>:\win95_09.cab scandskw.exe /l %windir%
wobei <Laufwerk> für den Laufwerkbuchstaben des Diskettenlaufwerks steht, in dem sich die Windows 95-Diskette befindet.
  1. Legen Sie Diskette Nr. 2 der Windows 95-Disketten in das Diskettenlaufwerk ein.
  2. Geben Sie in der Eingabeaufforderung folgende Zeile ein und drücken Sie dann ENTER:
       extract /a <drive>:\ precopy2.cab dskmaint.dll /l %windir%\system
  3. Legen Sie Diskette Nr. 1 der Windows 95-Disketten in das Diskettenlaufwerk ein.
  4. Geben Sie in der Eingabeaufforderung folgende Zeile ein und drücken Sie dann ENTER:
       copy <drive>:\scandisk.exe %windir%\command
  5. Geben Sie "exit" (ohne Anführungszeichen) ein und drücken Sie dann ENTER, um zu Windows zurückzukehren.

Weitere Informationen

Für weitere Informationen über die Verwendung des Extrahierungsprogramms klicken Sie auf "Start", zeigen Sie auf "Programme", klicken Sie auf "MS-DOS-Eingabeaufforderung" und geben Sie dann "extract" ein (ohne Anführungszeichen). Drücken Sie dann ENTER. Oder lesen Sie den folgenden Artikel in der Microsoft Knowledge Base:
   ARTIKEL-ID: D35346
   TITEL     : Extrahieren komprimierter Windows-Originaldateien
Bitte beachten Sie: Bei diesem Artikel handelt es sich um eine Übersetzung aus dem Englischen. Es ist möglich, daß nachträgliche Änderungen bzw. Ergänzungen im englischen Originalartikel in dieser Übersetzung nicht berücksichtigt sind. Die in diesem Artikel enthaltenen Informationen basieren auf der/den englischsprachige(n) Produktversion(en). Die Richtigkeit dieser Informationen in Zusammenhang mit anderssprachigen Produktversionen wurde im Rahmen dieser Übersetzung nicht getestet. Microsoft stellt diese Informationen ohne Gewähr für Richtigkeit bzw. Funktionalität zur Verfügung und übernimmt auch keine Gewährleistung bezüglich der Vollständigkeit oder Richtigkeit der Übersetzung.

Eigenschaften

Artikel-ID: 154998 - Geändert am: Donnerstag, 10. August 2006 - Version: 2.0
Die Informationen in diesem Artikel beziehen sich auf:
  • Microsoft Windows 95
  • Microsoft Windows 98 Standard Edition
Keywords: 
kbtool KB154998
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