Czarny ekran podczas rozruchu

Ten artykuł zawiera rozwiązanie problemu polegającego na tym, że ponowne uruchomienie komputera z systemem Windows x86 kończy się niepowodzeniem z użyciem czarnego ekranu.

Dotyczy: Windows Server 2012 R2
Oryginalny numer KB: 155053

Symptomy

Po ponownym uruchomieniu komputera z systemem Windows x86 komputer zatrzymuje się z pustym, czarnym ekranem natychmiast po zakończeniu samotestu zasilania (POST).

Przyczyna

Główny rekord rozruchowy (MBR), tabele partycji, sektor rozruchu lub plik NTLDR są uszkodzone.

Rozwiązanie

  1. Utwórz dysk rozruchowy systemu Windows, aby uruchomić komputer.

    Jeśli komputer można uruchomić bez błędów, uszkodzenie jest ograniczone do głównego rekordu rozruchowego (MBR), sektora rozruchowego lub pliku NTLDR. Po uruchomieniu systemu Windows natychmiast utwórz kopię zapasową wszystkich danych wartości. Użyj administratora dysku, aby sprawdzić, czy partycje na dysku rozruchowym mają prawidłowy rozmiar. Jeśli istnieją nieprawidłowe partycje, najlepszym rozwiązaniem jest ponowne utworzenie tych partycji i sformatowanie dysków, których dotyczy problem, a następnie przywrócenie danych z najnowszej taśmy kopii zapasowej. Jeśli nie można uruchomić systemu z dysku rozruchowego systemu Windows, najprawdopodobniej będzie konieczne ponowne zainstalowanie systemu Windows i przywrócenie z taśmy.

  2. Uruchom najnowsze oprogramowanie do skanowania wirusów, aby sprawdzić, czy nie ma wirusa. Oprogramowanie antywirusowe oparte na systemie MS-DOS jest wystarczające do tego celu, nawet jeśli system plików to NTFS. Programy antywirusowe oparte na systemie MS-DOS można uruchamiać z dysku rozruchowego MS-DOS.

  3. Upewnij się, że główny rekord rozruchowy (MBR) jest prawidłowy. Rozruch z dysku rozruchowego MS-DOS w wersji 5.0 lub nowszej bez wirusów z dyskiem FDISK. FDISK /MBR Uruchom polecenie:

    Ostrzeżenie

    Jeśli komputer jest zainfekowany wirusem, użycie przełącznika FDISK /MBR może uniemożliwić uruchomienie komputera. Przed użyciem FDISK /MBR polecenia należy mieć pewność, że komputer nie jest zainfekowany wirusem.

  4. Jeśli podstawowa partycja rozruchowa jest partycją tabeli alokacji plików (FAT), uruchom rozruch z dysku MS-DOS, wykonaj SYS C: polecenie, aby dysk MS-DOS był rozruchowy, a następnie wykonaj krok 5, aby zastąpić sektor rozruchowy systemu Windows.

  5. Uruchom instalatora systemu Windows i wybierz opcję Napraw. Wybierz opcje Sprawdź sektor rozruchu i Przywróć środowisko startowe. Jeśli sektor rozruchowy na dysku rozruchowym jest uszkodzony, należy go naprawić.

  6. Jeśli rozruch systemu nadal nie powiedzie się poprawnie, użyj Attrib.exe lub Menedżera plików, aby usunąć atrybuty pliku z pliku NTLDR znajdującego się w katalogu głównym partycji systemowej. Skopiuj nowy plik NTLDR z katalogu i386 dysku CD-ROM systemu Windows, aby zastąpić istniejący.

  7. Jeśli korzystasz z systemu Windows, a partycja systemowa to NTFS, możesz mieć pofragmentowany MFT, który uniemożliwia rozruch systemu.