ACC : Résolution de l'erreur " Pilote ISAM introuvable "

Traductions disponibles Traductions disponibles
Numéro d'article: 155666 - Voir les produits auxquels s'applique cet article
Ancien nº de publication de cet article : F155666
Modéré : Requiert des compétences élémentaires en termes de macros, programmation et interopérabilité.

Agrandir tout | Réduire tout

Symptômes

Lorsque vous essayez d'exporter des données vers des fichiers Microsoft FoxPro, Paradox, dBASE, Lotus 1-2-3, texte ou Microsoft Excel, il se peut que le message d'erreur suivant s'affiche :
Pilote ISAM introuvable
Ce message d'erreur peut également s'afficher lorsque vous essayez d'importer des données à partir de l'un de ces types de fichiers.

Cause

Ce message d'erreur peut survenir si les informations du registre ne sont pas valides ou si un fichier de bibliothèque de liaison dynamique (.dll) est manquant ou corrompu.

Résolution

Vous pouvez corriger cette erreur en supprimant puis en réinstallant les pilotes ISAM (Indexed Sequential Access Method) dans Microsoft Access 95 ou Microsoft Access 97. Pour cela, procédez comme suit :
  1. Démarrez l'explorateur Windows (ou le Gestionnaire de fichier) et recherchez les fichiers suivants. Si vous trouvez l'un de ces fichiers, renommez-le. Par exemple, modifiez l'extension pour chaque fichier de .dll en .old (Msxl3032.old).

    Dans Microsoft Access 95, recherchez les fichiers suivants :
            Nom de fichier     Importer/Exporter ISAM pour
            ----------------------------------------------
            Msxl3032.dll       Microsoft Excel
            Mstx3032.dll       Texte
            Mslt3032.dll       Lotus 1-2-3
            Mspx3032.dll       Paradox
            Msxb3032.dll       Microsoft FoxPro
            Msxb3032.dll       dBase
    Dans Microsoft Access 97, recherchez les fichiers suivants :
            Nom de fichier     Importer/Exporter ISAM pour
            ----------------------------------------------
            Msexcl35.dll       Microsoft Excel
            Mstext35.dll       Texte
            Msltus35.dll       Lotus 1-2-3
            Mspdox35.dll       Paradox
            Msxbse35.dll       Microsoft FoxPro
            Msxbse35.dll       dBase
  2. Si Microsoft Access est défini comme programme autonome (ne faisant pas partie de Microsoft Office), démarrez le programme d'installation pour votre version de Microsoft Access (95 ou 97). Si Microsoft Access fait partie de Microsoft Office Professionnel, démarrez le programme d'installation pour votre version de Microsoft Office Professionnel.
  3. Cliquez sur le bouton Ajouter/Supprimer.

    REMARQUE : Si vous exécutez le programme d'installation pour Microsoft Office 95, sélectionnez Microsoft Access dans la zone Options, puis cliquez sur Modifier une option avant de passer à l'étape 4.
  4. Sélectionnez Accès aux données dans la zone Options, puis cliquez sur Modifier une option.
  5. Désactivez la case à cocher de chaque pilote dont la case est cochée.
  6. Cliquez sur Continuer. Suivez les instructions à l'écran pour compléter le processus de suppression des composants ISAM.
  7. Redémarrez le programme d'installation pour réinstaller les pilotes ISAM.
  8. Cliquez sur le bouton Ajouter/Supprimer.

    REMARQUE : Si vous exécutez le programme d'installation de Microsoft Office 95 ou 97, sélectionnez Microsoft Access dans la zone Options, puis cliquez sur Modifier une option avant de passer à l'étape 9.
  9. Sélectionnez Accès aux données dans la zone Options, puis cliquez sur Modifier une option.
  10. Activez la case à cocher de chaque pilote ISAM que vous souhaitez réinstaller.
  11. Cliquez sur Continuer. Suivez les instructions à l'écran pour compléter le processus de suppression des composants ISAM.
Si le message d'erreur s'affiche toujours une fois ces étapes complétées, supprimez, puis réinstallez Microsoft Access. Pour cela, procédez comme suit :
  1. Sauvegardez tous les fichiers de base de données Microsoft Access (.mdb) que vous avez créés.
  2. Si Microsoft Access est défini comme programme autonome (ne faisant pas partie de Microsoft Office), démarrez le programme d'installation pour votre version de Microsoft Access (95 ou 97). Si Microsoft Access fait partie de Microsoft Office Professionnel, démarrez le programme d'installation pour votre version de Microsoft Office Professionnel.
  3. Appliquez l'une des méthodes suivantes pour supprimer Microsoft Access.
    1. Si Microsoft Access est défini comme programme autonome, dans la zone Programme de modification de l'installation, cliquez sur Supprimer tout.
    2. Si Microsoft Access fait partie de Microsoft Office Professionnel, dans la zone Programme de modification de l'installation, cliquez sur Ajouter/Supprimer, puis désactivez la case à cocher Microsoft Access. Cliquez sur Continuer.
  4. Suivez les instructions à l'écran pour compléter le processus de suppression de Microsoft Access 95 ou de Microsoft Access 97.
  5. Démarrez l'explorateur Windows (ou le Gestionnaire de fichier) et recherchez les fichiers suivants. Si vous trouvez l'un de ces fichiers, renommez-le. Par exemple, modifiez l'extension pour chaque fichier de .dll en .old (Msxl3032.old).

    Dans Microsoft Access 95, recherchez :
           Nom de fichier     Importer/Exporter ISAM pour
           ----------------------------------------------
           Msxl3032.dll       Microsoft Excel
           Mstx3032.dll       Texte
           Mslt3032.dll       Lotus 1-2-3
           Mspx3032.dll       Paradox
           Msxb3032.dll       Microsoft FoxPro
           Msxb3032.dll       dBase
    Dans Microsoft Access 97, recherchez :
           Nom de fichier     Importer/Exporter ISAM pour
           ------------------------------------------------
           Msexcl35.dll       Microsoft Excel
           Mstext35.dll       Texte
           Msltus35.dll       Lotus 1-2-3
           Mspdox35.dll       Paradox
           Msxbse35.dll       Microsoft FoxPro
           Msxbse35.dll       dBase
  6. Insérez la disquette n°1 de Microsoft Access 95 ou de Microsoft Access 97 dans le lecteur de disquettes de votre ordinateur, ou insérez le CD de Microsoft Access 95 ou de Microsoft Access 97 dans le lecteur de CD-ROM.
  7. Appliquez l'une des méthodes suivantes pour réinstaller Microsoft Access :

    1. Si vous installez Microsoft Access comme programme autonome, cliquez sur Démarrer, puis sur Exécuter, tapez une commande pour démarrer le programme d'installation, puis suivez les instructions pour installer Microsoft Access sur votre ordinateur. Par exemple, tapez :
      a:\setup
    2. Si vous installez Microsoft Access comme composant de Microsoft Office, démarrez le programme d'installation, cliquez sur le bouton Ajouter/Supprimer, puis activez la case à cocher Microsoft Access. Cliquez sur Continuer et suivez les instructions à l'écran pour installer Microsoft Access.

Références

Pour plus d'informations sur les paramètres ISAM dans le registre Windows, recherchez " ISAM ", puis affichez " Personnalisation des paramètres du registre Windows utilisés par Microsoft Access " ou consultez le Compagnon Office.

Propriétés

Numéro d'article: 155666 - Dernière mise à jour: mercredi 14 janvier 2004 - Version: 3.0
Les informations contenues dans cet article s'appliquent au(x) produit(s) suivant(s):
  • Microsoft Access 95 Standard
  • Microsoft Access 97 Standard
Mots-clés : 
kb3rdparty kberrmsg kbprb KB155666
L'INFORMATION CONTENUE DANS CE DOCUMENT EST FOURNIE PAR MICROSOFT SANS GARANTIE D'AUCUNE SORTE, EXPLICITE OU IMPLICITE. L'UTILISATEUR ASSUME LE RISQUE DE L'UTILISATION DU CONTENU DE CE DOCUMENT. CE DOCUMENT NE PEUT ETRE REVENDU OU CEDE EN ECHANGE D'UN QUELCONQUE PROFIT.
Exclusion de responsabilité concernant les contenus obsolètes dans la Base de connaissances
Cet article concerne des produits pour lesquels Microsoft n'offre plus de support. Il est par conséquent fourni « en l'état » et ne sera plus mis à jour.

Envoyer des commentaires

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com