Xl97: Žádná volba nabídka vybrat všechny hypertextové odkazy

Překlady článku Překlady článku
ID článku: 156353 - Produkty, které se vztahují k tomuto článku.
Tento článek byl archivován. Je nabízen v takovém stavu, v jakém je, a nebude již nadále aktualizován.
Rozbalit všechny záložky | Minimalizovat všechny záložky

Příznaky

Microsoft Excel 97 má možnost žádné nabídce, která umožňuje vybrat všechny hypertextové odkazy v rámci listu.

Jak potíže obejít

Ukázky programů jsou společností Microsoft poskytovány pouze pro ilustraci bez žádné záruky výslovně uvedené ani předpokládané, včetně předpokládaných záruk vztahujících se k obchodovatelnosti nebo vhodnosti pro určitý účel. Tento článek předpokládá, že uživatel je obeznámen s programovacím jazykem, který je předmětem ukázky, a s nástroji použitými pro vytvoření a ladění skriptu. Pracovníci technické podpory společnosti Microsoft mohou vysvětlit funkce určitého postupu, nemohou však následující příklady rozšířit o další funkce nebo konstrukce podle konkrétních požadavků uživatele.
Pokud máte zkušenosti s programováním omezený, můžete kontaktovat partnera s certifikátem Microsoft nebo služby Advisory. Na další informace těchto webech společnosti Microsoft:

Microsoft Certified Partner - https://partner.microsoft.com/global/30000104

Služba Microsoft zpravodaje - http://support.microsoft.com/gp/advisoryservice

Další informace o možnostech podpory, které jsou k dispozici a o možnostech kontaktování společnosti Microsoft na následujícím webu společnosti Microsoft: http://support.microsoft.com/default.aspx?scid=fh;EN-US;CNTACTMSJe možné použít Microsoft Visual Basic for Applications podprogram cyklicky všechny hypertextové odkazy v rámci listu a provedení určité operace na každý hypertextový odkaz. Může odstranit všechny hypertextové odkazy nebo mohl jednoduše sestavy umístění každý hypertextový odkaz.

  1. Vytvoření nového sešitu v aplikaci Microsoft Excel.
  2. V nabídce Nástroje přejděte na příkaz Makro a potom klepněte na příkaz Editor jazyka.
  3. V editoru jazyka modulu klepněte v nabídce Vložit.
  4. Do modulu zadejte následující kód:
          'This Sub procedure deletes all hyperlinks in the active worksheet.
          Sub DeleteAllHyperlinks()
              For Each xLink In ActiveSheet.Hyperlinks
                  xLink.Delete
              Next xLink
          End Sub
    
          'This Sub procedure displays a series of message boxes indicating
          'the location of each hyperlink in the active worksheet.
          Sub ReportHyperlinkLocations()
              For Each xLink In ActiveSheet.Hyperlinks
                  MsgBox xLink.Range.Address
              Next xLink
          End Sub
    
          'This Sub procedure identifies each hyperlink and asks if you want
          'to delete it. If you click Yes, the hyperlink is deleted.
          Sub ReportAndDeleteHyperlinks()
              For Each xLink In ActiveSheet.Hyperlinks
                  Response = MsgBox("Delete hyperlink in cell " & _
                      xLink.Range.Address & " ?", vbYesNo)
                  If Response = vbYes Then xLink.Delete
              Next xLink
          End Sub
    
          'This Sub procedure selects all cells in the worksheet that contain
          'hyperlinks. You can then clear the selected cells to delete all of
          'the hyperlinks.
          Sub SelectAllHyperlinkCells()
              FirstCell = 1
              For Each xLink In ActiveSheet.Hyperlinks
                  If FirstCell = 1 Then
                      Set xRange = xLink.Range
                      FirstCell = 0
                  Else
                      Set xRange = Application.Union(xRange, xLink.Range)
                  End If
              Next xLink
              xRange.Select
          End Sub
    						
  5. V nabídce Soubor klepněte na tlačítko Zavřít a návrat do aplikace Excel."
Některé hypertextové odkazy vkládat do listu, můžete zkusit spuštění různých maker přejdete v nabídce Nástroje příkaz makra a klepnutím na makra. Potom vyberte název spuštění makra a klepněte na příkaz Spustit.

Další informace

Přejít na dialogové okno v aplikaci Microsoft Excel umožňuje vybrat buňky nebo objekty v listu v několika různých kombinací. Můžete například vybrat všechny objekty v listu nebo vybrat všechny buňky obsahující podmíněné formáty nebo komentáře.

Použít dialogové okno Přejít na, postupujte takto:

  1. V nabídce Úpravy klepněte na příkaz Přejít.
  2. Klepněte na tlačítko speciální.
Ale dialogovém okně Přejít jinak nabízejí voleb výběru buněk obsahujících hypertextové odkazy. Z tohoto důvodu setkat některé potíže při práci s velkým počtem hypertextové odkazy; například, pokud chcete odstranit všechny hypertextové odkazy z listu žádným způsobem dosáhnete bez použití makra.

Odkazy

Další informace o hypertextové odkazy v nabídce Nápověda klepněte na příkaz obsah a rejstřík, klepněte na kartu Rejstřík v nápovědě aplikace Microsoft Excel, zadejte následující text
hypertextové odkazy, vytváření
a potom poklepejte na vybraný text přejděte na téma "Vytvořit hypertextový odkaz". Pokud nelze najít informace potřebujete požádejte pomocníka Office.

Vlastnosti

ID článku: 156353 - Poslední aktualizace: 1. února 2014 - Revize: 2.4
Informace v tomto článku jsou určeny pro produkt:
  • Microsoft Excel 97 Standard Edition
Klíčová slova: 
kbnosurvey kbarchive kbmt kbdtacode kbprb kbualink97 KB156353 KbMtcs
Strojově přeložený článek
Důležité: Tento článek byl přeložen pomocí software společnosti Microsoft na strojový překlad, ne profesionálním překladatelem. Společnost Microsoft nabízí jak články přeložené překladatelem, tak články přeložené pomocí software na strojový překlad, takže všechny články ve Znalostní databázi (Knowledge Base) jsou dostupné v češtině. Překlad pomocí software na strojový překlad ale není bohužel vždy dokonalý. Obsahuje chyby ve skloňování slov, skladbě vět, nebo gramatice, podobně jako když cizinci dělají chyby při mluvení v češtině. Společnost Microsoft není právně zodpovědná za nepřesnosti, chyby nebo škody vzniklé chybami v překladu, nebo při použití nepřesně přeložených instrukcí v článku zákazníkem. Společnost Microsoft aktualizuje software na strojový překlad, aby byl počet chyb omezen na minimum.
Projděte si také anglickou verzi článku:156353

Dejte nám zpětnou vazbu

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com