XL97: Sin opción de menú para seleccionar todos los hipervínculos

Seleccione idioma Seleccione idioma
Id. de artículo: 156353 - Ver los productos a los que se aplica este artículo
Este artículo se ha archivado. Se ofrece "tal cual" y no se volverá a actualizar.
Expandir todo | Contraer todo

Síntomas

Microsoft Excel 97 no tiene ninguna opción de menú le permite seleccionar todos los hipervínculos dentro de una hoja de cálculo.

Solución

Microsoft proporciona ejemplos de programación con fines ilustrativos únicamente, sin ninguna garantía tanto expresa como implícita, incluyendo, pero sin limitarse a, las garantías implícitas de comerciabilidad e idoneidad para un propósito determinado. En este artículo se supone que está familiarizado con el lenguaje de programación que se muestra y las herramientas utilizadas para crear y depurar procedimientos. Los profesionales de soporte técnico de Microsoft pueden explicarle la funcionalidad de un determinado procedimiento, pero no modificarán estos ejemplos para ofrecer mayor funcionalidad ni crearán procedimientos a necesidades específicas.
Si tiene poca experiencia en programación, desea póngase en contacto con un Microsoft Certified Partner o servicios de consultoría de Microsoft. Para obtener más información, visite estos sitios Web de Microsoft:

Microsoft certificado Partners - https://partner.microsoft.com/global/30000104

Servicios de asesoramiento de Microsoft - http://support.microsoft.com/gp/advisoryservice

Para obtener más información acerca de las opciones de soporte técnico que están disponibles y cómo ponerse en contacto con Microsoft, visite el siguiente sitio Web de Microsoft: http://support.microsoft.com/default.aspx?scid=fh;EN-US;CNTACTMSEs posible utilizar un Microsoft subrutina de Visual Basic para aplicaciones para recorrer todos los hipervínculos dentro de una hoja de cálculo y realizar una operación específica en cada hipervínculo. Por ejemplo, podría eliminar todos los hipervínculos o simplemente podría informar de la ubicación de cada hipervínculo.

  1. Crear un nuevo libro en Microsoft Excel.
  2. En el menú Herramientas, elija Macro y, a continuación, haga clic en Editor de Visual Basic.
  3. En el Editor de Visual Basic, vaya al menú Insertar y haga clic en Módulo.
  4. Escriba el siguiente código en el módulo:
          'This Sub procedure deletes all hyperlinks in the active worksheet.
          Sub DeleteAllHyperlinks()
              For Each xLink In ActiveSheet.Hyperlinks
                  xLink.Delete
              Next xLink
          End Sub
    
          'This Sub procedure displays a series of message boxes indicating
          'the location of each hyperlink in the active worksheet.
          Sub ReportHyperlinkLocations()
              For Each xLink In ActiveSheet.Hyperlinks
                  MsgBox xLink.Range.Address
              Next xLink
          End Sub
    
          'This Sub procedure identifies each hyperlink and asks if you want
          'to delete it. If you click Yes, the hyperlink is deleted.
          Sub ReportAndDeleteHyperlinks()
              For Each xLink In ActiveSheet.Hyperlinks
                  Response = MsgBox("Delete hyperlink in cell " & _
                      xLink.Range.Address & " ?", vbYesNo)
                  If Response = vbYes Then xLink.Delete
              Next xLink
          End Sub
    
          'This Sub procedure selects all cells in the worksheet that contain
          'hyperlinks. You can then clear the selected cells to delete all of
          'the hyperlinks.
          Sub SelectAllHyperlinkCells()
              FirstCell = 1
              For Each xLink In ActiveSheet.Hyperlinks
                  If FirstCell = 1 Then
                      Set xRange = xLink.Range
                      FirstCell = 0
                  Else
                      Set xRange = Application.Union(xRange, xLink.Range)
                  End If
              Next xLink
              xRange.Select
          End Sub
    						
  5. En el menú Archivo, haga clic en "cerrar y volver a Microsoft Excel.
Si inserta algunos hipervínculos en la hoja de cálculo, puede intentar ejecutar las macros diferentes seleccionando macro en el menú Herramientas y haciendo clic en macros. A continuación, seleccione el nombre de la ejecución de la macro y haga clic en ejecutar.

Más información

El cuadro de diálogo Ir A especial en Microsoft Excel permite seleccionar celdas u objetos en una hoja de cálculo varias combinaciones diferentes. Por ejemplo, puede seleccionar todos los objetos en una hoja de cálculo o seleccione todas las celdas que contienen formatos condicionales o comentarios.

Para utilizar el cuadro de diálogo Ir A especial, siga estos pasos:

  1. En el menú Edición, haga clic en Ir A.
  2. Haga clic en especial.
Pero, en el cuadro de diálogo Ir A especial no ofrece la posibilidad de seleccionar todas las celdas que contienen hipervínculos. A causa de esto, puede encontrar alguna dificultad al trabajar con gran número de hipervínculos; por ejemplo, si desea eliminar todos los hipervínculos de la hoja de cálculo, no hay ninguna forma de hacerlo sin utilizar una macro.

Referencias

Para obtener más información acerca de los hipervínculos, haga clic en contenido e índice en el menú Ayuda, haga clic en la ficha Índice de Ayuda de Microsoft Excel, escriba el texto siguiente
hipervínculos, crear
y, a continuación, haga doble clic en el texto seleccionado para ir al tema "Crear un hipervínculo". Si no se puede encontrar la información que necesita, pregunte al Ayudante de Office.

Propiedades

Id. de artículo: 156353 - Última revisión: martes, 11 de febrero de 2014 - Versión: 2.4
La información de este artículo se refiere a:
  • Microsoft Excel 97 Standard Edition
Palabras clave: 
kbnosurvey kbarchive kbmt kbdtacode kbprb kbualink97 KB156353 KbMtes
Traducción automática
IMPORTANTE: Este artículo ha sido traducido por un software de traducción automática de Microsoft (http://support.microsoft.com/gp/mtdetails) en lugar de un traductor humano. Microsoft le ofrece artículos traducidos por un traductor humano y artículos traducidos automáticamente para que tenga acceso en su propio idioma a todos los artículos de nuestra base de conocimientos (Knowledge Base). Sin embargo, los artículos traducidos automáticamente pueden contener errores en el vocabulario, la sintaxis o la gramática, como los que un extranjero podría cometer al hablar el idioma. Microsoft no se hace responsable de cualquier imprecisión, error o daño ocasionado por una mala traducción del contenido o como consecuencia de su utilización por nuestros clientes. Microsoft suele actualizar el software de traducción frecuentemente.
Haga clic aquí para ver el artículo original (en inglés): 156353

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com