XL97 : Aucun choix de menu pour sélectionner tous les liens hypertexte

Traductions disponibles Traductions disponibles
Numéro d'article: 156353 - Voir les produits auxquels s'applique cet article
Cet article a été archivé. Il est proposé « en l'état » et ne sera plus mis à jour.
Agrandir tout | Réduire tout

Symptômes

Microsoft Excel 97 ne dispose d'aucune option de menu vous permet de sélectionner tous les liens hypertexte dans une feuille de calcul.

Contournement

Microsoft fournit des exemples de programmation à des fins d'illustration uniquement, sans garantie expresse ou implicite, y compris, sans que cela soit limitatif, les garanties implicites de qualité marchande et/ou d'adéquation à un usage particulier. Cet article suppose que vous connaissez le langage de programmation présenté et les outils utilisés pour créer et déboguer des procédures. Les techniciens du support technique Microsoft peuvent vous aider à comprendre la fonctionnalité d'une procédure particulière, mais ils ne modifieront pas ces exemples pour fournir des fonctionnalités supplémentaires ou créer des procédures répondant à vos besoins spécifiques.
Si vous ne maîtrisez que partiellement la programmation, il convient contacter un partenaire certifié Microsoft ou les services de conseil Microsoft. Pour plus d'informations, visitez ces sites Web de Microsoft :

Microsoft certifié partners - https://partner.microsoft.com/global/30000104

Avis de Microsoft Services - http://support.microsoft.com/gp/advisoryservice

Pour plus d'informations sur les options de support technique disponibles et sur la façon de contacter Microsoft, reportez-vous au site Web de Microsoft à l'adresse suivante : http://support.microsoft.com/default.aspx?scid=fh;EN-US;CNTACTMSIl est possible d'utiliser un Microsoft Visual Basic pour applications sous-routine pour passer en revue tous les liens hypertexte dans une feuille de calcul et d'effectuer une opération spécifique sur chaque lien hypertexte. Par exemple, vous pouvez supprimer tous les liens hypertexte ou vous pourriez simplement signaler l'emplacement de chaque lien hypertexte.

  1. Créer un nouveau classeur dans Microsoft Excel.
  2. Dans le menu Outils, pointez sur macro et cliquez sur Visual Basic Editor.
  3. Dans Visual Basic Editor, cliquez sur module dans le menu Insertion.
  4. Tapez le code suivant dans le module :
          'This Sub procedure deletes all hyperlinks in the active worksheet.
          Sub DeleteAllHyperlinks()
              For Each xLink In ActiveSheet.Hyperlinks
                  xLink.Delete
              Next xLink
          End Sub
    
          'This Sub procedure displays a series of message boxes indicating
          'the location of each hyperlink in the active worksheet.
          Sub ReportHyperlinkLocations()
              For Each xLink In ActiveSheet.Hyperlinks
                  MsgBox xLink.Range.Address
              Next xLink
          End Sub
    
          'This Sub procedure identifies each hyperlink and asks if you want
          'to delete it. If you click Yes, the hyperlink is deleted.
          Sub ReportAndDeleteHyperlinks()
              For Each xLink In ActiveSheet.Hyperlinks
                  Response = MsgBox("Delete hyperlink in cell " & _
                      xLink.Range.Address & " ?", vbYesNo)
                  If Response = vbYes Then xLink.Delete
              Next xLink
          End Sub
    
          'This Sub procedure selects all cells in the worksheet that contain
          'hyperlinks. You can then clear the selected cells to delete all of
          'the hyperlinks.
          Sub SelectAllHyperlinkCells()
              FirstCell = 1
              For Each xLink In ActiveSheet.Hyperlinks
                  If FirstCell = 1 Then
                      Set xRange = xLink.Range
                      FirstCell = 0
                  Else
                      Set xRange = Application.Union(xRange, xLink.Range)
                  End If
              Next xLink
              xRange.Select
          End Sub
    						
  5. Dans le menu fichier, cliquez sur «Fermer et retourner à Microsoft Excel.
Si vous insérez des liens hypertexte dans votre feuille de calcul, vous pouvez essayer d'exécuter les macros différentes en pointant sur macro dans le menu Outils, puis en cliquant sur Macros. Ensuite, sélectionnez le nom de l'exécution de la macro et cliquez sur Exécuter.

Plus d'informations

La boîte de dialogue Sélectionner les cellules dans Microsoft Excel permet de sélectionner des cellules ou des objets dans une feuille de calcul en plusieurs combinaisons différentes. Par exemple, vous pouvez sélectionner tous les objets dans une feuille de calcul, ou sélectionnez toutes les cellules qui contiennent des formats conditionnels ou des commentaires.

Pour utiliser la boîte de dialogue Sélectionner les cellules, procédez comme suit :

  1. Dans le menu Edition, cliquez sur Atteindre.
  2. Cliquez sur spécial.
Mais, la boîte de dialogue Sélectionner les cellules n'offre pas le choix de la sélection de toutes les cellules qui contiennent des liens hypertexte. Par conséquent, que vous pouvez rencontrer des difficultés à lors de l'utilisation avec un grand nombre de liens hypertexte ; par exemple, si vous souhaitez supprimer tous les liens hypertexte à partir de votre feuille de calcul, il n'existe aucun moyen pour ce faire sans l'aide d'une macro.

Références

Pour plus d'informations sur les liens hypertexte, cliquez sur Sommaire et index dans le menu Aide, cliquez sur l'onglet Index dans l'aide de Microsoft Excel, tapez le texte suivant :
liens hypertexte, création
puis double-cliquez sur le texte sélectionné pour aller à la rubrique «Créer un lien hypertexte». Si vous ne parvenez pas à trouver les informations dont vous avez besoin, interrogez le Compagnon Office.

Propriétés

Numéro d'article: 156353 - Dernière mise à jour: mardi 11 février 2014 - Version: 2.4
Les informations contenues dans cet article s'appliquent au(x) produit(s) suivant(s):
  • Microsoft Excel 97 Standard
Mots-clés : 
kbnosurvey kbarchive kbmt kbdtacode kbprb kbualink97 KB156353 KbMtfr
Traduction automatique
IMPORTANT : Cet article est issu du système de traduction automatique mis au point par Microsoft (http://support.microsoft.com/gp/mtdetails). Un certain nombre d?articles obtenus par traduction automatique sont en effet mis à votre disposition en complément des articles traduits en langue française par des traducteurs professionnels. Cela vous permet d?avoir accès, dans votre propre langue, à l?ensemble des articles de la base de connaissances rédigés originellement en langue anglaise. Les articles traduits automatiquement ne sont pas toujours parfaits et peuvent comporter des erreurs de vocabulaire, de syntaxe ou de grammaire (probablement semblables aux erreurs que ferait une personne étrangère s?exprimant dans votre langue !). Néanmoins, mis à part ces imperfections, ces articles devraient suffire à vous orienter et à vous aider à résoudre votre problème. Microsoft s?efforce aussi continuellement de faire évoluer son système de traduction automatique.
La version anglaise de cet article est la suivante: 156353
L'INFORMATION CONTENUE DANS CE DOCUMENT EST FOURNIE PAR MICROSOFT SANS GARANTIE D'AUCUNE SORTE, EXPLICITE OU IMPLICITE. L'UTILISATEUR ASSUME LE RISQUE DE L'UTILISATION DU CONTENU DE CE DOCUMENT. CE DOCUMENT NE PEUT ETRE REVENDU OU CEDE EN ECHANGE D'UN QUELCONQUE PROFIT.

Envoyer des commentaires

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com