XL97: No Menu Choice to Select All Hyperlinks

Traduções de Artigos Traduções de Artigos
Artigo: 156353 - Ver produtos para os quais este artigo se aplica.
Este artigo foi arquivado. Este artigo é oferecido "tal como está" e deixará de ser actualizado.
Expandir tudo | Reduzir tudo

Sintomas

Microsoft Excel 97 não tem nenhuma opção de menu permite-lhe seleccionar todas as hiperligações numa folha de cálculo.

Como contornar

Microsoft fornece exemplos de programação ilustração só, sem garantia expressa ou implícita, incluindo, sem limitação, garantias implícitas de comercialização e/ou adequação a um fim específico. Este artigo pressupõe que está familiarizado com a linguagem de programação apresentada e as ferramentas utilizadas para criar e depurar procedimentos. Profissionais de suporte da Microsoft podem ajudar a explicar a funcionalidade de um determinado procedimento, mas não modificarão estes exemplos para proporcionarem funcionalidades adicionais nem criarão procedimentos adaptados às necessidades específicas.
Se dispõe de limitada experiência de programação, poderá contactar um Microsoft Certified Partner ou a serviços de aviso. Para obter mais informações, visite estes Web sites da Microsoft:

Microsoft certificado Partner - https://partner.microsoft.com/global/30000104

Serviços Microsoft aviso - http://support.microsoft.com/gp/advisoryservice

Para obter mais informações sobre as opções de suporte estão disponíveis e sobre como contactar a Microsoft, visite o seguinte Web site da Microsoft: http://support.microsoft.com/default.aspx?scid=fh;EN-US;CNTACTMSÉ possível utilizar um Microsoft Visual Basic for Applications subrotina para percorrer todas as hiperligações numa folha de cálculo e efectuar uma operação específica em cada hiperligação. Por exemplo, pode eliminar todas as hiperligações ou simplesmente pode comunicar a localização de cada hiperligação.

  1. Crie um novo livro no Microsoft Excel.
  2. No menu Ferramentas, aponte para macro e, em seguida, clique em Editor do Visual Basic.
  3. No Editor do Visual Basic, clique em módulo no menu ' Inserir '.
  4. Escreva o seguinte código no módulo:
          'This Sub procedure deletes all hyperlinks in the active worksheet.
          Sub DeleteAllHyperlinks()
              For Each xLink In ActiveSheet.Hyperlinks
                  xLink.Delete
              Next xLink
          End Sub
    
          'This Sub procedure displays a series of message boxes indicating
          'the location of each hyperlink in the active worksheet.
          Sub ReportHyperlinkLocations()
              For Each xLink In ActiveSheet.Hyperlinks
                  MsgBox xLink.Range.Address
              Next xLink
          End Sub
    
          'This Sub procedure identifies each hyperlink and asks if you want
          'to delete it. If you click Yes, the hyperlink is deleted.
          Sub ReportAndDeleteHyperlinks()
              For Each xLink In ActiveSheet.Hyperlinks
                  Response = MsgBox("Delete hyperlink in cell " & _
                      xLink.Range.Address & " ?", vbYesNo)
                  If Response = vbYes Then xLink.Delete
              Next xLink
          End Sub
    
          'This Sub procedure selects all cells in the worksheet that contain
          'hyperlinks. You can then clear the selected cells to delete all of
          'the hyperlinks.
          Sub SelectAllHyperlinkCells()
              FirstCell = 1
              For Each xLink In ActiveSheet.Hyperlinks
                  If FirstCell = 1 Then
                      Set xRange = xLink.Range
                      FirstCell = 0
                  Else
                      Set xRange = Application.Union(xRange, xLink.Range)
                  End If
              Next xLink
              xRange.Select
          End Sub
    						
  5. No menu Ficheiro, clique em "fechar e voltar ao Microsoft Excel.
Se inserir algumas hiperligações na folha de cálculo, pode tentar executar as macros diferentes, apontando para macro no menu Ferramentas e clicando em macros. Em seguida, seleccione o nome da macro para executar e clique em executar.

Mais Informação

Caixa de diálogo Ir para especial no Microsoft Excel permite-lhe seleccionar células ou objectos numa folha de cálculo em várias combinações diferentes. Por exemplo, pode seleccionar todos os objectos numa folha de cálculo ou seleccione todas as células que contêm formatação condicional ou comentários.

Para utilizar a caixa de diálogo Ir para especial, siga estes passos:

  1. No menu Editar, clique em Ir para.
  2. Clique em ' especial '.
No entanto, a caixa de diálogo Ir para especial não oferece a opção de seleccionar todas as células que contêm hiperligações. Deste modo, poderá encontrar algumas dificuldades quando trabalhar com grandes quantidades de hiperligações; por exemplo, não se pretender eliminar todas as hiperligações da folha de cálculo, existe nenhuma forma sem utilizar uma macro.

Referências

Para obter mais informações sobre hiperligações, clique em índice e índice remissivo no menu Ajuda, clique no separador Índice remissivo na ajuda do Microsoft Excel, escreva o seguinte texto
hiperligações, criar
e faça duplo clique sobre o texto seleccionado para ir para o tópico "Criar uma hiperligação". Se não for possível localizar as informações que necessita, pergunte ao Assistente do Office.

Propriedades

Artigo: 156353 - Última revisão: 3 de fevereiro de 2014 - Revisão: 2.4
A informação contida neste artigo aplica-se a:
  • Microsoft Excel 97 Standard Edition
Palavras-chave: 
kbnosurvey kbarchive kbmt kbdtacode kbprb kbualink97 KB156353 KbMtpt
Tradução automática
IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine translation ou MT), não tendo sido portanto revisto ou traduzido por humanos. A Microsoft tem artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais. O objectivo é simples: oferecer em Português a totalidade dos artigos existentes na base de dados do suporte. Sabemos no entanto que a tradução automática não é sempre perfeita. Esta pode conter erros de vocabulário, sintaxe ou gramática? erros semelhantes aos que um estrangeiro realiza ao falar em Português. A Microsoft não é responsável por incoerências, erros ou estragos realizados na sequência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza actualizações frequentes ao software de tradução automática (MT). Obrigado.
Clique aqui para ver a versão em Inglês deste artigo: 156353

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com