XL97: How to Create a Report Template

Article translations Article translations
Article ID: 156449 - View products that this article applies to.
This article was previously published under Q156449
Expand all | Collapse all

SUMMARY

In Microsoft Excel 97 there is a new feature called a report template. A report template is a Microsoft Excel template that includes one or more queries or PivotTables based on external data. When you save a report template, the external data is not stored in the template. Instead, the data is refreshed each time you open the report template.

MORE INFORMATION

To create a report template:
  1. Open the workbook that contains the queries or PivotTables that are based on external data.

    NOTE: For more information about creating a PivotTable, or retrieving data from external sources, see the "References" section later in this article.
  2. On the File menu, click Save As.
  3. In the Save as type list, click Template(*.xlt).
  4. in the File name box, type a name for the template.

    NOTE: The destination folder for the template must be either the \Program Files\Microsoft Office\Templates or \Program Files\Microsoft Office\Templates\Spreadsheet Solutions folder. These folders are the default Templates folders. However, the default Template folders on your computer may be different depending on where you installed Microsoft Office.
  5. Click Save.

    The following message appears:
    This workbook contains external data. Do you want Microsoft Excel to clear the data before saving the template, and then automatically refresh the data whenever the template is opened?
  6. Click Yes to create the Report template.

    If you click Yes, the file is saved as a report template, and the external data is not stored in the file. If you click No, the file is saved as a normal template, and the external data is saved in the file. If you click Cancel, the save process is canceled and you receive the following message:
    Document not saved
  7. On the File menu, click Close.
  8. On the File menu click New.

    The report template appears on the General tab or the Spreadsheet Solutions tab in the New dialog box, depending on the location in which you saved the file in step 5.
  9. Click the report template you saved, and then click OK.

    Microsoft Excel opens a copy of the template that contains the updated external data.
You can also open the template file directly in Microsoft Excel to refresh and display the external data.

Because the report template removes the external data from the file when you save and close the file, it is smaller in size and secure from users who may not have access to the data source. By default, a template that is not a report template stores all of the data in the file that is based on the template.

REFERENCES

For more information about creating a PivotTable, click Contents and Index on the Help menu, click the Index tab in Excel Help, type the following text
pivottable
and then double-click the selected text to go to the "Create a PivotTable" topic. If you are unable to find the information you need, ask the Office Assistant.

For more information about retrieving data from external sources, click Contents and Index on the Help menu, click the Index tab in Excel Help, type the following text
external data sources, retrieving data
and then double-click the selected text to go to the "Ways to retrieve data from an external database" topic. If you are unable to find the information you need, ask the Office Assistant.

Properties

Article ID: 156449 - Last Review: April 18, 2003 - Revision: 1.1
APPLIES TO
  • Microsoft Excel 97 Standard Edition
Keywords: 
kbfaq kbhowto kbualink97 KB156449
Retired KB Content Disclaimer
This article was written about products for which Microsoft no longer offers support. Therefore, this article is offered "as is" and will no longer be updated.

Give Feedback

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com