文書番号: 156640 - 最終更新日: 2005年11月29日 - リビジョン: 5.0

Stop 0xC0000218 エラー メッセージのトラブルシューティング

お知らせお使いのオペレーティング システムには適用しない情報が含まれている場合があります。
この記事は、以前は次の ID で公開されていました: JP156640
すべて展開する | すべて折りたたむ

現象

Windows ベースのコンピュータで次の Stop エラー メッセージが表示されます。
Stop 0xc0000218 (0xe11a30e8, 0x00000000, 0x000000000,0x00000000)
UNKNOWN_HARD_ERROR
または
Stop: 0xc0000218 {レジストリ ファイル エラー}
レジストリは、ハイブ (ファイル)
\SystemRoot\System32\Config\SYSTEM、そのログ、または代替ファイルを読み込めません。
壊れているか、紛失したか、または書き込み不可能です。
: かっこ内のパラメータは、ユーザーのシステム構成に固有のもので、毎回異なる可能性があります。

原因

Stop 0xc0000218 のエラー メッセージは、必要なレジストリ ハイブ ファイルを読み込むことができなかったことを意味しています。このエラー メッセージは、ファイルが壊れているか存在しない場合に発生することがあります。この問題を解決するには、オペレーティング システムを再インストールし、バックアップからレジストリ ファイルを復元します。レジストリ ファイルの破損は、ハード ディスクの破損やその他のハードウェア障害が原因で発生する場合があります。

このエラー メッセージは、メモリへのレジストリ データの読み込み中にドライバによってデータが破壊されている場合や、レジストリの読み込み先となるメモリにパリティ エラーが存在する場合にも発生することがあります。後者の場合は、外部キャッシュを無効にしてメモリ チップをチェックしてください。

解決方法

この問題を解決するには、以下の手順を実行します。
  1. 回復コンソールを実行してコンピュータを起動し、ドライブに対して chkdsk /p コマンドを実行してからコンピュータを再起動します。問題が解決したかどうかを確認するためにテストを行います。問題が解決された場合には残りの手順は行わないでください。問題が解決しない場合には、手順 2. に進みます。
  2. Windows の起動時に、"ここで Space キーを押すと、ハードウェア プロファイル/システムの構成の回復メニューが表示されます" というメッセージが表示されたら、Space キーを押します。

    Windows 2000 の場合は、"Windows を起動しています" というメッセージが表示されたら、F8 キーを押し、方向キーで [前回正常起動時の構成] を選択します。
  3. パラレル インストールを完了し、テープ バックアップからレジストリ ファイルを復元します。これを行うには、次の操作を実行します。
    • 別のフォルダに Windows を再インストールします。
    • 破損しているレジストリ ハイブをバックアップから復元します。この手順は、バックアップの作成に使用したバックアップ アプリケーションによって異なります。バックアップ アプリケーションのマニュアルを参照するか、支援が必要な場合はアプリケーション製造元に問い合わせてください。通常、この手順では、別の場所にシステム状態バックアップを復元し、その後、破損したオペレーティング システムの %SYSTEMROOT%\System32\config フォルダに適切なレジストリ ファイルをコピーする必要があります。
    • テープ バックアップがない場合は、ネットワーク サーバーおよび運用中のワークステーションのバックアップも考慮に入れてください。
    : Windows が FAT パーティションに格納されている場合は、別のコンピュータを使用し、レジストリ ハイブ ファイルを %SYSTEMROOT%\System32\Config サブフォルダにコピーすることによりファイルを復元することができます。

詳細

Stop エラー メッセージの原因がハードウェア障害 (ハード ディスク ドライブ上の不良セクタなど) である場合、ドライブの低レベル フォーマット、パーティションの再構成、再フォーマット、およびテープ バックアップからのシステム全体の復元を行って、問題を解消することが必要な場合があります。これは極端なケースですが、Stop エラー メッセージの原因が物理的な不良セクタにある場合は、低レベル フォーマットを実行することによって、問題のあるセクタを再配置する必要があります。

Microsoft Windows XP における同様の問題の関連情報を参照するには、以下の「サポート技術情報」 (Microsoft Knowledge Base) をクリックしてください。
307545? (http://support.microsoft.com/kb/307545/ ) レジストリの破損により Windows XP を起動できなくなった場合の回復方法

この資料は以下の製品について記述したものです。
  • Microsoft Windows 2000 Datacenter Server
  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows 2000 Professional
  • Microsoft Small Business Server 2000 Standard Edition
  • Microsoft Windows NT Workstation 3.5
  • Microsoft Windows NT Workstation 3.51
  • Microsoft Windows NT Workstation 4.0 Developer Edition
  • Microsoft Windows NT Server 3.5
  • Microsoft Windows NT Server 3.51
  • Microsoft Windows NT Server 4.0 Standard Edition
キーワード:?
kberrmsg kbhowto kbnetwork KB156640
"Microsoft Knowledge Baseに含まれている情報は、いかなる保証もない現状ベースで提供されるものです。Microsoft Corporation及びその関連会社は、市場性および特定の目的への適合性を含めて、明示的にも黙示的にも、一切の保証をいたしません。さらに、Microsoft Corporation及びその関連会社は、本文書に含まれている情報の使用及び使用結果につき、正確性、真実性等、いかなる表明・保証も行ないません。Microsoft Corporation、その関連会社及びこれらの権限ある代理人による口頭または書面による一切の情報提供またはアドバイスは、保証を意味するものではなく、かつ上記免責条項の範囲を狭めるものではありません。Microsoft Corporation、その関連会社 及びこれらの者の供給者は、直接的、間接的、偶発的、結果的損害、逸失利益、懲罰的損害、または特別損害を含む全ての損害に対して、状況のいかんを問わず一切責任を負いません。(Microsoft Corporation、その関連会社 またはこれらの者の供給者がかかる損害の発生可能性を了知している場合を含みます。) 結果的損害または偶発的損害に対する責任の免除または制限を認めていない地域においては、上記制限が適用されない場合があります。なお、本文書においては、文書の体裁上の都合により製品名の表記において商標登録表示、その他の商標表示を省略している場合がありますので、予めご了解ください。"