วิธีการแก้ไขข้อความแสดงข้อผิดพลาดที่ทำให้หยุดชะงัก 0xC0000218

การแปลบทความ การแปลบทความ
หมายเลขบทความ (Article ID): 156640 - ผลิตภัณฑ์ที่เกี่ยวข้องในบทความนี้
ขยายทั้งหมด | ยุบทั้งหมด

อาการ

คอมพิวเตอร์ที่ใช้ Windows แสดงข้อความแสดงข้อผิดพลาดที่ทำให้หยุดชะงักต่อไปนี้:
หยุดการ 0xc0000218 (0xe11a30e8, 0x00000000, 0x000000000, 0x00000000)
unknown_hard_error
หรือ
หยุด: 0xc0000218 {แฟ้มรีจิสทรีล้มเหลว}
รีจิสทรีไม่สามารถโหลดไฮฟ์ (แฟ้ม):
\SystemRoot\System32\Config\SYSTEM หรือการบันทึก หรือเลือกสำรอง
It is corrupt, absent, or not writable.
หมายเหตุ:: พารามิเตอร์ในวงเล็บจะใช้การตั้งค่าคอนฟิกระบบของคุณ และอาจแตกต่างกันในแต่ละครั้ง

สาเหตุ

ข้อความแสดงข้อผิดพลาด 0xc0000218 ที่ทำให้หยุดชะงักหมายความ ว่า ไม่สามารถโหลดแฟ้มกลุ่มรีจิสทรีที่จำเป็น ข้อความแสดงข้อผิดพลาดนี้อาจเกิดขึ้นหากแฟ้มเสียหาย หรือสูญหาย เมื่อต้องการแก้ไขปัญหานี้ คุณสามารถติดตั้งระบบปฏิบัติการ และการคืนค่าแฟ้มรีจิสทรีจากการสำรองข้อมูล แฟ้มรีจิสทรีอาจได้รับเสียเนื่องจากความเสียหายของฮาร์ดดิสก์หรือบางปัญหาฮาร์ดแวร์อื่น ๆ

ข้อความแสดงข้อผิดพลาดนี้อาจเกิดขึ้นได้เช่นกันถ้าโปรแกรมควบคุมที่มีเสียข้อมูลรีจิสทรีในขณะกำลังโหลดลงในหน่วยความจำ หรือหน่วยความจำที่การโหลดรีจิสทรีได้ข้อผิดพลาดของพาริตี ในกรณี latter ปิดใช้งานแคภายนอก และทำการตรวจสอบ chips หน่วยความจำ

การแก้ไข

เมื่อต้องการแก้ปัญหานี้ ให้ทำตามขั้นตอนต่อไปนี้:
  1. เริ่มการทำงานของคอมพิวเตอร์ของคุณ โดยใช้คอนโซลการกู้คืน ทำการchkdsk /pคำสั่งบนไดรฟ์ แล้ว รีสตาร์ทเครื่องคอมพิวเตอร์ของคุณ ทดสอบเพื่อดูว่าปัญหาได้รับการแก้ไขหรือไม่ หากปัญหาหมดไป คุณไม่ต้องดำเนินการในขั้นตอนถัดจากนี้ ถ้ามีการแก้ปัญหาไม่ได้ ไปขั้นตอนที่ 2
  2. เมื่อ Windows โหลด กด SPACE BAR เมื่อข้อความ "การโหลดล่าสุดทราบดี" ปรากฏขึ้น
  3. ดำเนินการติดตั้งแบบขนาน และการคืนค่าแฟ้มรีจิสทรีจากเทปสำรองข้อมูล โดย::
    • ติดตั้ง Windows ในโฟลเดอร์ที่แยกต่างหาก
    • คืนค่ากลุ่มรีจิสทรีที่เสียหายจากการสำรองข้อมูล ขั้นตอนนี้จะระบุไปยังโปรแกรมประยุกต์การสำรองข้อมูลที่คุณใช้การสำรองข้อมูล คู่มือของโปรแกรมประยุกต์ที่มีการสำรองข้อมูลของคุณ หรือดูผู้ขายถ้าคุณต้องการให้ความช่วยเหลือ โดยทั่วไป กระบวนการนี้ต้อง การคืนค่าการสำรองข้อมูลสถานะระบบไปยังตำแหน่งอื่น แล้ว คัดลอกแฟ้มรีจิสทรีที่เหมาะสมไปยังโฟลเดอร์ %SYSTEMROOT%\System32\config ของระบบปฏิบัติการเสียหายคุณ
    • ถ้าคุณไม่มีเทปสำรองข้อมูล รวมถึงการสำรองข้อมูลของเครือข่ายเซิร์ฟเวอร์และเวิร์กสเตชันของการผลิต
    หมายเหตุ:: ถ้า Windows ถูกเก็บอยู่บนพาร์ติชัน FAT คุณสามารถคืนค่าแฟ้ม โดยใช้คอมพิวเตอร์เครื่องอื่น และ โดยการคัดลอกแฟ้มกลุ่มรีจิสทรีไปยังโฟลเดอร์ย่อยของ %SYSTEMROOT%\System32\Config

ข้อมูลเพิ่มเติม

ถ้าข้อความแสดงข้อผิดพลาดที่ทำให้หยุดชะงักถูกเกิดจากปัญหาฮาร์ดแวร์ (ตัวอย่าง กเตอร์บนฮาร์ดไดรฟ์), ไดรฟ์อาจจำเป็นต้องมีรูปแบบระดับต่ำ repartition, reformat และคืนค่าของระบบทั้งหมดจากเทปสำรองข้อมูลเพื่อยกเลิกเลือกอัพปัญหา แม้ว่าข้อมูลนี้จะกรณี drastic มากที่สุด ถ้าข้อความแสดงข้อผิดพลาดที่ทำให้หยุดชะงักถูกเกิดจากเซกเตอร์ที่เสียทางกายภาพ เซกเตอร์ต้องถูก relocated ด้วยรูปแบบระดับต่ำ

สำหรับข้อมูลเพิ่มเติมเกี่ยวกับปัญหาที่คล้ายกันที่เกิดขึ้นใน Windows XP คลิกหมายเลขบทความต่อไปนี้เพื่อดูบทความในฐานความรู้ของ Microsoft:
307545วิธีการกู้คืนจากรีจิสทรีที่เสียหายซึ่งขัดขวางไม่ให้ Windows XP เริ่มทำงานได้

คุณสมบัติ

หมายเลขบทความ (Article ID): 156640 - รีวิวครั้งสุดท้าย: 6 มกราคม 2554 - Revision: 4.0
ใช้กับ
  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows 2000 Professional Edition
  • Microsoft Small Business Server 2000 Standard Edition
  • Microsoft Windows NT Workstation 3.5
  • Microsoft Windows NT Workstation 3.51
  • Microsoft Windows NT Workstation 4.0 Developer Edition
  • Microsoft Windows NT Server 3.51
  • Microsoft Windows NT Server 4.0 Standard Edition
Keywords: 
kberrmsg kbhowto kbnetwork kbmt KB156640 KbMtth
แปลโดยคอมพิวเตอร์
ข้อมูลสำคัญ: บทความนี้แปลโดยซอฟต์แวร์การแปลด้วยคอมพิวเตอร์ของ Microsoft แทนที่จะเป็นนักแปลที่เป็นบุคคล Microsoft มีบทความที่แปลโดยนักแปลและบทความที่แปลด้วยคอมพิวเตอร์ เพื่อให้คุณสามารถเข้าถึงบทความทั้งหมดในฐานความรู้ของเรา ในภาษาของคุณเอง อย่างไรก็ตาม บทความที่แปลด้วยคอมพิวเตอร์นั้นอาจมีข้อบกพร่อง โดยอาจมีข้อผิดพลาดในคำศัพท์ รูปแบบการใช้ภาษาและไวยากรณ์ เช่นเดียวกับกรณีที่ชาวต่างชาติพูดผิดเมื่อพูดภาษาของคุณ Microsoft ไม่มีส่วนรับผิดชอบต่อความคลาดเคลื่อน ความผิดพลาดหรือความเสียหายที่เกิดจากการแปลเนื้อหาผิดพลาด หรือการใช้บทแปลของลูกค้า และ Microsoft มีการปรับปรุงซอฟต์แวร์การแปลด้วยคอมพิวเตอร์อยู่เป็นประจำ
ต่อไปนี้เป็นฉบับภาษาอังกฤษของบทความนี้:156640

ให้ข้อเสนอแนะ

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com