Fehler "<Datenbank-Name> ist kein Index in dieser Tabelle"

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Dieser Artikel ist eine Übersetzung des folgenden englischsprachigen Artikels der Microsoft Knowledge Base:
158933 ACC95: Error "<Database Name> Isn't an Index in This Table"
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Problembeschreibung

Wenn Sie den "Datenbank reparieren"-Befehl ausführen, tritt möglicherweise die folgende Fehlermeldung auf:
   "<Datenbank-Name> ist kein Index in dieser Tabelle"
Anmerkung: Dieses Problem kann auch in Access 97 mit Datenbanken auftreten, die aus Access 7.0 konvertiert wurden. Wenn dies passiert, sollten Sie entweder:
  • eine neue Datenbank in Access 97 erstellen und alle Objekte aus der letzten Sicherungskopie der Access 7.0-Datenbank importieren
    -oder-
  • die Hilfsdatei Jetcomp.exe zum Komprimieren der Datenbank verwenden.

Ursache

Die Systemtabelle MSysObjects ist beschädigt.

Lösung

Wenn diese Fehlermeldung auftritt, ist die Datenbank so zerstört, daß Sie nicht mehr repariert werden kann. Das Datenbank-Reparatur-Tool kann die Datei nicht wiederherstellen. Die einzige Lösung besteht im Rückgriff auf eine Sicherungskopie der Datenbank.

Um diesem Fehler in Zukunft vorzubeugen, installieren Sie bitte das Update der jeweiligen Jet Engine mit dem verbesserten Reparatur Tool von der Microsoft Software Library (MSL).

Für Access 95 laden Sie bitte die Datei Msjtwng.exe herunter. Eine nähere Beschreibung finden Sie im folgenden Knowledge Base-Artikel:
   ARTIKEL-ID: Q151186
   TITEL     : ACC95: Updated Jet DLLs Available on MSL
Für Access 97 laden Sie bitte die Datei Jet35upd.exe herunter. Eine nähere Beschreibung finden Sie im folgenden Knowledge Base-Artikel:
   ARTIKEL-ID: Q172733
   TITEL     : ACC97: Updated Version of
               Microsoft Jet 3.5 Available on MSL

Status

Microsoft hat bestätigt, daß es sich hierbei um ein Problem in der Microsoft-Jet-Database-Engine in der Version 3.0 handelt. Wir untersuchen dieses Problem weiterhin und werden neue Informationen, sofern verfügbar, in der Microsoft Knowledge Base veröffentlichen.

Zusätzliche Informationen:
Jede Access-Datenbank enthält System-Tabellen, die Informationen über die verschiedenen Objekte dieser Datenbank speichert. Die Microsoft-Jet-Database-Engine erstellt automatisch die Systemtabellen wie zum Beispiel MSysObjects, wenn Sie eine neue Datenbank erstellen. Wenn die MsysObjects-Tabelle ohne Reparaturmöglichkeit zerstört wurde, ist die Datenbank unbrauchbar und läßt sich nicht mehr öffnen.

Dem beschriebenen Fehler gehen normalerweise Anzeichen voraus, die auf Probleme in der Datenbank hinweisen:
  • doppelte Tabellennamen erscheinen in der Datenbank,
  • beim Zugriff auf Tabellen erscheint die Meldung, daß Sie keine Berechtigung zum Löschen haben, obwohl Sie Administrator-Rechte in der betreffenden Datenbank haben
  • Tabellen haben den Eigentümer <Unbekannt> oder Engine
Wenn diese Symptome in Ihrer Datenbank auftreten, gehen Sie bitte folgendermaßen vor:
  1. Erstellen Sie eine Sicherungskopie der Datenbank
  2. Führen Sie den Befehl "Datenbank komprimieren" aus
  3. Führen Sie den Befehl "Datenbank reparieren" aus
  4. Importieren Sie die unversehrten Objekte in eine neue Datenbank
Weitere Hinweise:
Weitere Informationen zum Reparieren einer Datenbank lesen Sie bitte folgenden Artikel in der Microsoft Knowledge Base:
109953 ACC: How to Repair a Damaged Database

Weitere Informationen zur Verwendung des Befehls "Datenbank komprimieren" finden Sie in der Online-Hilfe im Index unter "Datenbanken komprimieren".

Oben angegebene Artikel und MSL-Dateien finden Sie unter folgenden Internet-Adressen:

englischsprachig (Einmalige Eingabe von persönlichen Daten erforderlich):
   http://support.microsoft.com/support/default.asp
deutschsprachig:
   http://www.microsoft.com/germany/support/kb/default.asp
MSL:
   ftp://ftp.microsoft.com/softlib/mslfiles
Bitte beachten Sie: Bei diesem Artikel handelt es sich um eine Übersetzung aus dem Englischen. Es ist möglich, daß nachträgliche Änderungen bzw. Ergänzungen im englischen Originalartikel in dieser Übersetzung nicht berücksichtigt sind. Die in diesem Artikel enthaltenen Informationen basieren auf der/den englischsprachige(n) Produktversion(en). Die Richtigkeit dieser Informationen in Zusammenhang mit anderssprachigen Produktversionen wurde im Rahmen dieser Übersetzung nicht getestet. Microsoft stellt diese Informationen ohne Gewähr für Richtigkeit bzw. Funktionalität zur Verfügung und übernimmt auch keine Gewährleistung bezüglich der Vollständigkeit oder Richtigkeit der Übersetzung.

Eigenschaften

Artikel-ID: 158933 - Geändert am: Freitag, 9. Januar 2004 - Version: 4.0
Die Informationen in diesem Artikel beziehen sich auf:
  • Microsoft Access 95 Standard Edition
  • Microsoft Access 97 Standard Edition
Keywords: 
kberrmsg KB158933
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