Un archivo de no ser eliminado o acceso en un volumen NTFS

Seleccione idioma Seleccione idioma
Id. de artículo: 159199 - Ver los productos a los que se aplica este artículo
Expandir todo | Contraer todo

Síntomas

No se eliminado o tener acceso a un archivo o directorio en un volumen NTFS. Windows devuelve un mensaje de error "Access Denied" cuando intenta manipular el archivo. No es capaz de ver los permisos, el propietario o el contenido del archivo. El archivo existe, sin embargo, aparecen en una lista de DIR en el Administrador de archivos y en el explorador. Esto ocurre aunque el usuario intenta tener acceso al archivo tenga permisos en el archivo. Incluso un administrador podrá tomar posesión de este archivo.

Causa

Hay dos causas:
  • Este archivo está en un estado conocido como pendiente de eliminación. Se ha eliminado este archivo pero todavía hay controladores abiertos a él. NTFS esperará hasta que se cierran todos los controladores para este archivo antes de actualizar el índice. Sin embargo, si intenta tener acceso al archivo, NTFS denegará el intento. Porque el archivo aparece en el índice, pero es eficazmente que se elimina, se puede ver el archivo pero no puede tener acceso a él.
  • El archivo dañado.

Solución

Los siguientes son las resoluciones de las causas anteriores, respectivamente:
  • Esto es así por diseño. Espere simplemente de todos los controladores para este archivo se cierra y el archivo se quitará el índice. Si es un directorio se encuentra en este estado, asegúrese de que este directorio no tiene un recurso compartido asociado con él o cualquier directorio por debajo de él en el árbol de. Reiniciar el equipo siempre hará que el archivo desaparecen, ya que se cerrarán todos los controladores durante el cierre.
  • Ejecute CHKDSK /F en el volumen que contiene el archivo.

Propiedades

Id. de artículo: 159199 - Última revisión: martes, 20 de febrero de 2007 - Versión: 2.1
La información de este artículo se refiere a:
  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows 2000 Professional Edition
  • Microsoft Windows NT Workstation 3.5
  • Microsoft Windows NT Workstation 3.51
  • Microsoft Windows NT Workstation 4.0 Developer Edition
  • Microsoft Windows NT Server 3.5
  • Microsoft Windows NT Server 3.51
  • Microsoft Windows NT Server 4.0 Standard Edition
Palabras clave: 
kbmt kbother KB159199 KbMtes
Traducción automática
IMPORTANTE: Este artículo ha sido traducido por un software de traducción automática de Microsoft (http://support.microsoft.com/gp/mtdetails) en lugar de un traductor humano. Microsoft le ofrece artículos traducidos por un traductor humano y artículos traducidos automáticamente para que tenga acceso en su propio idioma a todos los artículos de nuestra base de conocimientos (Knowledge Base). Sin embargo, los artículos traducidos automáticamente pueden contener errores en el vocabulario, la sintaxis o la gramática, como los que un extranjero podría cometer al hablar el idioma. Microsoft no se hace responsable de cualquier imprecisión, error o daño ocasionado por una mala traducción del contenido o como consecuencia de su utilización por nuestros clientes. Microsoft suele actualizar el software de traducción frecuentemente.
Haga clic aquí para ver el artículo original (en inglés): 159199

Enviar comentarios

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com